Upstream information

CVE-2016-10397 at MITRE

Description

In PHP before 5.6.28 and 7.x before 7.0.13, incorrect handling of various URI components in the URL parser could be used by attackers to bypass hostname-specific URL checks, as demonstrated by evil.example.com:80#@good.example.com/ and evil.example.com:80?@good.example.com/ inputs to the parse_url function (implemented in the php_url_parse_ex function in ext/standard/url.c).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 5.8
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact High Low
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1047454 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • php53-devel >= 5.3.17-112.5.1
  • php53-imap >= 5.3.17-112.5.1
  • php53-posix >= 5.3.17-112.5.1
  • php53-readline >= 5.3.17-112.5.1
  • php53-sockets >= 5.3.17-112.5.1
  • php53-sqlite >= 5.3.17-112.5.1
  • php53-tidy >= 5.3.17-112.5.1
Patchnames:
sdksp4-php53-13282
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • php5-devel >= 5.5.14-109.5.1
  • php7-devel >= 7.0.7-50.9.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1417
SUSE-SLE-SDK-12-SP2-2017-1431
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • php5-devel >= 5.5.14-109.5.1
  • php7-devel >= 7.0.7-50.9.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1417
SUSE-SLE-SDK-12-SP3-2017-1431
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • php5-devel >= 5.5.14-109.41.1
  • php7-devel >= 7.0.7-50.52.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php5-devel-5.5.14-109.41.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php7-devel-7.0.7-50.52.1
SUSE Linux Enterprise High Performance Computing 12
SUSE Linux Enterprise Module for Web and Scripting 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • apache2-mod_php5 >= 5.5.14-109.5.1
  • apache2-mod_php7 >= 7.0.7-50.9.2
  • php5 >= 5.5.14-109.5.1
  • php5-bcmath >= 5.5.14-109.5.1
  • php5-bz2 >= 5.5.14-109.5.1
  • php5-calendar >= 5.5.14-109.5.1
  • php5-ctype >= 5.5.14-109.5.1
  • php5-curl >= 5.5.14-109.5.1
  • php5-dba >= 5.5.14-109.5.1
  • php5-dom >= 5.5.14-109.5.1
  • php5-enchant >= 5.5.14-109.5.1
  • php5-exif >= 5.5.14-109.5.1
  • php5-fastcgi >= 5.5.14-109.5.1
  • php5-fileinfo >= 5.5.14-109.5.1
  • php5-fpm >= 5.5.14-109.5.1
  • php5-ftp >= 5.5.14-109.5.1
  • php5-gd >= 5.5.14-109.5.1
  • php5-gettext >= 5.5.14-109.5.1
  • php5-gmp >= 5.5.14-109.5.1
  • php5-iconv >= 5.5.14-109.5.1
  • php5-imap >= 5.5.14-109.5.1
  • php5-intl >= 5.5.14-109.5.1
  • php5-json >= 5.5.14-109.5.1
  • php5-ldap >= 5.5.14-109.5.1
  • php5-mbstring >= 5.5.14-109.5.1
  • php5-mcrypt >= 5.5.14-109.5.1
  • php5-mysql >= 5.5.14-109.5.1
  • php5-odbc >= 5.5.14-109.5.1
  • php5-opcache >= 5.5.14-109.5.1
  • php5-openssl >= 5.5.14-109.5.1
  • php5-pcntl >= 5.5.14-109.5.1
  • php5-pdo >= 5.5.14-109.5.1
  • php5-pear >= 5.5.14-109.5.1
  • php5-pgsql >= 5.5.14-109.5.1
  • php5-phar >= 5.5.14-109.5.1
  • php5-posix >= 5.5.14-109.5.1
  • php5-pspell >= 5.5.14-109.5.1
  • php5-shmop >= 5.5.14-109.5.1
  • php5-snmp >= 5.5.14-109.5.1
  • php5-soap >= 5.5.14-109.5.1
  • php5-sockets >= 5.5.14-109.5.1
  • php5-sqlite >= 5.5.14-109.5.1
  • php5-suhosin >= 5.5.14-109.5.1
  • php5-sysvmsg >= 5.5.14-109.5.1
  • php5-sysvsem >= 5.5.14-109.5.1
  • php5-sysvshm >= 5.5.14-109.5.1
  • php5-tokenizer >= 5.5.14-109.5.1
  • php5-wddx >= 5.5.14-109.5.1
  • php5-xmlreader >= 5.5.14-109.5.1
  • php5-xmlrpc >= 5.5.14-109.5.1
  • php5-xmlwriter >= 5.5.14-109.5.1
  • php5-xsl >= 5.5.14-109.5.1
  • php5-zip >= 5.5.14-109.5.1
  • php5-zlib >= 5.5.14-109.5.1
  • php7 >= 7.0.7-50.9.2
  • php7-bcmath >= 7.0.7-50.9.2
  • php7-bz2 >= 7.0.7-50.9.2
  • php7-calendar >= 7.0.7-50.9.2
  • php7-ctype >= 7.0.7-50.9.2
  • php7-curl >= 7.0.7-50.9.2
  • php7-dba >= 7.0.7-50.9.2
  • php7-dom >= 7.0.7-50.9.2
  • php7-enchant >= 7.0.7-50.9.2
  • php7-exif >= 7.0.7-50.9.2
  • php7-fastcgi >= 7.0.7-50.9.2
  • php7-fileinfo >= 7.0.7-50.9.2
  • php7-fpm >= 7.0.7-50.9.2
  • php7-ftp >= 7.0.7-50.9.2
  • php7-gd >= 7.0.7-50.9.2
  • php7-gettext >= 7.0.7-50.9.2
  • php7-gmp >= 7.0.7-50.9.2
  • php7-iconv >= 7.0.7-50.9.2
  • php7-imap >= 7.0.7-50.9.2
  • php7-intl >= 7.0.7-50.9.2
  • php7-json >= 7.0.7-50.9.2
  • php7-ldap >= 7.0.7-50.9.2
  • php7-mbstring >= 7.0.7-50.9.2
  • php7-mcrypt >= 7.0.7-50.9.2
  • php7-mysql >= 7.0.7-50.9.2
  • php7-odbc >= 7.0.7-50.9.2
  • php7-opcache >= 7.0.7-50.9.2
  • php7-openssl >= 7.0.7-50.9.2
  • php7-pcntl >= 7.0.7-50.9.2
  • php7-pdo >= 7.0.7-50.9.2
  • php7-pear >= 7.0.7-50.9.2
  • php7-pear-Archive_Tar >= 7.0.7-50.9.2
  • php7-pgsql >= 7.0.7-50.9.2
  • php7-phar >= 7.0.7-50.9.2
  • php7-posix >= 7.0.7-50.9.2
  • php7-pspell >= 7.0.7-50.9.2
  • php7-shmop >= 7.0.7-50.9.2
  • php7-snmp >= 7.0.7-50.9.2
  • php7-soap >= 7.0.7-50.9.2
  • php7-sockets >= 7.0.7-50.9.2
  • php7-sqlite >= 7.0.7-50.9.2
  • php7-sysvmsg >= 7.0.7-50.9.2
  • php7-sysvsem >= 7.0.7-50.9.2
  • php7-sysvshm >= 7.0.7-50.9.2
  • php7-tokenizer >= 7.0.7-50.9.2
  • php7-wddx >= 7.0.7-50.9.2
  • php7-xmlreader >= 7.0.7-50.9.2
  • php7-xmlrpc >= 7.0.7-50.9.2
  • php7-xmlwriter >= 7.0.7-50.9.2
  • php7-xsl >= 7.0.7-50.9.2
  • php7-zip >= 7.0.7-50.9.2
  • php7-zlib >= 7.0.7-50.9.2
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2017-1417
SUSE-SLE-Module-Web-Scripting-12-2017-1431
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • apache2-mod_php53 >= 5.3.17-112.5.1
  • php53 >= 5.3.17-112.5.1
  • php53-bcmath >= 5.3.17-112.5.1
  • php53-bz2 >= 5.3.17-112.5.1
  • php53-calendar >= 5.3.17-112.5.1
  • php53-ctype >= 5.3.17-112.5.1
  • php53-curl >= 5.3.17-112.5.1
  • php53-dba >= 5.3.17-112.5.1
  • php53-devel >= 5.3.17-112.5.1
  • php53-dom >= 5.3.17-112.5.1
  • php53-exif >= 5.3.17-112.5.1
  • php53-fastcgi >= 5.3.17-112.5.1
  • php53-fileinfo >= 5.3.17-112.5.1
  • php53-ftp >= 5.3.17-112.5.1
  • php53-gd >= 5.3.17-112.5.1
  • php53-gettext >= 5.3.17-112.5.1
  • php53-gmp >= 5.3.17-112.5.1
  • php53-iconv >= 5.3.17-112.5.1
  • php53-imap >= 5.3.17-112.5.1
  • php53-intl >= 5.3.17-112.5.1
  • php53-json >= 5.3.17-112.5.1
  • php53-ldap >= 5.3.17-112.5.1
  • php53-mbstring >= 5.3.17-112.5.1
  • php53-mcrypt >= 5.3.17-112.5.1
  • php53-mysql >= 5.3.17-112.5.1
  • php53-odbc >= 5.3.17-112.5.1
  • php53-openssl >= 5.3.17-112.5.1
  • php53-pcntl >= 5.3.17-112.5.1
  • php53-pdo >= 5.3.17-112.5.1
  • php53-pear >= 5.3.17-112.5.1
  • php53-pgsql >= 5.3.17-112.5.1
  • php53-posix >= 5.3.17-112.5.1
  • php53-pspell >= 5.3.17-112.5.1
  • php53-readline >= 5.3.17-112.5.1
  • php53-shmop >= 5.3.17-112.5.1
  • php53-snmp >= 5.3.17-112.5.1
  • php53-soap >= 5.3.17-112.5.1
  • php53-sockets >= 5.3.17-112.5.1
  • php53-sqlite >= 5.3.17-112.5.1
  • php53-suhosin >= 5.3.17-112.5.1
  • php53-sysvmsg >= 5.3.17-112.5.1
  • php53-sysvsem >= 5.3.17-112.5.1
  • php53-sysvshm >= 5.3.17-112.5.1
  • php53-tidy >= 5.3.17-112.5.1
  • php53-tokenizer >= 5.3.17-112.5.1
  • php53-wddx >= 5.3.17-112.5.1
  • php53-xmlreader >= 5.3.17-112.5.1
  • php53-xmlrpc >= 5.3.17-112.5.1
  • php53-xmlwriter >= 5.3.17-112.5.1
  • php53-xsl >= 5.3.17-112.5.1
  • php53-zip >= 5.3.17-112.5.1
  • php53-zlib >= 5.3.17-112.5.1
Patchnames:
sdksp4-php53-13282
slessp4-php53-13282
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • apache2-mod_php5 >= 5.5.14-109.5.1
  • apache2-mod_php7 >= 7.0.7-50.9.2
  • php5 >= 5.5.14-109.5.1
  • php5-bcmath >= 5.5.14-109.5.1
  • php5-bz2 >= 5.5.14-109.5.1
  • php5-calendar >= 5.5.14-109.5.1
  • php5-ctype >= 5.5.14-109.5.1
  • php5-curl >= 5.5.14-109.5.1
  • php5-dba >= 5.5.14-109.5.1
  • php5-devel >= 5.5.14-109.5.1
  • php5-dom >= 5.5.14-109.5.1
  • php5-enchant >= 5.5.14-109.5.1
  • php5-exif >= 5.5.14-109.5.1
  • php5-fastcgi >= 5.5.14-109.5.1
  • php5-fileinfo >= 5.5.14-109.5.1
  • php5-fpm >= 5.5.14-109.5.1
  • php5-ftp >= 5.5.14-109.5.1
  • php5-gd >= 5.5.14-109.5.1
  • php5-gettext >= 5.5.14-109.5.1
  • php5-gmp >= 5.5.14-109.5.1
  • php5-iconv >= 5.5.14-109.5.1
  • php5-imap >= 5.5.14-109.5.1
  • php5-intl >= 5.5.14-109.5.1
  • php5-json >= 5.5.14-109.5.1
  • php5-ldap >= 5.5.14-109.5.1
  • php5-mbstring >= 5.5.14-109.5.1
  • php5-mcrypt >= 5.5.14-109.5.1
  • php5-mysql >= 5.5.14-109.5.1
  • php5-odbc >= 5.5.14-109.5.1
  • php5-opcache >= 5.5.14-109.5.1
  • php5-openssl >= 5.5.14-109.5.1
  • php5-pcntl >= 5.5.14-109.5.1
  • php5-pdo >= 5.5.14-109.5.1
  • php5-pear >= 5.5.14-109.5.1
  • php5-pgsql >= 5.5.14-109.5.1
  • php5-phar >= 5.5.14-109.5.1
  • php5-posix >= 5.5.14-109.5.1
  • php5-pspell >= 5.5.14-109.5.1
  • php5-shmop >= 5.5.14-109.5.1
  • php5-snmp >= 5.5.14-109.5.1
  • php5-soap >= 5.5.14-109.5.1
  • php5-sockets >= 5.5.14-109.5.1
  • php5-sqlite >= 5.5.14-109.5.1
  • php5-suhosin >= 5.5.14-109.5.1
  • php5-sysvmsg >= 5.5.14-109.5.1
  • php5-sysvsem >= 5.5.14-109.5.1
  • php5-sysvshm >= 5.5.14-109.5.1
  • php5-tokenizer >= 5.5.14-109.5.1
  • php5-wddx >= 5.5.14-109.5.1
  • php5-xmlreader >= 5.5.14-109.5.1
  • php5-xmlrpc >= 5.5.14-109.5.1
  • php5-xmlwriter >= 5.5.14-109.5.1
  • php5-xsl >= 5.5.14-109.5.1
  • php5-zip >= 5.5.14-109.5.1
  • php5-zlib >= 5.5.14-109.5.1
  • php7 >= 7.0.7-50.9.2
  • php7-bcmath >= 7.0.7-50.9.2
  • php7-bz2 >= 7.0.7-50.9.2
  • php7-calendar >= 7.0.7-50.9.2
  • php7-ctype >= 7.0.7-50.9.2
  • php7-curl >= 7.0.7-50.9.2
  • php7-dba >= 7.0.7-50.9.2
  • php7-devel >= 7.0.7-50.9.2
  • php7-dom >= 7.0.7-50.9.2
  • php7-enchant >= 7.0.7-50.9.2
  • php7-exif >= 7.0.7-50.9.2
  • php7-fastcgi >= 7.0.7-50.9.2
  • php7-fileinfo >= 7.0.7-50.9.2
  • php7-fpm >= 7.0.7-50.9.2
  • php7-ftp >= 7.0.7-50.9.2
  • php7-gd >= 7.0.7-50.9.2
  • php7-gettext >= 7.0.7-50.9.2
  • php7-gmp >= 7.0.7-50.9.2
  • php7-iconv >= 7.0.7-50.9.2
  • php7-imap >= 7.0.7-50.9.2
  • php7-intl >= 7.0.7-50.9.2
  • php7-json >= 7.0.7-50.9.2
  • php7-ldap >= 7.0.7-50.9.2
  • php7-mbstring >= 7.0.7-50.9.2
  • php7-mcrypt >= 7.0.7-50.9.2
  • php7-mysql >= 7.0.7-50.9.2
  • php7-odbc >= 7.0.7-50.9.2
  • php7-opcache >= 7.0.7-50.9.2
  • php7-openssl >= 7.0.7-50.9.2
  • php7-pcntl >= 7.0.7-50.9.2
  • php7-pdo >= 7.0.7-50.9.2
  • php7-pear >= 7.0.7-50.9.2
  • php7-pear-Archive_Tar >= 7.0.7-50.9.2
  • php7-pgsql >= 7.0.7-50.9.2
  • php7-phar >= 7.0.7-50.9.2
  • php7-posix >= 7.0.7-50.9.2
  • php7-pspell >= 7.0.7-50.9.2
  • php7-shmop >= 7.0.7-50.9.2
  • php7-snmp >= 7.0.7-50.9.2
  • php7-soap >= 7.0.7-50.9.2
  • php7-sockets >= 7.0.7-50.9.2
  • php7-sqlite >= 7.0.7-50.9.2
  • php7-sysvmsg >= 7.0.7-50.9.2
  • php7-sysvsem >= 7.0.7-50.9.2
  • php7-sysvshm >= 7.0.7-50.9.2
  • php7-tokenizer >= 7.0.7-50.9.2
  • php7-wddx >= 7.0.7-50.9.2
  • php7-xmlreader >= 7.0.7-50.9.2
  • php7-xmlrpc >= 7.0.7-50.9.2
  • php7-xmlwriter >= 7.0.7-50.9.2
  • php7-xsl >= 7.0.7-50.9.2
  • php7-zip >= 7.0.7-50.9.2
  • php7-zlib >= 7.0.7-50.9.2
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2017-1417
SUSE-SLE-Module-Web-Scripting-12-2017-1431
SUSE-SLE-SDK-12-SP3-2017-1417
SUSE-SLE-SDK-12-SP3-2017-1431
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • apache2-mod_php5 >= 5.5.14-109.5.1
  • apache2-mod_php7 >= 7.0.7-50.9.2
  • php5 >= 5.5.14-109.5.1
  • php5-bcmath >= 5.5.14-109.5.1
  • php5-bz2 >= 5.5.14-109.5.1
  • php5-calendar >= 5.5.14-109.5.1
  • php5-ctype >= 5.5.14-109.5.1
  • php5-curl >= 5.5.14-109.5.1
  • php5-dba >= 5.5.14-109.5.1
  • php5-devel >= 5.5.14-109.41.1
  • php5-dom >= 5.5.14-109.5.1
  • php5-enchant >= 5.5.14-109.5.1
  • php5-exif >= 5.5.14-109.5.1
  • php5-fastcgi >= 5.5.14-109.5.1
  • php5-fileinfo >= 5.5.14-109.5.1
  • php5-fpm >= 5.5.14-109.5.1
  • php5-ftp >= 5.5.14-109.5.1
  • php5-gd >= 5.5.14-109.5.1
  • php5-gettext >= 5.5.14-109.5.1
  • php5-gmp >= 5.5.14-109.5.1
  • php5-iconv >= 5.5.14-109.5.1
  • php5-imap >= 5.5.14-109.5.1
  • php5-intl >= 5.5.14-109.5.1
  • php5-json >= 5.5.14-109.5.1
  • php5-ldap >= 5.5.14-109.5.1
  • php5-mbstring >= 5.5.14-109.5.1
  • php5-mcrypt >= 5.5.14-109.5.1
  • php5-mysql >= 5.5.14-109.5.1
  • php5-odbc >= 5.5.14-109.5.1
  • php5-opcache >= 5.5.14-109.5.1
  • php5-openssl >= 5.5.14-109.5.1
  • php5-pcntl >= 5.5.14-109.5.1
  • php5-pdo >= 5.5.14-109.5.1
  • php5-pear >= 5.5.14-109.5.1
  • php5-pgsql >= 5.5.14-109.5.1
  • php5-phar >= 5.5.14-109.5.1
  • php5-posix >= 5.5.14-109.5.1
  • php5-pspell >= 5.5.14-109.5.1
  • php5-shmop >= 5.5.14-109.5.1
  • php5-snmp >= 5.5.14-109.5.1
  • php5-soap >= 5.5.14-109.5.1
  • php5-sockets >= 5.5.14-109.5.1
  • php5-sqlite >= 5.5.14-109.5.1
  • php5-suhosin >= 5.5.14-109.5.1
  • php5-sysvmsg >= 5.5.14-109.5.1
  • php5-sysvsem >= 5.5.14-109.5.1
  • php5-sysvshm >= 5.5.14-109.5.1
  • php5-tokenizer >= 5.5.14-109.5.1
  • php5-wddx >= 5.5.14-109.5.1
  • php5-xmlreader >= 5.5.14-109.5.1
  • php5-xmlrpc >= 5.5.14-109.5.1
  • php5-xmlwriter >= 5.5.14-109.5.1
  • php5-xsl >= 5.5.14-109.5.1
  • php5-zip >= 5.5.14-109.5.1
  • php5-zlib >= 5.5.14-109.5.1
  • php7 >= 7.0.7-50.9.2
  • php7-bcmath >= 7.0.7-50.9.2
  • php7-bz2 >= 7.0.7-50.9.2
  • php7-calendar >= 7.0.7-50.9.2
  • php7-ctype >= 7.0.7-50.9.2
  • php7-curl >= 7.0.7-50.9.2
  • php7-dba >= 7.0.7-50.9.2
  • php7-devel >= 7.0.7-50.52.1
  • php7-dom >= 7.0.7-50.9.2
  • php7-enchant >= 7.0.7-50.9.2
  • php7-exif >= 7.0.7-50.9.2
  • php7-fastcgi >= 7.0.7-50.9.2
  • php7-fileinfo >= 7.0.7-50.9.2
  • php7-fpm >= 7.0.7-50.9.2
  • php7-ftp >= 7.0.7-50.9.2
  • php7-gd >= 7.0.7-50.9.2
  • php7-gettext >= 7.0.7-50.9.2
  • php7-gmp >= 7.0.7-50.9.2
  • php7-iconv >= 7.0.7-50.9.2
  • php7-imap >= 7.0.7-50.9.2
  • php7-intl >= 7.0.7-50.9.2
  • php7-json >= 7.0.7-50.9.2
  • php7-ldap >= 7.0.7-50.9.2
  • php7-mbstring >= 7.0.7-50.9.2
  • php7-mcrypt >= 7.0.7-50.9.2
  • php7-mysql >= 7.0.7-50.9.2
  • php7-odbc >= 7.0.7-50.9.2
  • php7-opcache >= 7.0.7-50.9.2
  • php7-openssl >= 7.0.7-50.9.2
  • php7-pcntl >= 7.0.7-50.9.2
  • php7-pdo >= 7.0.7-50.9.2
  • php7-pear >= 7.0.7-50.9.2
  • php7-pear-Archive_Tar >= 7.0.7-50.9.2
  • php7-pgsql >= 7.0.7-50.9.2
  • php7-phar >= 7.0.7-50.9.2
  • php7-posix >= 7.0.7-50.9.2
  • php7-pspell >= 7.0.7-50.9.2
  • php7-shmop >= 7.0.7-50.9.2
  • php7-snmp >= 7.0.7-50.9.2
  • php7-soap >= 7.0.7-50.9.2
  • php7-sockets >= 7.0.7-50.9.2
  • php7-sqlite >= 7.0.7-50.9.2
  • php7-sysvmsg >= 7.0.7-50.9.2
  • php7-sysvsem >= 7.0.7-50.9.2
  • php7-sysvshm >= 7.0.7-50.9.2
  • php7-tokenizer >= 7.0.7-50.9.2
  • php7-wddx >= 7.0.7-50.9.2
  • php7-xmlreader >= 7.0.7-50.9.2
  • php7-xmlrpc >= 7.0.7-50.9.2
  • php7-xmlwriter >= 7.0.7-50.9.2
  • php7-xsl >= 7.0.7-50.9.2
  • php7-zip >= 7.0.7-50.9.2
  • php7-zlib >= 7.0.7-50.9.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php5-devel-5.5.14-109.41.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA php7-devel-7.0.7-50.52.1
SUSE-SLE-Module-Web-Scripting-12-2017-1417
SUSE-SLE-Module-Web-Scripting-12-2017-1431
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • apache2-mod_php5 >= 5.5.14-109.5.1
  • apache2-mod_php7 >= 7.0.7-50.9.2
  • php5 >= 5.5.14-109.5.1
  • php5-bcmath >= 5.5.14-109.5.1
  • php5-bz2 >= 5.5.14-109.5.1
  • php5-calendar >= 5.5.14-109.5.1
  • php5-ctype >= 5.5.14-109.5.1
  • php5-curl >= 5.5.14-109.5.1
  • php5-dba >= 5.5.14-109.5.1
  • php5-dom >= 5.5.14-109.5.1
  • php5-enchant >= 5.5.14-109.5.1
  • php5-exif >= 5.5.14-109.5.1
  • php5-fastcgi >= 5.5.14-109.5.1
  • php5-fileinfo >= 5.5.14-109.5.1
  • php5-fpm >= 5.5.14-109.5.1
  • php5-ftp >= 5.5.14-109.5.1
  • php5-gd >= 5.5.14-109.5.1
  • php5-gettext >= 5.5.14-109.5.1
  • php5-gmp >= 5.5.14-109.5.1
  • php5-iconv >= 5.5.14-109.5.1
  • php5-imap >= 5.5.14-109.5.1
  • php5-intl >= 5.5.14-109.5.1
  • php5-json >= 5.5.14-109.5.1
  • php5-ldap >= 5.5.14-109.5.1
  • php5-mbstring >= 5.5.14-109.5.1
  • php5-mcrypt >= 5.5.14-109.5.1
  • php5-mysql >= 5.5.14-109.5.1
  • php5-odbc >= 5.5.14-109.5.1
  • php5-opcache >= 5.5.14-109.5.1
  • php5-openssl >= 5.5.14-109.5.1
  • php5-pcntl >= 5.5.14-109.5.1
  • php5-pdo >= 5.5.14-109.5.1
  • php5-pear >= 5.5.14-109.5.1
  • php5-pgsql >= 5.5.14-109.5.1
  • php5-phar >= 5.5.14-109.5.1
  • php5-posix >= 5.5.14-109.5.1
  • php5-pspell >= 5.5.14-109.5.1
  • php5-shmop >= 5.5.14-109.5.1
  • php5-snmp >= 5.5.14-109.5.1
  • php5-soap >= 5.5.14-109.5.1
  • php5-sockets >= 5.5.14-109.5.1
  • php5-sqlite >= 5.5.14-109.5.1
  • php5-suhosin >= 5.5.14-109.5.1
  • php5-sysvmsg >= 5.5.14-109.5.1
  • php5-sysvsem >= 5.5.14-109.5.1
  • php5-sysvshm >= 5.5.14-109.5.1
  • php5-tokenizer >= 5.5.14-109.5.1
  • php5-wddx >= 5.5.14-109.5.1
  • php5-xmlreader >= 5.5.14-109.5.1
  • php5-xmlrpc >= 5.5.14-109.5.1
  • php5-xmlwriter >= 5.5.14-109.5.1
  • php5-xsl >= 5.5.14-109.5.1
  • php5-zip >= 5.5.14-109.5.1
  • php5-zlib >= 5.5.14-109.5.1
  • php7 >= 7.0.7-50.9.2
  • php7-bcmath >= 7.0.7-50.9.2
  • php7-bz2 >= 7.0.7-50.9.2
  • php7-calendar >= 7.0.7-50.9.2
  • php7-ctype >= 7.0.7-50.9.2
  • php7-curl >= 7.0.7-50.9.2
  • php7-dba >= 7.0.7-50.9.2
  • php7-devel >= 7.0.7-50.85.1
  • php7-dom >= 7.0.7-50.9.2
  • php7-enchant >= 7.0.7-50.9.2
  • php7-exif >= 7.0.7-50.9.2
  • php7-fastcgi >= 7.0.7-50.9.2
  • php7-fileinfo >= 7.0.7-50.9.2
  • php7-fpm >= 7.0.7-50.9.2
  • php7-ftp >= 7.0.7-50.9.2
  • php7-gd >= 7.0.7-50.9.2
  • php7-gettext >= 7.0.7-50.9.2
  • php7-gmp >= 7.0.7-50.9.2
  • php7-iconv >= 7.0.7-50.9.2
  • php7-imap >= 7.0.7-50.9.2
  • php7-intl >= 7.0.7-50.9.2
  • php7-json >= 7.0.7-50.9.2
  • php7-ldap >= 7.0.7-50.9.2
  • php7-mbstring >= 7.0.7-50.9.2
  • php7-mcrypt >= 7.0.7-50.9.2
  • php7-mysql >= 7.0.7-50.9.2
  • php7-odbc >= 7.0.7-50.9.2
  • php7-opcache >= 7.0.7-50.9.2
  • php7-openssl >= 7.0.7-50.9.2
  • php7-pcntl >= 7.0.7-50.9.2
  • php7-pdo >= 7.0.7-50.9.2
  • php7-pear >= 7.0.7-50.9.2
  • php7-pear-Archive_Tar >= 7.0.7-50.9.2
  • php7-pgsql >= 7.0.7-50.9.2
  • php7-phar >= 7.0.7-50.9.2
  • php7-posix >= 7.0.7-50.9.2
  • php7-pspell >= 7.0.7-50.9.2
  • php7-shmop >= 7.0.7-50.9.2
  • php7-snmp >= 7.0.7-50.9.2
  • php7-soap >= 7.0.7-50.9.2
  • php7-sockets >= 7.0.7-50.9.2
  • php7-sqlite >= 7.0.7-50.9.2
  • php7-sysvmsg >= 7.0.7-50.9.2
  • php7-sysvsem >= 7.0.7-50.9.2
  • php7-sysvshm >= 7.0.7-50.9.2
  • php7-tokenizer >= 7.0.7-50.9.2
  • php7-wddx >= 7.0.7-50.9.2
  • php7-xmlreader >= 7.0.7-50.9.2
  • php7-xmlrpc >= 7.0.7-50.9.2
  • php7-xmlwriter >= 7.0.7-50.9.2
  • php7-xsl >= 7.0.7-50.9.2
  • php7-zip >= 7.0.7-50.9.2
  • php7-zlib >= 7.0.7-50.9.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA php7-devel-7.0.7-50.85.1
SUSE-SLE-Module-Web-Scripting-12-2017-1417
SUSE-SLE-Module-Web-Scripting-12-2017-1431
SUSE Linux Enterprise Software Development Kit 12 SP5
  • php7-devel >= 7.0.7-50.85.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA php7-devel-7.0.7-50.85.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 php5 Released
SUSE Linux Enterprise High Performance Computing 12 php7 Released
SUSE Linux Enterprise High Performance Computing 12 php72 Affected
SUSE Linux Enterprise High Performance Computing 12 php74 Affected
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php7 Released
SUSE Linux Enterprise Module for Web and Scripting 12 php72 Affected
SUSE Linux Enterprise Module for Web and Scripting 12 php74 Affected
SUSE Linux Enterprise Server 12 SP5 php5 Released
SUSE Linux Enterprise Server 12 SP5 php7 Released
SUSE Linux Enterprise Server 12 SP5 php72 Affected
SUSE Linux Enterprise Server 12 SP5 php74 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php72 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php74 Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 php72 Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 php74 Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP4 php5 Released
SUSE Linux Enterprise Server 12 SP4 php7 Released
SUSE Linux Enterprise Server 12 SP4 php72 Affected
SUSE Linux Enterprise Server 12 SP4 php74 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php72 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php74 Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP4 php53 Released
SUSE Linux Enterprise Desktop 12 php5 Affected
SUSE Linux Enterprise Desktop 12 php7 Affected
SUSE Linux Enterprise Desktop 12 SP1 php5 Affected
SUSE Linux Enterprise Desktop 12 SP1 php7 Affected
SUSE Linux Enterprise Desktop 12 SP2 php5 Released
SUSE Linux Enterprise Desktop 12 SP2 php7 Released
SUSE Linux Enterprise Desktop 12 SP3 php5 Released
SUSE Linux Enterprise Desktop 12 SP3 php7 Released
SUSE Linux Enterprise Desktop 12 SP3 php72 Affected
SUSE Linux Enterprise Desktop 12 SP4 php5 Affected
SUSE Linux Enterprise Desktop 12 SP4 php7 Affected
SUSE Linux Enterprise Desktop 12 SP4 php72 Affected
SUSE Linux Enterprise Desktop 12 SP4 php74 Affected
SUSE Linux Enterprise Point of Service 11 SP3 php53 Released
SUSE Linux Enterprise Server 11 SP3 php53 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Affected
SUSE Linux Enterprise Server 11 SP3-LTSS php53 Affected
SUSE Linux Enterprise Server 11 SP4 php53 Released
SUSE Linux Enterprise Server 11 SP4 LTSS php53 Released
SUSE Linux Enterprise Server 11 SP4-LTSS php53 Released
SUSE Linux Enterprise Server 12 php5 Released
SUSE Linux Enterprise Server 12 php7 Released
SUSE Linux Enterprise Server 12 php72 Affected
SUSE Linux Enterprise Server 12 php74 Affected
SUSE Linux Enterprise Server 12 SP1 php5 Affected
SUSE Linux Enterprise Server 12 SP1 php7 Affected
SUSE Linux Enterprise Server 12 SP2 php5 Released
SUSE Linux Enterprise Server 12 SP2 php7 Released
SUSE Linux Enterprise Server 12 SP3 php5 Released
SUSE Linux Enterprise Server 12 SP3 php7 Released
SUSE Linux Enterprise Server 12 SP3 php72 Affected
SUSE Linux Enterprise Server 12 SP3 php74 Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 php53 Released
SUSE Linux Enterprise Server for SAP Applications 12 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 php72 Affected
SUSE Linux Enterprise Server for SAP Applications 12 php74 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php5 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php7 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php5 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php7 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php72 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php74 Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 php53 Released
SUSE Linux Enterprise Software Development Kit 12 php5 Affected
SUSE Linux Enterprise Software Development Kit 12 php7 Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 php5 Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 php7 Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 php5 Released
SUSE Linux Enterprise Software Development Kit 12 SP2 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 php5 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 php7 Released
SUSE Linux Enterprise Software Development Kit 12 SP3 php72 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php5 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php7 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php72 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php74 Affected


SUSE Timeline for this CVE

CVE page created: Thu Jul 6 10:16:11 2017
CVE page last modified: Tue Jan 17 13:39:22 2023