Upstream information

CVE-2016-10317 at MITRE

Description

The fill_threshhold_buffer function in base/gxht_thresh.c in Artifex Software, Inc. Ghostscript 9.20 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted PostScript document.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.4
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.3
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1032230 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • ghostscript >= 9.15-23.7.1
  • ghostscript-devel >= 9.15-23.7.1
  • ghostscript-x11 >= 9.15-23.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-277
SUSE-SLE-SDK-12-SP2-2018-277
SUSE Linux Enterprise Desktop 12 SP3
  • ghostscript >= 9.15-23.7.1
  • ghostscript-devel >= 9.15-23.7.1
  • ghostscript-x11 >= 9.15-23.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-277
SUSE-SLE-SDK-12-SP3-2018-277
SUSE Linux Enterprise Desktop 12 SP4
  • ghostscript >= 9.25-23.13.1
  • ghostscript-devel >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA ghostscript-9.25-23.13.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA ghostscript-devel-9.25-23.13.1
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • ghostscript >= 9.26a-3.15.1
  • ghostscript-devel >= 9.26a-3.15.1
  • ghostscript-x11 >= 9.26a-3.15.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA ghostscript-9.26a-3.15.1
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • ghostscript >= 9.52-3.27.2
  • ghostscript-devel >= 9.52-3.27.2
  • ghostscript-x11 >= 9.52-3.27.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA ghostscript-9.52-3.27.2
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • ghostscript >= 9.52-3.32.1
  • ghostscript-devel >= 9.52-3.32.1
  • ghostscript-x11 >= 9.52-3.32.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA ghostscript-9.52-3.32.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • ghostscript >= 9.23-1.16
  • ghostscript-devel >= 9.23-1.16
  • ghostscript-x11 >= 9.23-1.16
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA ghostscript-9.23-1.16
SUSE Linux Enterprise High Performance Computing 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA ghostscript-9.27-23.28.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ghostscript >= 9.15-23.7.1
  • ghostscript-devel >= 9.15-23.7.1
  • ghostscript-x11 >= 9.15-23.7.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-277
SUSE-SLE-SERVER-12-SP2-2018-277
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ghostscript >= 9.15-23.7.1
  • ghostscript-devel >= 9.15-23.7.1
  • ghostscript-x11 >= 9.15-23.7.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-277
SUSE-SLE-SERVER-12-SP3-2018-277
SUSE Linux Enterprise Server 12 SP4
  • ghostscript >= 9.25-23.13.1
  • ghostscript-devel >= 9.25-23.13.1
  • ghostscript-x11 >= 9.25-23.13.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA ghostscript-9.25-23.13.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA ghostscript-devel-9.25-23.13.1
SUSE Linux Enterprise Server 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-devel >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA ghostscript-9.27-23.28.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA ghostscript-devel-9.27-23.28.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ghostscript >= 9.15-23.7.1
  • ghostscript-x11 >= 9.15-23.7.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-277
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ghostscript-devel >= 9.25-23.13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA ghostscript-devel-9.25-23.13.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ghostscript-devel >= 9.27-23.28.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA ghostscript-devel-9.27-23.28.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • ghostscript-devel >= 9.15-23.7.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-277
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ghostscript-devel >= 9.15-23.7.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-277
openSUSE Leap 15.0
  • ghostscript >= 9.23-lp150.1.1
  • ghostscript-x11 >= 9.23-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA ghostscript-9.23-lp150.1.1
openSUSE Tumbleweed
  • ghostscript >= 9.54.0-2.2
  • ghostscript-devel >= 9.54.0-2.2
  • ghostscript-x11 >= 9.54.0-2.2
Patchnames:
openSUSE Tumbleweed GA ghostscript-9.54.0-2.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 ghostscript Released
SLES for SAP Applications ghostscript-library Affected
SUSE CaaS Platform 4.5 ghostscript Already fixed
SUSE Enterprise Storage 5 ghostscript Released
SUSE Enterprise Storage 7 ghostscript Already fixed
SUSE Linux Enterprise Desktop 11 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Desktop 12 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP1 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP2 ghostscript Released
SUSE Linux Enterprise Desktop 12 SP3 ghostscript Released
SUSE Linux Enterprise Desktop 12 SP4 ghostscript Affected
SUSE Linux Enterprise Desktop 15 ghostscript Already fixed
SUSE Linux Enterprise Desktop 15 SP3 ghostscript Already fixed
SUSE Linux Enterprise Desktop 15 SP4 ghostscript Already fixed
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search ghostscript-library Affected
SUSE Linux Enterprise High Performance Computing 12 SP2 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP3 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 ghostscript Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ghostscript Released
SUSE Linux Enterprise High Performance Computing 15 ghostscript Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS ghostscript Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS ghostscript Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS ghostscript Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 ghostscript Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 ghostscript Already fixed
SUSE Linux Enterprise Module for Basesystem 15 ghostscript Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 ghostscript Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 ghostscript Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 ghostscript-library In progress
SUSE Linux Enterprise Point of Service Image Server 12 SP2 ghostscript Released
SUSE Linux Enterprise Real Time 15 SP2 ghostscript Already fixed
SUSE Linux Enterprise Server 11 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP1 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP2 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP2 for VMware ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP3 for VMware ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP4 LTSS ghostscript-library In progress
SUSE Linux Enterprise Server 12 ghostscript Affected
SUSE Linux Enterprise Server 12 LTSS ghostscript Unsupported
SUSE Linux Enterprise Server 12 SP1 ghostscript Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ghostscript Unsupported
SUSE Linux Enterprise Server 12 SP2 ghostscript Released
SUSE Linux Enterprise Server 12 SP2 BCL ghostscript Released
SUSE Linux Enterprise Server 12 SP2 ESPOS ghostscript Released
SUSE Linux Enterprise Server 12 SP2 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP3 ghostscript Released
SUSE Linux Enterprise Server 12 SP3 BCL ghostscript Released
SUSE Linux Enterprise Server 12 SP3 ESPOS ghostscript Released
SUSE Linux Enterprise Server 12 SP3 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP4 ghostscript Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS ghostscript Released
SUSE Linux Enterprise Server 12 SP4 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP5 ghostscript Released
SUSE Linux Enterprise Server 15 ghostscript Already fixed
SUSE Linux Enterprise Server 15 SP2 LTSS ghostscript Already fixed
SUSE Linux Enterprise Server 15 SP3 ghostscript Already fixed
SUSE Linux Enterprise Server 15 SP4 ghostscript Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ghostscript Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 ghostscript Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 12 ghostscript Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 ghostscript Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ghostscript Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 15 ghostscript Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ghostscript Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ghostscript Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 ghostscript Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 11 ghostscript-library Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Software Development Kit 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Software Development Kit 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Software Development Kit 12 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 ghostscript Released
SUSE Linux Enterprise Software Development Kit 12 SP3 ghostscript Released
SUSE Linux Enterprise Software Development Kit 12 SP4 ghostscript Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 ghostscript Released
SUSE Linux Enterprise Storage 7.1 ghostscript Already fixed
SUSE Manager Proxy 4.1 ghostscript Already fixed
SUSE Manager Proxy 4.2 ghostscript Already fixed
SUSE Manager Proxy 4.3 ghostscript Already fixed
SUSE Manager Retail Branch Server 4.1 ghostscript Already fixed
SUSE Manager Retail Branch Server 4.2 ghostscript Already fixed
SUSE Manager Retail Branch Server 4.3 ghostscript Already fixed
SUSE Manager Server 4.1 ghostscript Already fixed
SUSE Manager Server 4.2 ghostscript Already fixed
SUSE Manager Server 4.3 ghostscript Already fixed
SUSE OpenStack Cloud 7 ghostscript Released
SUSE OpenStack Cloud 8 ghostscript Released
SUSE OpenStack Cloud 9 ghostscript Released
SUSE OpenStack Cloud Crowbar 8 ghostscript Released
SUSE OpenStack Cloud Crowbar 9 ghostscript Released