Upstream information

CVE-2016-10197 at MITRE

Description

The search_make_new function in evdns.c in libevent before 2.1.6-beta allows attackers to cause a denial of service (out-of-bounds read) via an empty hostname.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1022919 [RESOLVED / FIXED], 1035082 [RESOLVED / FIXED], 1035209 [RESOLVED / INVALID], 1075618 [RESOLVED], 1123122 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-OCI-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
  • libevent-2_0-5 >= 2.0.21-6.3.1
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libevent-devel >= 1.4.5-24.24.3.1
Patchnames:
sdksp4-libevent-13447
SUSE Linux Enterprise Desktop 12 SP2
  • libevent-2_0-5 >= 2.0.21-6.3.1
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-143
SUSE-SLE-SDK-12-SP2-2018-143
SUSE Linux Enterprise Desktop 12 SP3
  • libevent-2_0-5 >= 2.0.21-6.3.1
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-143
SUSE-SLE-SDK-12-SP3-2018-143
SUSE Linux Enterprise Desktop 12 SP4
  • libevent-2_0-5 >= 2.0.21-6.3.1
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libevent-2_0-5-2.0.21-6.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libevent-devel-2.0.21-6.3.1
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libevent-2_0-5 >= 2.0.21-6.3.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libevent-2_0-5-2.0.21-6.3.1
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libevent-1_4-2 >= 1.4.5-24.24.3.1
  • libevent-devel >= 1.4.5-24.24.3.1
Patchnames:
sdksp4-libevent-13447
slessp4-libevent-13447
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libevent-2_0-5 >= 2.0.21-6.3.1
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-143
SUSE-SLE-SERVER-12-SP2-2018-143
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libevent-2_0-5 >= 2.0.21-6.3.1
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-143
SUSE-SLE-SERVER-12-SP3-2018-143
SUSE Linux Enterprise Server 12 SP4
  • libevent-2_0-5 >= 2.0.21-6.3.1
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libevent-2_0-5-2.0.21-6.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libevent-devel-2.0.21-6.3.1
SUSE Linux Enterprise Server 12 SP5
  • libevent-2_0-5 >= 2.0.21-6.3.1
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libevent-2_0-5-2.0.21-6.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libevent-devel-2.0.21-6.3.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libevent-2_0-5 >= 2.0.21-6.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-143
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libevent-devel-2.0.21-6.3.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libevent-devel-2.0.21-6.3.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-143
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libevent-devel >= 2.0.21-6.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-143


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libevent Affected
SUSE CaaS Platform 3.0 libevent Affected
SUSE Container as a Service Platform 2.0 libevent Released
SUSE Linux Enterprise Desktop 11 SP4 libevent Released
SUSE Linux Enterprise Desktop 12 libevent Affected
SUSE Linux Enterprise Desktop 12 SP1 libevent Unsupported
SUSE Linux Enterprise Desktop 12 SP2 libevent Released
SUSE Linux Enterprise Desktop 12 SP3 libevent Released
SUSE Linux Enterprise Desktop 12 SP4 libevent Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libevent Affected
SUSE Linux Enterprise Point of Service 11 SP3 libevent Released
SUSE Linux Enterprise Server 11 SP3 libevent Affected
SUSE Linux Enterprise Server 11 SP3-LTSS libevent Affected
SUSE Linux Enterprise Server 11 SP4 libevent Released
SUSE Linux Enterprise Server 11 SP4 LTSS libevent Released
SUSE Linux Enterprise Server 11 SP4-LTSS libevent Released
SUSE Linux Enterprise Server 12 libevent Affected
SUSE Linux Enterprise Server 12 SP1 libevent Unsupported
SUSE Linux Enterprise Server 12 SP1-LTSS libevent Affected
SUSE Linux Enterprise Server 12 SP2 libevent Released
SUSE Linux Enterprise Server 12 SP2-BCL libevent Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS libevent Affected
SUSE Linux Enterprise Server 12 SP2-LTSS libevent Affected
SUSE Linux Enterprise Server 12 SP3 libevent Released
SUSE Linux Enterprise Server 12 SP3-BCL libevent Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS libevent Affected
SUSE Linux Enterprise Server 12 SP3-LTSS libevent Affected
SUSE Linux Enterprise Server 12 SP4 libevent Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libevent Affected
SUSE Linux Enterprise Server 12 SP4-LTSS libevent Affected
SUSE Linux Enterprise Server 12 SP5 libevent Affected
SUSE Linux Enterprise Server 12-LTSS libevent Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libevent Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libevent Released
SUSE Linux Enterprise Server for SAP Applications 12 libevent Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libevent Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libevent Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libevent Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libevent Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libevent Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 libevent Released
SUSE Linux Enterprise Software Development Kit 12 libevent Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libevent Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 libevent Released
SUSE Linux Enterprise Software Development Kit 12 SP3 libevent Released
SUSE Linux Enterprise Software Development Kit 12 SP4 libevent Affected
SUSE OpenStack Cloud 7 libevent Affected
SUSE OpenStack Cloud 8 libevent Affected
SUSE OpenStack Cloud 9 libevent Affected
SUSE OpenStack Cloud Crowbar 8 libevent Affected
SUSE OpenStack Cloud Crowbar 9 libevent Affected


SUSE Timeline for this CVE

CVE page created: Wed Feb 1 01:45:54 2017
CVE page last modified: Sat Dec 3 15:51:42 2022