Upstream information

CVE-2016-0749 at MITRE

Description

The smartcard interaction in SPICE allows remote attackers to cause a denial of service (QEMU-KVM process crash) or possibly execute arbitrary code via vectors related to connecting to a guest VM, which triggers a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 10 6
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C AV:L/AC:H/Au:S/C:C/I:C/A:C
Access Vector Network Local
Access Complexity Low High
Authentication None Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3.1
SUSE Bugzilla entries: 982385 [RESOLVED / FIXED], 982386 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libspice-server1 >= 0.12.5-4.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-925
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
  • libspice-server1 >= 0.12.7-6.3
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • libspice-server1 >= 0.12.8-1.17
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • libspice-server1 >= 0.12.8-6.1
SUSE Linux Enterprise Desktop 12
  • libspice-server1 >= 0.12.4-8.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-928
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libspice-server1 >= 0.12.8-12.1
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • libspice-server-devel >= 0.14.1-2.21
  • libspice-server1 >= 0.14.1-2.21
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • libspice-server-devel >= 0.14.2-1.58
  • libspice-server1 >= 0.14.2-1.58
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • libspice-server-devel >= 0.14.3-1.48
  • libspice-server1 >= 0.14.3-1.48
SUSE Linux Enterprise Module for Server Applications 15
  • libspice-server-devel >= 0.14.0-2.32
  • libspice-server1 >= 0.14.0-2.32
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libspice-server1 >= 0.12.5-4.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-925
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • libspice-server1 >= 0.12.4-8.9.1
Patchnames:
SUSE-SLE-SERVER-12-2016-928
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libspice-server-devel >= 0.12.5-4.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-925
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libspice-server-devel >= 0.12.7-6.3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libspice-server-devel >= 0.12.8-1.17
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libspice-server-devel >= 0.12.8-6.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libspice-server-devel >= 0.12.8-12.1
SUSE Linux Enterprise Software Development Kit 12
  • libspice-server-devel >= 0.12.4-8.9.1
Patchnames:
SUSE-SLE-SDK-12-2016-928
openSUSE Leap 15.0
  • libspice-server1 >= 0.14.0-lp150.2.4
Patchnames:
openSUSE Leap 15.0 GA libspice-server1-0.14.0-lp150.2.4
openSUSE Tumbleweed
  • libspice-server-devel >= 0.12.8-2.1
  • libspice-server1 >= 0.12.8-2.1
  • spice-client >= 0.12.8-2.1
Patchnames:
openSUSE Tumbleweed GA libspice-server-devel-0.12.8-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 spice Already fixed
SUSE Enterprise Storage 5 spice Not affected
SUSE Linux Enterprise Desktop 12 spice Released
SUSE Linux Enterprise Desktop 12 SP1 spice Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP5 spice Already fixed
SUSE Linux Enterprise High Performance Computing 15 LTSS spice Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 spice Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 spice Not affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 spice Already fixed
SUSE Linux Enterprise Server 11 SP4 spice Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS spice Not affected
SUSE Linux Enterprise Server 12 spice Released
SUSE Linux Enterprise Server 12 LTSS spice Released
SUSE Linux Enterprise Server 12 SP1 spice Unsupported
SUSE Linux Enterprise Server 12 SP2 ESPOS spice Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS spice Already fixed
SUSE Linux Enterprise Server 12 SP3 ESPOS spice Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS spice Already fixed
SUSE Linux Enterprise Server 12 SP4 ESPOS spice Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS spice Already fixed
SUSE Linux Enterprise Server 12 SP5 spice Already fixed
SUSE Linux Enterprise Server 15 ESPOS spice Not affected
SUSE Linux Enterprise Server 15 LTSS spice Not affected
SUSE Linux Enterprise Server BCL 12 SP2 spice Already fixed
SUSE Linux Enterprise Server BCL 12 SP3 spice Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 spice Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 spice Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 spice Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 spice Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 spice Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 spice Unsupported
SUSE Linux Enterprise Software Development Kit 12 spice Released
SUSE Linux Enterprise Software Development Kit 12 SP1 spice Unsupported
SUSE OpenStack Cloud 7 spice Already fixed
SUSE OpenStack Cloud 8 spice Already fixed
SUSE OpenStack Cloud 9 spice Already fixed
SUSE OpenStack Cloud Crowbar 8 spice Already fixed
SUSE OpenStack Cloud Crowbar 9 spice Already fixed