Upstream information

CVE-2015-8923 at MITRE

Description

The process_extra function in libarchive before 3.2.0 uses the size field and a signed number in an offset, which allows remote attackers to cause a denial of service (crash) via a crafted zip file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5.8
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None Partial
Availability Impact Partial Partial
SUSE Bugzilla entry: 985703 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libarchive-devel >= 3.1.2-22.1
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1123
SUSE-SLE-SDK-12-SP1-2016-1123
SUSE Linux Enterprise Desktop 12 SP2
  • libarchive-devel >= 3.1.2-22.1
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libarchive13-3.1.2-22.1
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libarchive-devel-3.1.2-22.1
SUSE Linux Enterprise Desktop 12 SP3
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Desktop 12 SP4
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libarchive13 >= 3.1.2-26.3.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libarchive13-3.1.2-26.3.1
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libarchive-devel >= 3.1.2-22.1
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1123
SUSE-SLE-SERVER-12-SP1-2016-1123
SUSE Linux Enterprise Server 12 SP2
  • libarchive-devel >= 3.1.2-22.1
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libarchive13-3.1.2-22.1
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libarchive-devel-3.1.2-22.1
SUSE Linux Enterprise Server 12 SP3
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server 12 SP4
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server 12 SP5
  • libarchive-devel >= 3.1.2-26.3.1
  • libarchive13 >= 3.1.2-26.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libarchive13-3.1.2-26.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libarchive-devel-3.1.2-26.3.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libarchive13-3.1.2-22.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libarchive-devel >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libarchive-devel-3.1.2-22.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libarchive-devel >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libarchive-devel >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libarchive-devel >= 3.1.2-26.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libarchive-devel-3.1.2-26.3.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libarchive-devel >= 3.1.2-22.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1123


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libarchive In progress
SUSE CaaS Platform 4.5 libarchive Analysis
SUSE Enterprise Storage 7 libarchive Already fixed
SUSE Linux Enterprise Desktop 11 SP4 bsdtar Affected
SUSE Linux Enterprise Desktop 12 libarchive Released
SUSE Linux Enterprise Desktop 12 SP1 libarchive Released
SUSE Linux Enterprise Desktop 12 SP2 libarchive Released
SUSE Linux Enterprise Desktop 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Desktop 15 SP4 libarchive Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 libarchive Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 libarchive Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP4 libarchive Not affected
SUSE Linux Enterprise Real Time 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Server 11 SP1 bsdtar Unsupported
SUSE Linux Enterprise Server 11 SP2 LTSS bsdtar Affected
SUSE Linux Enterprise Server 11 SP3 bsdtar Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS bsdtar Affected
SUSE Linux Enterprise Server 11 SP4 bsdtar Affected
SUSE Linux Enterprise Server 11 SP4 LTSS bsdtar Affected
SUSE Linux Enterprise Server 12 libarchive Released
SUSE Linux Enterprise Server 12 LTSS libarchive Released
SUSE Linux Enterprise Server 12 SP1 libarchive Released
SUSE Linux Enterprise Server 12 SP2 libarchive Released
SUSE Linux Enterprise Server 12 SP2 BCL libarchive In progress
SUSE Linux Enterprise Server 12 SP3 BCL libarchive In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS libarchive In progress
SUSE Linux Enterprise Server 12 SP3 LTSS libarchive In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS libarchive Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS libarchive Already fixed
SUSE Linux Enterprise Server 12 SP5 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP2 LTSS libarchive Already fixed
SUSE Linux Enterprise Server 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP4 libarchive Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libarchive Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP4 bsdtar Affected
SUSE Linux Enterprise Server for SAP Applications 12 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libarchive Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libarchive Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 bsdtar Affected
SUSE Linux Enterprise Software Development Kit 12 libarchive Released
SUSE Linux Enterprise Software Development Kit 12 SP1 libarchive Released
SUSE Linux Enterprise Software Development Kit 12 SP2 libarchive Released
SUSE Linux Enterprise Storage 7.1 libarchive Already fixed
SUSE Manager Proxy 4.1 libarchive Already fixed
SUSE Manager Proxy 4.2 libarchive Already fixed
SUSE Manager Proxy 4.3 libarchive Not affected
SUSE Manager Retail Branch Server 4.1 libarchive Already fixed
SUSE Manager Retail Branch Server 4.2 libarchive Already fixed
SUSE Manager Retail Branch Server 4.3 libarchive Not affected
SUSE Manager Server 4.1 libarchive Already fixed
SUSE Manager Server 4.2 libarchive Already fixed
SUSE Manager Server 4.3 libarchive Not affected
SUSE OpenStack Cloud 8 libarchive In progress
SUSE OpenStack Cloud 9 libarchive Already fixed
SUSE OpenStack Cloud Crowbar 8 libarchive In progress
SUSE OpenStack Cloud Crowbar 9 libarchive Already fixed
SUSE Studio Onsite 1.3 bsdtar Affected