Upstream information

CVE-2015-8805 at MITRE

Description

The ecc_256_modq function in ecc-256.c in Nettle before 3.2 does not properly handle carry propagation and produces incorrect output in its implementation of the P-256 NIST elliptic curve, which allows attackers to have unspecified impact via unknown vectors, a different vulnerability than CVE-2015-8803.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 964849 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-259
SUSE Linux Enterprise Desktop 12 SP1
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-259
SUSE Linux Enterprise Desktop 12 SP2
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libhogweed2
SUSE Linux Enterprise Desktop 12 SP3
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libhogweed2
SUSE Linux Enterprise Module for Basesystem 15
  • libhogweed4 >= 3.4-2.12
  • libnettle-devel >= 3.4-2.12
  • libnettle6 >= 3.4-2.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libhogweed4
SUSE Linux Enterprise Module for Desktop Applications 15
  • libhogweed4-32bit >= 3.4-2.12
  • libnettle6-32bit >= 3.4-2.12
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libhogweed4-32bit
SUSE Linux Enterprise Server 12
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE-SLE-SERVER-12-2016-259
SUSE Linux Enterprise Server 12 SP1
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-259
SUSE Linux Enterprise Server 12 SP2
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libhogweed2
SUSE Linux Enterprise Server 12 SP3
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libhogweed2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libhogweed2 >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libhogweed2
SUSE Linux Enterprise Server for SAP Applications 12
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE-SLE-SERVER-12-2016-259
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-259
SUSE Linux Enterprise Software Development Kit 12
  • libnettle >= 2.7.1-9.1
  • libnettle-devel >= 2.7.1-9.1
Patchnames:
SUSE-SLE-SDK-12-2016-259
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libnettle >= 2.7.1-9.1
  • libnettle-devel >= 2.7.1-9.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-259
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libnettle-devel >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libnettle-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libnettle-devel >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libnettle-devel
openSUSE 13.1
  • libhogweed2 >= 2.7.1-2.3.1
  • libhogweed2-32bit >= 2.7.1-2.3.1
  • libhogweed2-debuginfo >= 2.7.1-2.3.1
  • libhogweed2-debuginfo-32bit >= 2.7.1-2.3.1
  • libnettle >= 2.7.1-2.3.1
  • libnettle-debugsource >= 2.7.1-2.3.1
  • libnettle-devel >= 2.7.1-2.3.1
  • libnettle-devel-32bit >= 2.7.1-2.3.1
  • libnettle4 >= 2.7.1-2.3.1
  • libnettle4-32bit >= 2.7.1-2.3.1
  • libnettle4-debuginfo >= 2.7.1-2.3.1
  • libnettle4-debuginfo-32bit >= 2.7.1-2.3.1
  • nettle >= 2.7.1-2.3.1
  • nettle-debuginfo >= 2.7.1-2.3.1
Patchnames:
2016-217
openSUSE Leap 15.0
  • libhogweed4 >= 3.4-lp150.2.3
  • libnettle6 >= 3.4-lp150.2.3
Patchnames:
openSUSE Leap 15.0 GA libhogweed4
openSUSE Leap 42.1
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libhogweed2-debuginfo >= 2.7.1-9.1
  • libhogweed2-debuginfo-32bit >= 2.7.1-9.1
  • libnettle >= 2.7.1-9.1
  • libnettle-debugsource >= 2.7.1-9.1
  • libnettle-devel >= 2.7.1-9.1
  • libnettle-devel-32bit >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
  • libnettle4-debuginfo >= 2.7.1-9.1
  • libnettle4-debuginfo-32bit >= 2.7.1-9.1
  • nettle >= 2.7.1-9.1
  • nettle-debuginfo >= 2.7.1-9.1
Patchnames:
openSUSE-2016-212
openSUSE Leap 42.2
  • libhogweed2 >= 2.7.1-9.5
  • libhogweed2-32bit >= 2.7.1-9.5
  • libnettle-devel >= 2.7.1-9.5
  • libnettle4 >= 2.7.1-9.5
  • libnettle4-32bit >= 2.7.1-9.5
Patchnames:
openSUSE Leap 42.2 GA libhogweed2
openSUSE Leap 42.3
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle-devel >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
openSUSE Leap 42.3 GA libhogweed2
openSUSE Tumbleweed
  • libhogweed4 >= 3.3-1.1
  • libhogweed4-32bit >= 3.3-1.1
  • libnettle-devel >= 3.3-1.1
  • libnettle-devel-32bit >= 3.3-1.1
  • libnettle6 >= 3.3-1.1
  • libnettle6-32bit >= 3.3-1.1
  • nettle >= 3.3-1.1
Patchnames:
openSUSE Tumbleweed GA libhogweed4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA libnettle Released
SUSE Linux Enterprise Desktop 12 SP1 libnettle Released
SUSE Linux Enterprise SDK 12 GA libnettle Released
SUSE Linux Enterprise SDK 12 SP1 libnettle Released
SUSE Linux Enterprise Server 12 GA libnettle Released
SUSE Linux Enterprise Server 12 SP1 libnettle Released