Upstream information

CVE-2015-8805 at MITRE

Description

The ecc_256_modq function in ecc-256.c in Nettle before 3.2 does not properly handle carry propagation and produces incorrect output in its implementation of the P-256 NIST elliptic curve, which allows attackers to have unspecified impact via unknown vectors, a different vulnerability than CVE-2015-8803.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 964849 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/dnsmasq-nanny:2.78
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-ECS-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • libhogweed2 >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
Image SLES12-SP4-Azure-BYOS
Image SLES12-SP4-EC2-HVM-BYOS
Image SLES12-SP4-GCE-BYOS
Image SLES12-SP4-OCI-BYOS
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-HPC-BYOS
Image SLES12-SP5-Azure-HPC-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-EC2-On-Demand
Image SLES12-SP5-GCE-BYOS
Image SLES12-SP5-GCE-On-Demand
Image SLES12-SP5-OCI-BYOS-BYOS
  • libnettle4 >= 2.7.1-9.1
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libhogweed4 >= 3.4.1-4.9.1
  • libhogweed4-32bit >= 3.4.1-4.9.1
  • libnettle-devel >= 3.4.1-4.9.1
  • libnettle6 >= 3.4.1-4.9.1
  • libnettle6-32bit >= 3.4.1-4.9.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libhogweed4-3.4.1-4.9.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libhogweed4 >= 3.4.1-4.15.1
  • libhogweed4-32bit >= 3.4.1-4.15.1
  • libnettle-devel >= 3.4.1-4.15.1
  • libnettle6 >= 3.4.1-4.15.1
  • libnettle6-32bit >= 3.4.1-4.15.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libhogweed4-3.4.1-4.15.1
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libhogweed4 >= 3.4.1-4.12.1
  • libhogweed4-32bit >= 3.4.1-4.12.1
  • libnettle-devel >= 3.4.1-4.12.1
  • libnettle6 >= 3.4.1-4.12.1
  • libnettle6-32bit >= 3.4.1-4.12.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libhogweed4-3.4.1-4.12.1
SUSE Linux Enterprise Desktop 12 SP2
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle-devel >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libhogweed2-2.7.1-9.1
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libnettle-devel-2.7.1-9.1
SUSE Linux Enterprise Desktop 12 SP3
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle-devel >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libhogweed2-2.7.1-12.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libnettle-devel-2.7.1-12.1
SUSE Linux Enterprise Desktop 12 SP4
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle-devel >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libhogweed2-2.7.1-12.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libnettle-devel-2.7.1-12.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libhogweed6 >= 3.7.3-150400.2.21
  • libhogweed6-32bit >= 3.7.3-150400.2.21
  • libnettle-devel >= 3.7.3-150400.2.21
  • libnettle8 >= 3.7.3-150400.2.21
  • libnettle8-32bit >= 3.7.3-150400.2.21
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libhogweed6-3.7.3-150400.2.21
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libhogweed4 >= 3.4-2.12
  • libhogweed4-32bit >= 3.4-2.12
  • libnettle-devel >= 3.4-2.12
  • libnettle6 >= 3.4-2.12
  • libnettle6-32bit >= 3.4-2.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libhogweed4-3.4-2.12
SUSE Linux Enterprise Module for Desktop Applications 15 GA libhogweed4-32bit-3.4-2.12
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libhogweed2-2.7.1-12.1
SUSE Linux Enterprise Module for Basesystem 15
  • libhogweed4 >= 3.4-2.12
  • libnettle-devel >= 3.4-2.12
  • libnettle6 >= 3.4-2.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libhogweed4-3.4-2.12
SUSE Linux Enterprise Module for Desktop Applications 15
  • libhogweed4-32bit >= 3.4-2.12
  • libnettle6-32bit >= 3.4-2.12
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libhogweed4-32bit-3.4-2.12
SUSE Linux Enterprise Server 12 SP2
  • libhogweed2 >= 2.7.1-9.1
  • libhogweed2-32bit >= 2.7.1-9.1
  • libnettle-devel >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
  • libnettle4-32bit >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libhogweed2-2.7.1-9.1
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libnettle-devel-2.7.1-9.1
SUSE Linux Enterprise Server 12 SP3
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle-devel >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libhogweed2-2.7.1-12.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libnettle-devel-2.7.1-12.1
SUSE Linux Enterprise Server 12 SP4
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle-devel >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libhogweed2-2.7.1-12.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libnettle-devel-2.7.1-12.1
SUSE Linux Enterprise Server 12 SP5
  • libhogweed2 >= 2.7.1-12.1
  • libhogweed2-32bit >= 2.7.1-12.1
  • libnettle-devel >= 2.7.1-12.1
  • libnettle4 >= 2.7.1-12.1
  • libnettle4-32bit >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libhogweed2-2.7.1-12.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libnettle-devel-2.7.1-12.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libhogweed2 >= 2.7.1-9.1
  • libnettle4 >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libhogweed2-2.7.1-9.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libnettle-devel >= 2.7.1-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libnettle-devel-2.7.1-9.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libnettle-devel >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libnettle-devel-2.7.1-12.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libnettle-devel >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libnettle-devel-2.7.1-12.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libnettle-devel >= 2.7.1-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libnettle-devel-2.7.1-12.1
openSUSE Leap 15.0
  • libhogweed4 >= 3.4-lp150.2.3
  • libnettle6 >= 3.4-lp150.2.3
Patchnames:
openSUSE Leap 15.0 GA libhogweed4-3.4-lp150.2.3
openSUSE Leap 15.2
  • libhogweed4 >= 3.4.1-lp152.3.16
  • libhogweed4-32bit >= 3.4.1-lp152.3.16
  • libnettle6 >= 3.4.1-lp152.3.16
  • libnettle6-32bit >= 3.4.1-lp152.3.16
Patchnames:
openSUSE Leap 15.2 GA libhogweed4-3.4.1-lp152.3.1
openSUSE Leap 15.3
  • libhogweed4 >= 3.4.1-4.15.1
  • libhogweed4-32bit >= 3.4.1-4.15.1
  • libnettle6 >= 3.4.1-4.15.1
  • libnettle6-32bit >= 3.4.1-4.15.1
Patchnames:
openSUSE Leap 15.3 GA libhogweed4-3.4.1-4.15.1
openSUSE Leap 15.4
  • libhogweed6 >= 3.7.3-150400.2.21
  • libhogweed6-32bit >= 3.7.3-150400.2.21
  • libnettle8 >= 3.7.3-150400.2.21
  • libnettle8-32bit >= 3.7.3-150400.2.21
Patchnames:
openSUSE Leap 15.4 GA libhogweed6-3.7.3-150400.2.21
openSUSE Tumbleweed
  • libhogweed4 >= 3.3-1.1
  • libhogweed4-32bit >= 3.3-1.1
  • libnettle-devel >= 3.3-1.1
  • libnettle-devel-32bit >= 3.3-1.1
  • libnettle6 >= 3.3-1.1
  • libnettle6-32bit >= 3.3-1.1
  • nettle >= 3.3-1.1
Patchnames:
openSUSE Tumbleweed GA libhogweed4-3.3-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libnettle Released
SUSE Enterprise Storage 5 libnettle Released
SUSE Linux Enterprise Desktop 12 libnettle Released
SUSE Linux Enterprise Desktop 12 SP1 libnettle Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libnettle Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 libnettle Released
SUSE Linux Enterprise Server 12 libnettle Released
SUSE Linux Enterprise Server 12 SP1 libnettle Released
SUSE Linux Enterprise Server 12 SP2-BCL libnettle Released
SUSE Linux Enterprise Server 12 SP2-ESPOS libnettle Released
SUSE Linux Enterprise Server 12 SP2-LTSS libnettle Released
SUSE Linux Enterprise Server 12 SP3-BCL libnettle Released
SUSE Linux Enterprise Server 12 SP3-ESPOS libnettle Released
SUSE Linux Enterprise Server 12 SP3-LTSS libnettle Released
SUSE Linux Enterprise Server 12 SP4-ESPOS libnettle Released
SUSE Linux Enterprise Server 12 SP4-LTSS libnettle Released
SUSE Linux Enterprise Server 12 SP5 libnettle Released
SUSE Linux Enterprise Server for SAP Applications 12 libnettle Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libnettle Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libnettle Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libnettle Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libnettle Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libnettle Released
SUSE Linux Enterprise Software Development Kit 12 libnettle Released
SUSE Linux Enterprise Software Development Kit 12 SP1 libnettle Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libnettle Released
SUSE OpenStack Cloud 7 libnettle Released
SUSE OpenStack Cloud 8 libnettle Released
SUSE OpenStack Cloud 9 libnettle Released
SUSE OpenStack Cloud Crowbar 8 libnettle Released
SUSE OpenStack Cloud Crowbar 9 libnettle Released


SUSE Timeline for this CVE

CVE page created: Wed Feb 3 02:15:21 2016
CVE page last modified: Tue Nov 29 01:55:30 2022