Upstream information

CVE-2015-8734 at MITRE

Description

The dissect_nwp function in epan/dissectors/packet-nwp.c in the NWP dissector in Wireshark 2.0.x before 2.0.1 mishandles the packet type, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libwireshark9 >= 2.4.14-3.25.2
  • libwiretap7 >= 2.4.14-3.25.2
  • libwscodecs1 >= 2.4.14-3.25.2
  • libwsutil8 >= 2.4.14-3.25.2
  • wireshark >= 2.4.14-3.25.2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libwireshark13 >= 3.2.2-3.35.2
  • libwiretap10 >= 3.2.2-3.35.2
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil11 >= 3.2.2-3.35.2
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.2.2-3.35.2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libwireshark13 >= 3.2.8-3.44.1
  • libwiretap10 >= 3.2.8-3.44.1
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil11 >= 3.2.8-3.44.1
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.2.8-3.44.1
SUSE Linux Enterprise Module for Basesystem 15
  • libwireshark9 >= 2.4.6-1.31
  • libwiretap7 >= 2.4.6-1.31
  • libwscodecs1 >= 2.4.6-1.31
  • libwsutil8 >= 2.4.6-1.31
  • wireshark >= 2.4.6-1.31
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • wireshark-devel >= 2.4.14-3.25.2
  • wireshark-ui-qt >= 2.4.14-3.25.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • wireshark-devel >= 3.2.2-3.35.2
  • wireshark-ui-qt >= 3.2.2-3.35.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • wireshark-devel >= 3.2.8-3.44.1
  • wireshark-ui-qt >= 3.2.8-3.44.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • wireshark-devel >= 2.4.6-1.31
  • wireshark-ui-qt >= 2.4.6-1.31
openSUSE Tumbleweed
  • wireshark >= 2.2.2-1.1
  • wireshark-devel >= 2.2.2-1.1
  • wireshark-ui-gtk >= 2.2.2-1.1
  • wireshark-ui-qt >= 2.2.2-1.1
Patchnames:
openSUSE Tumbleweed GA wireshark-2.2.2-1.1