Upstream information

CVE-2015-8704 at MITRE

Description

apl_42.c in ISC BIND 9.x before 9.9.8-P3, 9.9.x, and 9.10.x before 9.10.3-P3 allows remote authenticated users to cause a denial of service (INSIST assertion failure and daemon exit) via a malformed Address Prefix List (APL) record.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.8
Vector AV:N/AC:L/Au:S/C:N/I:N/A:C AV:N/AC:L/Au:S/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Low Low
Authentication Single Single
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Complete Complete
SUSE Bugzilla entries: 962189 [RESOLVED / FIXED], 962190 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • bind >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
sledsp3-bind-12354
SUSE Linux Enterprise Desktop 11 SP4
  • bind >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
sledsp4-bind-12354
SUSE Linux Enterprise Desktop 12
  • bind >= 9.9.6P1-28.9.1
  • bind-libs >= 9.9.6P1-28.9.1
  • bind-libs-32bit >= 9.9.6P1-28.9.1
  • bind-utils >= 9.9.6P1-28.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-118
SUSE Linux Enterprise Desktop 12 SP1
  • bind >= 9.9.6P1-35.1
  • bind-libs >= 9.9.6P1-35.1
  • bind-libs-32bit >= 9.9.6P1-35.1
  • bind-utils >= 9.9.6P1-35.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-114
SUSE Linux Enterprise Desktop 12 SP2
  • bind-libs >= 9.9.9P1-46.1
  • bind-libs-32bit >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA bind-libs-32bit
SUSE Linux Enterprise Desktop 12 SP3
  • bind-libs >= 9.9.9P1-62.1
  • bind-libs-32bit >= 9.9.9P1-62.1
  • bind-utils >= 9.9.9P1-62.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA bind-libs-32bit
SUSE Linux Enterprise Module for Basesystem 15
  • bind-devel >= 9.11.2-10.4
  • bind-utils >= 9.11.2-10.4
  • libbind9-160 >= 9.11.2-10.4
  • libdns169 >= 9.11.2-10.4
  • libirs-devel >= 9.11.2-10.4
  • libirs160 >= 9.11.2-10.4
  • libisc166 >= 9.11.2-10.4
  • libisccc160 >= 9.11.2-10.4
  • libisccfg160 >= 9.11.2-10.4
  • liblwres160 >= 9.11.2-10.4
  • python3-bind >= 9.11.2-10.4
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA bind-devel
SUSE Linux Enterprise Module for Server Applications 15
  • bind >= 9.11.2-10.4
  • bind-chrootenv >= 9.11.2-10.4
  • bind-doc >= 9.11.2-10.4
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA bind
SUSE Linux Enterprise Server 11 SP2-LTSS
  • bind >= 9.9.6P1-0.22.1
  • bind-chrootenv >= 9.9.6P1-0.22.1
  • bind-devel >= 9.9.6P1-0.22.1
  • bind-doc >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
slessp2-bind-12354
SUSE Linux Enterprise Server 11 SP3
  • bind >= 9.9.6P1-0.22.1
  • bind-chrootenv >= 9.9.6P1-0.22.1
  • bind-doc >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-libs-x86 >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
slessp3-bind-12354
SUSE Linux Enterprise Server 11 SP4
  • bind >= 9.9.6P1-0.22.1
  • bind-chrootenv >= 9.9.6P1-0.22.1
  • bind-doc >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-libs-x86 >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
slessp4-bind-12354
SUSE Linux Enterprise Server 12
  • bind >= 9.9.6P1-28.9.1
  • bind-chrootenv >= 9.9.6P1-28.9.1
  • bind-doc >= 9.9.6P1-28.9.1
  • bind-libs >= 9.9.6P1-28.9.1
  • bind-libs-32bit >= 9.9.6P1-28.9.1
  • bind-utils >= 9.9.6P1-28.9.1
Patchnames:
SUSE-SLE-SERVER-12-2016-118
SUSE Linux Enterprise Server 12 SP1
  • bind >= 9.9.6P1-35.1
  • bind-chrootenv >= 9.9.6P1-35.1
  • bind-doc >= 9.9.6P1-35.1
  • bind-libs >= 9.9.6P1-35.1
  • bind-libs-32bit >= 9.9.6P1-35.1
  • bind-utils >= 9.9.6P1-35.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-114
SUSE Linux Enterprise Server 12 SP2
  • bind >= 9.9.9P1-46.1
  • bind-chrootenv >= 9.9.9P1-46.1
  • bind-doc >= 9.9.9P1-46.1
  • bind-libs >= 9.9.9P1-46.1
  • bind-libs-32bit >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA bind
SUSE Linux Enterprise Server 12 SP3
  • bind >= 9.9.9P1-62.1
  • bind-chrootenv >= 9.9.9P1-62.1
  • bind-doc >= 9.9.9P1-62.1
  • bind-libs >= 9.9.9P1-62.1
  • bind-libs-32bit >= 9.9.9P1-62.1
  • bind-utils >= 9.9.9P1-62.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA bind
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • bind >= 9.9.9P1-46.1
  • bind-chrootenv >= 9.9.9P1-46.1
  • bind-doc >= 9.9.9P1-46.1
  • bind-libs >= 9.9.9P1-46.1
  • bind-utils >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA bind
SUSE Linux Enterprise Server for SAP Applications 11 SP2-LTSS
  • bind >= 9.9.6P1-0.22.1
  • bind-chrootenv >= 9.9.6P1-0.22.1
  • bind-devel >= 9.9.6P1-0.22.1
  • bind-doc >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
slessp2-bind-12354
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • bind >= 9.9.6P1-0.22.1
  • bind-chrootenv >= 9.9.6P1-0.22.1
  • bind-doc >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-libs-x86 >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
slessp3-bind-12354
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • bind >= 9.9.6P1-0.22.1
  • bind-chrootenv >= 9.9.6P1-0.22.1
  • bind-doc >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-libs-x86 >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
slessp4-bind-12354
SUSE Linux Enterprise Server for SAP Applications 12
  • bind >= 9.9.6P1-28.9.1
  • bind-chrootenv >= 9.9.6P1-28.9.1
  • bind-doc >= 9.9.6P1-28.9.1
  • bind-libs >= 9.9.6P1-28.9.1
  • bind-libs-32bit >= 9.9.6P1-28.9.1
  • bind-utils >= 9.9.6P1-28.9.1
Patchnames:
SUSE-SLE-SERVER-12-2016-118
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • bind >= 9.9.6P1-35.1
  • bind-chrootenv >= 9.9.6P1-35.1
  • bind-doc >= 9.9.6P1-35.1
  • bind-libs >= 9.9.6P1-35.1
  • bind-libs-32bit >= 9.9.6P1-35.1
  • bind-utils >= 9.9.6P1-35.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-114
SUSE Linux Enterprise Server for VMWare 11 SP3
  • bind >= 9.9.6P1-0.22.1
  • bind-chrootenv >= 9.9.6P1-0.22.1
  • bind-doc >= 9.9.6P1-0.22.1
  • bind-libs >= 9.9.6P1-0.22.1
  • bind-libs-32bit >= 9.9.6P1-0.22.1
  • bind-libs-x86 >= 9.9.6P1-0.22.1
  • bind-utils >= 9.9.6P1-0.22.1
Patchnames:
slessp3-bind-12354
SUSE Linux Enterprise Software Development Kit 11 SP3
  • bind >= 9.9.6P1-0.22.1
  • bind-devel >= 9.9.6P1-0.22.1
  • bind-devel-32bit >= 9.9.6P1-0.22.1
Patchnames:
sdksp3-bind-12354
SUSE Linux Enterprise Software Development Kit 11 SP4
  • bind >= 9.9.6P1-0.22.1
  • bind-devel >= 9.9.6P1-0.22.1
  • bind-devel-32bit >= 9.9.6P1-0.22.1
Patchnames:
sdksp4-bind-12354
SUSE Linux Enterprise Software Development Kit 12
  • bind >= 9.9.6P1-28.9.1
  • bind-devel >= 9.9.6P1-28.9.1
Patchnames:
SUSE-SLE-SDK-12-2016-118
SUSE Linux Enterprise Software Development Kit 12 SP1
  • bind >= 9.9.6P1-35.1
  • bind-devel >= 9.9.6P1-35.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-114
SUSE Linux Enterprise Software Development Kit 12 SP2
  • bind-devel >= 9.9.9P1-46.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA bind-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • bind-devel >= 9.9.9P1-62.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA bind-devel
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • bind >= 9.6ESVR11P1-0.18.1
  • bind-chrootenv >= 9.6ESVR11P1-0.18.1
  • bind-devel >= 9.6ESVR11P1-0.18.1
  • bind-doc >= 9.6ESVR11P1-0.18.1
  • bind-libs >= 9.6ESVR11P1-0.18.1
  • bind-utils >= 9.6ESVR11P1-0.18.1
Builds
ZYPP Patch Nr: 9213
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • bind >= 9.6ESVR11P1-0.18.1
  • bind-chrootenv >= 9.6ESVR11P1-0.18.1
  • bind-devel >= 9.6ESVR11P1-0.18.1
  • bind-doc >= 9.6ESVR11P1-0.18.1
  • bind-libs >= 9.6ESVR11P1-0.18.1
  • bind-libs-32bit >= 9.6ESVR11P1-0.18.1
  • bind-utils >= 9.6ESVR11P1-0.18.1
Builds
ZYPP Patch Nr: 9213
openSUSE 13.1
  • bind >= 9.9.4P2-2.23.1
  • bind-chrootenv >= 9.9.4P2-2.23.1
  • bind-debuginfo >= 9.9.4P2-2.23.1
  • bind-debugsource >= 9.9.4P2-2.23.1
  • bind-devel >= 9.9.4P2-2.23.1
  • bind-doc >= 9.9.4P2-2.23.1
  • bind-libs >= 9.9.4P2-2.23.1
  • bind-libs-32bit >= 9.9.4P2-2.23.1
  • bind-libs-debuginfo >= 9.9.4P2-2.23.1
  • bind-libs-debuginfo-32bit >= 9.9.4P2-2.23.1
  • bind-lwresd >= 9.9.4P2-2.23.1
  • bind-lwresd-debuginfo >= 9.9.4P2-2.23.1
  • bind-utils >= 9.9.4P2-2.23.1
  • bind-utils-debuginfo >= 9.9.4P2-2.23.1
Patchnames:
2016-73
openSUSE Leap 15.0
  • bind >= 9.11.2-lp150.7.2
  • bind-chrootenv >= 9.11.2-lp150.7.2
  • bind-utils >= 9.11.2-lp150.7.2
  • libbind9-160 >= 9.11.2-lp150.7.2
  • libdns169 >= 9.11.2-lp150.7.2
  • libirs160 >= 9.11.2-lp150.7.2
  • libisc166 >= 9.11.2-lp150.7.2
  • libisccc160 >= 9.11.2-lp150.7.2
  • libisccfg160 >= 9.11.2-lp150.7.2
  • liblwres160 >= 9.11.2-lp150.7.2
  • python3-bind >= 9.11.2-lp150.7.2
Patchnames:
openSUSE Leap 15.0 GA bind
openSUSE Leap 42.1
  • bind >= 9.9.6P1-30.1
  • bind-chrootenv >= 9.9.6P1-30.1
  • bind-debuginfo >= 9.9.6P1-30.1
  • bind-debugsource >= 9.9.6P1-30.1
  • bind-devel >= 9.9.6P1-30.1
  • bind-doc >= 9.9.6P1-30.1
  • bind-libs >= 9.9.6P1-30.1
  • bind-libs-32bit >= 9.9.6P1-30.1
  • bind-libs-debuginfo >= 9.9.6P1-30.1
  • bind-libs-debuginfo-32bit >= 9.9.6P1-30.1
  • bind-lwresd >= 9.9.6P1-30.1
  • bind-lwresd-debuginfo >= 9.9.6P1-30.1
  • bind-utils >= 9.9.6P1-30.1
  • bind-utils-debuginfo >= 9.9.6P1-30.1
Patchnames:
openSUSE-2016-70
openSUSE Leap 42.2
  • bind >= 9.9.9P1-41.1
  • bind-chrootenv >= 9.9.9P1-41.1
  • bind-doc >= 9.9.9P1-41.1
  • bind-libs >= 9.9.9P1-41.1
  • bind-utils >= 9.9.9P1-41.1
Patchnames:
openSUSE Leap 42.2 GA bind
openSUSE Leap 42.3
  • bind >= 9.9.9P1-51.1
  • bind-chrootenv >= 9.9.9P1-51.1
  • bind-doc >= 9.9.9P1-51.1
  • bind-libs >= 9.9.9P1-51.1
  • bind-utils >= 9.9.9P1-51.1
Patchnames:
openSUSE Leap 42.3 GA bind
openSUSE Tumbleweed
  • bind >= 9.10.3P4-21.1
  • bind-chrootenv >= 9.10.3P4-21.1
  • bind-devel >= 9.10.3P4-21.1
  • bind-devel-32bit >= 9.10.3P4-21.1
  • bind-doc >= 9.10.3P4-21.1
  • bind-lwresd >= 9.10.3P4-21.1
  • bind-utils >= 9.10.3P4-21.1
  • idnkit >= 1.0-21.1
  • idnkit-devel >= 1.0-21.1
  • idnkit-devel-32bit >= 1.0-21.1
  • libbind9-140 >= 9.10.3P4-21.1
  • libbind9-140-32bit >= 9.10.3P4-21.1
  • libdns162 >= 9.10.3P4-21.1
  • libdns162-32bit >= 9.10.3P4-21.1
  • libidnkit1 >= 1.0-21.1
  • libidnkit1-32bit >= 1.0-21.1
  • libidnkitlite1 >= 1.0-21.1
  • libidnkitlite1-32bit >= 1.0-21.1
  • libidnkitres1 >= 1.0-21.1
  • libidnkitres1-32bit >= 1.0-21.1
  • libirs-devel >= 9.10.3P4-21.1
  • libirs141 >= 9.10.3P4-21.1
  • libirs141-32bit >= 9.10.3P4-21.1
  • libisc160 >= 9.10.3P4-21.1
  • libisc160-32bit >= 9.10.3P4-21.1
  • libisccc140 >= 9.10.3P4-21.1
  • libisccc140-32bit >= 9.10.3P4-21.1
  • libisccfg140 >= 9.10.3P4-21.1
  • libisccfg140-32bit >= 9.10.3P4-21.1
  • liblwres141 >= 9.10.3P4-21.1
  • liblwres141-32bit >= 9.10.3P4-21.1
Patchnames:
openSUSE Tumbleweed GA bind


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 bind Released
SUSE Linux Enterprise Desktop 10 SP4 bind Released
SUSE Linux Enterprise Desktop 11 SP1 bind Released
SUSE Linux Enterprise Desktop 11 SP2 bind Released
SUSE Linux Enterprise Desktop 11 SP3 bind Released
SUSE Linux Enterprise Desktop 11 SP4 bind Released
SUSE Linux Enterprise Desktop 12 GA bind Released
SUSE Linux Enterprise Desktop 12 SP1 bind Released
SUSE Linux Enterprise SDK 11 SP2 bind Released
SUSE Linux Enterprise SDK 11 SP3 bind Released
SUSE Linux Enterprise SDK 11 SP4 bind Released
SUSE Linux Enterprise SDK 12 GA bind Released
SUSE Linux Enterprise SDK 12 SP1 bind Released
SUSE Linux Enterprise Server 10 SP3 bind Released
SUSE Linux Enterprise Server 10 SP4 bind Released
SUSE Linux Enterprise Server 10 SP4 LTSS bind Released
SUSE Linux Enterprise Server 11 SP1 LTSS bind Released
SUSE Linux Enterprise Server 11 SP2 bind Released
SUSE Linux Enterprise Server 11 SP2 LTSS bind Released
SUSE Linux Enterprise Server 11 SP3 bind Released
SUSE Linux Enterprise Server 11 SP4 bind Released
SUSE Linux Enterprise Server 12 GA bind Released
SUSE Linux Enterprise Server 12 SP1 bind Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 bind Released
SUSE Linux Enterprise Server for VMWare 11 SP2 bind Released
SUSE Linux Enterprise Server for VMWare 11 SP3 bind Released