Upstream information

CVE-2015-4142 at MITRE

Description

Integer underflow in the WMM Action frame parser in hostapd 0.5.5 through 2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME functionality, allows remote attackers to cause a denial of service (crash) via a crafted frame, which triggers an out-of-bounds read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 915323 [RESOLVED / FIXED], 930078 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • wpa_supplicant >= 0.7.1-6.17.4
  • wpa_supplicant-gui >= 0.7.1-6.17.4
Patchnames:
sledsp3-wpa_supplicant-12252
SUSE Linux Enterprise Desktop 11 SP4
  • wpa_supplicant >= 0.7.1-6.17.4
  • wpa_supplicant-gui >= 0.7.1-6.17.4
Patchnames:
sledsp4-wpa_supplicant-12252
SUSE Linux Enterprise Desktop 12 SP1
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1351
SUSE Linux Enterprise Desktop 12 SP2
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA wpa_supplicant
SUSE Linux Enterprise Desktop 12 SP3
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA wpa_supplicant
SUSE Linux Enterprise Module for Basesystem 15
  • wpa_supplicant >= 2.6-2.50
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA wpa_supplicant
SUSE Linux Enterprise Server 11 SP3
  • wpa_supplicant >= 0.7.1-6.17.4
Patchnames:
slessp3-wpa_supplicant-12252
SUSE Linux Enterprise Server 11 SP4
  • wpa_supplicant >= 0.7.1-6.17.4
Patchnames:
slessp4-wpa_supplicant-12252
SUSE Linux Enterprise Server 12 SP1
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1351
SUSE Linux Enterprise Server 12 SP2
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA wpa_supplicant
SUSE Linux Enterprise Server 12 SP3
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA wpa_supplicant
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA wpa_supplicant
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • wpa_supplicant >= 0.7.1-6.17.4
Patchnames:
slessp3-wpa_supplicant-12252
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • wpa_supplicant >= 0.7.1-6.17.4
Patchnames:
slessp4-wpa_supplicant-12252
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • wpa_supplicant >= 2.2-14.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1351
SUSE Linux Enterprise Server for VMWare 11 SP3
  • wpa_supplicant >= 0.7.1-6.17.4
Patchnames:
slessp3-wpa_supplicant-12252
openSUSE 13.1
  • wpa_supplicant >= 2.0-3.14.1
  • wpa_supplicant-debuginfo >= 2.0-3.14.1
  • wpa_supplicant-debugsource >= 2.0-3.14.1
  • wpa_supplicant-gui >= 2.0-3.14.1
  • wpa_supplicant-gui-debuginfo >= 2.0-3.14.1
Patchnames:
openSUSE-2015-411
openSUSE Leap 15.0
  • wpa_supplicant >= 2.6-lp150.2.13
Patchnames:
openSUSE Leap 15.0 GA wpa_supplicant
openSUSE Leap 42.1
  • wpa_supplicant >= 2.2-8.1
  • wpa_supplicant-debuginfo >= 2.2-8.1
  • wpa_supplicant-debugsource >= 2.2-8.1
  • wpa_supplicant-gui >= 2.2-8.1
  • wpa_supplicant-gui-debuginfo >= 2.2-8.1
Patchnames:
openSUSE-2016-1104
openSUSE Leap 42.2
  • hostapd >= 2.6-5.3.1
  • hostapd-debuginfo >= 2.6-5.3.1
  • hostapd-debugsource >= 2.6-5.3.1
  • wpa_supplicant >= 2.2-8.2
  • wpa_supplicant-gui >= 2.2-8.2
Patchnames:
openSUSE Leap 42.2 GA wpa_supplicant
openSUSE-2017-1201
openSUSE Leap 42.3
  • hostapd >= 2.6-8.1
  • hostapd-debuginfo >= 2.6-8.1
  • hostapd-debugsource >= 2.6-8.1
  • wpa_supplicant >= 2.2-10.4
  • wpa_supplicant-gui >= 2.2-10.4
Patchnames:
openSUSE Leap 42.3 GA wpa_supplicant
openSUSE-2017-1201
openSUSE Tumbleweed
  • hostapd >= 2.6-1.1
  • wpa_supplicant >= 2.6-1.1
  • wpa_supplicant-gui >= 2.6-1.1
Patchnames:
openSUSE Tumbleweed GA hostapd
openSUSE Tumbleweed GA wpa_supplicant


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 wpa_supplicant Released
SUSE Linux Enterprise Desktop 11 SP3 wpa_supplicant Released
SUSE Linux Enterprise Desktop 11 SP4 wpa_supplicant Released
SUSE Linux Enterprise Desktop 12 GA wpa_supplicant Released
SUSE Linux Enterprise Desktop 12 SP1 wpa_supplicant Released
SUSE Linux Enterprise Desktop 12 SP2 wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP2 wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP2 LTSS wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP3 wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP3 LTSS wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP4 wpa_supplicant Released
SUSE Linux Enterprise Server 12 GA wpa_supplicant Released
SUSE Linux Enterprise Server 12 GA LTSS wpa_supplicant Released
SUSE Linux Enterprise Server 12 SP1 wpa_supplicant Released
SUSE Linux Enterprise Server 12 SP2 wpa_supplicant Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 wpa_supplicant Released
SUSE Linux Enterprise Server for VMWare 11 SP2 wpa_supplicant Released
SUSE Linux Enterprise Server for VMWare 11 SP3 wpa_supplicant Released