Upstream information

CVE-2015-3991 at MITRE

Description

strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 931272 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • strongswan >= 5.8.2-9.2
  • strongswan-doc >= 5.8.2-9.2
  • strongswan-hmac >= 5.8.2-9.2
  • strongswan-ipsec >= 5.8.2-9.2
  • strongswan-libs0 >= 5.8.2-9.2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • strongswan >= 5.8.2-11.8.4
  • strongswan-doc >= 5.8.2-11.8.4
  • strongswan-hmac >= 5.8.2-11.8.4
  • strongswan-ipsec >= 5.8.2-11.8.4
  • strongswan-libs0 >= 5.8.2-11.8.4
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • strongswan >= 5.6.0-2.43
  • strongswan-doc >= 5.6.0-2.43
  • strongswan-hmac >= 5.6.0-2.43
  • strongswan-ipsec >= 5.6.0-2.43
  • strongswan-libs0 >= 5.6.0-2.43
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
SUSE Linux Enterprise Workstation Extension 15 SP2
  • strongswan-nm >= 5.8.2-9.2
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • strongswan-nm >= 5.8.2-11.8.4
openSUSE Tumbleweed
  • strongswan >= 5.3.5-1.1
  • strongswan-doc >= 5.3.5-1.1
  • strongswan-hmac >= 5.3.5-1.1
  • strongswan-ipsec >= 5.3.5-1.1
  • strongswan-libs0 >= 5.3.5-1.1
  • strongswan-mysql >= 5.3.5-1.1
  • strongswan-nm >= 5.3.5-1.1
  • strongswan-sqlite >= 5.3.5-1.1
Patchnames:
openSUSE Tumbleweed GA strongswan


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 strongswan Already fixed
SUSE Enterprise Storage 6 strongswan Already fixed
SUSE Linux Enterprise Desktop 11 SP3 strongswan Not affected
SUSE Linux Enterprise Desktop 12 strongswan Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS strongswan Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS strongswan Already fixed
SUSE Linux Enterprise Server 11 SP3 strongswan Not affected
SUSE Linux Enterprise Server 11 SP3 for VMware strongswan Not affected
SUSE Linux Enterprise Server 12 strongswan Not affected
SUSE Linux Enterprise Server 15 LTSS strongswan Already fixed
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux strongswan Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS strongswan Already fixed
SUSE Linux Enterprise Server ESPOS 15 strongswan Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 strongswan Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 strongswan Already fixed
SUSE Manager Proxy 4.0 strongswan Already fixed
SUSE Manager Retail Branch Server 4.0 strongswan Already fixed
SUSE Manager Server 4.0 strongswan Already fixed