Upstream information

CVE-2015-3330 at MITRE

Description

The php_handler function in sapi/apache2handler/sapi_apache2.c in PHP before 5.4.40, 5.5.x before 5.5.24, and 5.6.x before 5.6.8, when the Apache HTTP Server 2.4.x is used, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via pipelined HTTP requests that result in a "deconfigured interpreter."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 908782 [RESOLVED / NORESPONSE], 928408 [RESOLVED / FIXED], 928506 [RESOLVED / FIXED], 928511 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Web Scripting 12
  • apache2-mod_php5 >= 5.5.14-22.1
  • php5 >= 5.5.14-22.1
  • php5-bcmath >= 5.5.14-22.1
  • php5-bz2 >= 5.5.14-22.1
  • php5-calendar >= 5.5.14-22.1
  • php5-ctype >= 5.5.14-22.1
  • php5-curl >= 5.5.14-22.1
  • php5-dba >= 5.5.14-22.1
  • php5-dom >= 5.5.14-22.1
  • php5-enchant >= 5.5.14-22.1
  • php5-exif >= 5.5.14-22.1
  • php5-fastcgi >= 5.5.14-22.1
  • php5-fileinfo >= 5.5.14-22.1
  • php5-fpm >= 5.5.14-22.1
  • php5-ftp >= 5.5.14-22.1
  • php5-gd >= 5.5.14-22.1
  • php5-gettext >= 5.5.14-22.1
  • php5-gmp >= 5.5.14-22.1
  • php5-iconv >= 5.5.14-22.1
  • php5-intl >= 5.5.14-22.1
  • php5-json >= 5.5.14-22.1
  • php5-ldap >= 5.5.14-22.1
  • php5-mbstring >= 5.5.14-22.1
  • php5-mcrypt >= 5.5.14-22.1
  • php5-mysql >= 5.5.14-22.1
  • php5-odbc >= 5.5.14-22.1
  • php5-openssl >= 5.5.14-22.1
  • php5-pcntl >= 5.5.14-22.1
  • php5-pdo >= 5.5.14-22.1
  • php5-pear >= 5.5.14-22.1
  • php5-pgsql >= 5.5.14-22.1
  • php5-pspell >= 5.5.14-22.1
  • php5-shmop >= 5.5.14-22.1
  • php5-snmp >= 5.5.14-22.1
  • php5-soap >= 5.5.14-22.1
  • php5-sockets >= 5.5.14-22.1
  • php5-sqlite >= 5.5.14-22.1
  • php5-suhosin >= 5.5.14-22.1
  • php5-sysvmsg >= 5.5.14-22.1
  • php5-sysvsem >= 5.5.14-22.1
  • php5-sysvshm >= 5.5.14-22.1
  • php5-tokenizer >= 5.5.14-22.1
  • php5-wddx >= 5.5.14-22.1
  • php5-xmlreader >= 5.5.14-22.1
  • php5-xmlrpc >= 5.5.14-22.1
  • php5-xmlwriter >= 5.5.14-22.1
  • php5-xsl >= 5.5.14-22.1
  • php5-zip >= 5.5.14-22.1
  • php5-zlib >= 5.5.14-22.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2015-192
SUSE Linux Enterprise Software Development Kit 12 SP1
  • php5-devel >= 5.5.14-39.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • php5-devel >= 5.5.14-73.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • php5-devel >= 5.5.14-108.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • php5-devel >= 5.5.14-109.41.1
SUSE Linux Enterprise Software Development Kit 12
  • php5-devel >= 5.5.14-22.1
Patchnames:
SUSE-SLE-SDK-12-2015-192


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Released
SUSE Linux Enterprise Server 11 SP3 php53 Ignore
SUSE Linux Enterprise Server 11 SP3 for VMware php53 Ignore
SUSE Linux Enterprise Software Development Kit 11 SP3 php53 Ignore
SUSE Linux Enterprise Software Development Kit 12 php5 Released
SUSE Linux Enterprise Software Development Kit 12 SP1 php5 Released