Upstream information

CVE-2015-3239 at MITRE

Description

Off-by-one error in the dwarf_to_unw_regnum function in include/dwarf_i.h in libunwind 1.1 allows local users to have unspecified impact via invalid dwarf opcodes.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 3.3 3.3
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact None None
SUSE Bugzilla entry: 936786 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libunwind >= 1.2.1-2.13
  • libunwind-devel >= 1.2.1-2.13
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libunwind
openSUSE 13.1
  • libunwind >= 1.1-6.3.1
  • libunwind-32bit >= 1.1-6.3.1
  • libunwind-debuginfo >= 1.1-6.3.1
  • libunwind-debuginfo-32bit >= 1.1-6.3.1
  • libunwind-debugsource >= 1.1-6.3.1
  • libunwind-devel >= 1.1-6.3.1
Patchnames:
openSUSE-2015-491
openSUSE Leap 15.0
  • libunwind >= 1.2.1-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libunwind
openSUSE Tumbleweed
  • libunwind >= 1.2~rc1-2.3
  • libunwind-32bit >= 1.2~rc1-2.3
  • libunwind-devel >= 1.2~rc1-2.3
Patchnames:
openSUSE Tumbleweed GA libunwind


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP3 libunwind Affected
SUSE Linux Enterprise SDK 11 SP4 libunwind Affected
SUSE Linux Enterprise SDK 12 GA libunwind Affected
SUSE Linux Enterprise Server 11 SP3 libunwind Affected
SUSE Linux Enterprise Server 11 SP4 libunwind Affected
SUSE Linux Enterprise Server 12 GA libunwind Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 libunwind Affected