Upstream information

CVE-2015-3239 at MITRE

Description

Off-by-one error in the dwarf_to_unw_regnum function in include/dwarf_i.h in libunwind 1.1 allows local users to have unspecified impact via invalid dwarf opcodes.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 3.3 3.3
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  SUSE
Base Score 4
Vector CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Access Vector Local
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1122012 [RESOLVED / FIXED], 936786 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libunwind >= 1.1-11.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-284
SUSE Linux Enterprise Desktop 12 SP4
  • libunwind >= 1.1-11.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-284
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libunwind >= 1.1-11.3.1
  • libunwind-devel >= 1.1-11.3.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libunwind >= 1.5.0-4.5.1
  • libunwind-devel >= 1.5.0-4.5.1
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libunwind >= 1.2.1-2.13
  • libunwind-devel >= 1.2.1-2.13
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • libunwind-32bit >= 1.2.1-2.13
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • libunwind-32bit >= 1.5.0-4.5.1
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libunwind >= 1.1-11.3.1
  • libunwind-devel >= 1.1-11.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-284
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libunwind >= 1.1-11.3.1
  • libunwind-devel >= 1.1-11.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-284
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libunwind-devel >= 1.1-11.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-284
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libunwind-devel >= 1.1-11.3.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-284
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libunwind-devel >= 1.1-11.3.1
openSUSE Leap 15.0
  • libunwind >= 1.2.1-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libunwind-1.2.1-lp150.2.1
openSUSE Tumbleweed
  • libunwind >= 1.2~rc1-2.3
  • libunwind-32bit >= 1.2~rc1-2.3
  • libunwind-devel >= 1.2~rc1-2.3
Patchnames:
openSUSE Tumbleweed GA libunwind-1.2~rc1-2.3


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 libunwind In progress
SUSE Linux Enterprise Desktop 12 SP3 libunwind Released
SUSE Linux Enterprise Desktop 12 SP4 libunwind Released
SUSE Linux Enterprise High Performance Computing 12 SP4 libunwind Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libunwind In progress
SUSE Linux Enterprise Point of Service 11 SP3 libunwind Released
SUSE Linux Enterprise Server 11 SP3 libunwind Affected
SUSE Linux Enterprise Server 11 SP3 for VMware libunwind Affected
SUSE Linux Enterprise Server 11 SP4 libunwind Affected
SUSE Linux Enterprise Server 11 SP4 LTSS libunwind Released
SUSE Linux Enterprise Server 12 libunwind Affected
SUSE Linux Enterprise Server 12 SP2 BCL libunwind In progress
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON libunwind In progress
SUSE Linux Enterprise Server 12 SP2 LTSS SAP libunwind In progress
SUSE Linux Enterprise Server 12 SP3 libunwind Released
SUSE Linux Enterprise Server 12 SP3 BCL libunwind In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS libunwind In progress
SUSE Linux Enterprise Server 12 SP3 LTSS libunwind In progress
SUSE Linux Enterprise Server 12 SP4 libunwind Released
SUSE Linux Enterprise Server 12 SP4 ESPOS libunwind In progress
SUSE Linux Enterprise Server 12 SP4 LTSS libunwind In progress
SUSE Linux Enterprise Server 12 SP5 libunwind In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libunwind In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libunwind Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libunwind In progress
SUSE Linux Enterprise Software Development Kit 11 SP3 libunwind Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 libunwind Affected
SUSE Linux Enterprise Software Development Kit 12 libunwind Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libunwind Released
SUSE Linux Enterprise Software Development Kit 12 SP4 libunwind Released
SUSE OpenStack Cloud 8 libunwind In progress
SUSE OpenStack Cloud 9 libunwind In progress
SUSE OpenStack Cloud Crowbar 8 libunwind In progress
SUSE OpenStack Cloud Crowbar 9 libunwind In progress