Upstream information

CVE-2015-1283 at MITRE

Description

Multiple integer overflows in the XML_GetBuffer function in Expat through 2.1.0, as used in Google Chrome before 44.0.2403.89 and other products, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted XML data, a related issue to CVE-2015-2716.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
SUSE Bugzilla entries: 1034050 [RESOLVED / NORESPONSE], 939077 [RESOLVED / FIXED], 979441 [RESOLVED / FIXED], 980391 [RESOLVED / FIXED], 983985 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/default-http-backend:beta1
Container caasp/v4/dnsmasq-nanny:2.78
Container caasp/v4/flannel:0.9.1
Container caasp/v4/haproxy:beta1
Container caasp/v4/kubedns:beta1
Container caasp/v4/nginx-ingress-controller:beta1
Container caasp/v4/openldap:beta1
Container caasp/v4/pause:1.0.0
Container caasp/v4/pv-recycler-node:8.25
Container caasp/v4/salt-api:beta1
Container caasp/v4/salt-master:beta1
Container caasp/v4/salt-minion:beta1
Container caasp/v4/sidecar:beta1
Container caasp/v4/velum:4.0.0
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
Container suse/sles12sp4:latest
Container suse/sles12sp5:latest
  • libexpat1 >= 2.1.0-17.1
SUSE Linux Enterprise Desktop 12 SP1
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-898
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • expat >= 2.1.0-20.2
  • libexpat1 >= 2.1.0-20.2
  • libexpat1-32bit >= 2.1.0-20.2
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • expat >= 2.1.0-21.3.1
  • libexpat1 >= 2.1.0-21.3.1
  • libexpat1-32bit >= 2.1.0-21.3.1
SUSE Linux Enterprise Desktop 12
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-898
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • expat >= 2.1.0-21.9.1
  • libexpat1 >= 2.1.0-21.9.1
  • libexpat1-32bit >= 2.1.0-21.9.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • expat >= 2.2.5-3.6.1
  • libexpat-devel >= 2.2.5-3.6.1
  • libexpat1 >= 2.2.5-3.6.1
  • libexpat1-32bit >= 2.2.5-3.6.1
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • expat >= 2.2.5-1.140
  • libexpat-devel >= 2.2.5-1.140
  • libexpat1 >= 2.2.5-1.140
  • libexpat1-32bit >= 2.2.5-1.140
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • expat >= 2.0.1-88.38.1
  • libexpat1 >= 2.0.1-88.38.1
  • libexpat1-32bit >= 2.0.1-88.38.1
  • libexpat1-x86 >= 2.0.1-88.38.1
Patchnames:
slessp4-expat-12600
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-898
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • expat >= 2.1.0-17.1
  • libexpat1 >= 2.1.0-17.1
  • libexpat1-32bit >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SERVER-12-2016-898
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libexpat-devel >= 2.0.1-88.38.1
Patchnames:
sdksp4-expat-12600
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libexpat-devel >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-898
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libexpat-devel >= 2.1.0-17.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libexpat-devel >= 2.1.0-20.2
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libexpat-devel >= 2.1.0-21.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libexpat-devel >= 2.1.0-21.9.1
SUSE Linux Enterprise Software Development Kit 12
  • libexpat-devel >= 2.1.0-17.1
Patchnames:
SUSE-SLE-SDK-12-2016-898
SUSE Studio Onsite 1.3
  • libexpat-devel >= 2.0.1-88.38.1
Patchnames:
slestso13-expat-12600
openSUSE Leap 15.0
  • chromium >= 66.0.3359.170-lp150.1.1
  • expat >= 2.2.5-lp150.1.9
  • libexpat1 >= 2.2.5-lp150.1.9
Patchnames:
openSUSE Leap 15.0 GA chromium-66.0.3359.170-lp150.1.1
openSUSE Leap 15.0 GA expat-2.2.5-lp150.1.9
openSUSE Tumbleweed
  • chromedriver >= 55.0.2883.75-3.1
  • chromium >= 55.0.2883.75-3.1
  • expat >= 2.2.0-3.1
  • libexpat-devel >= 2.2.0-3.1
  • libexpat-devel-32bit >= 2.2.0-3.1
  • libexpat1 >= 2.2.0-3.1
  • libexpat1-32bit >= 2.2.0-3.1
Patchnames:
openSUSE Tumbleweed GA chromedriver-55.0.2883.75-3.1
openSUSE Tumbleweed GA expat-2.2.0-3.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 expat In progress
SLES-LTSS-SAP expat In progress
SUSE Linux Enterprise High Performance Computing 12 SP5 expat Released
SUSE Linux Enterprise Module for Containers 12 sles12-docker-image Released
SUSE Linux Enterprise Module for Containers 12 sles12sp1-docker-image Released
SUSE Linux Enterprise Point of Service 11 SP3 expat In progress
SUSE Linux Enterprise Server 11 SP4 LTSS expat In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS expat In progress
SUSE Linux Enterprise Server 12 SP3 LTSS expat In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS expat In progress
SUSE Linux Enterprise Server 12 SP4 LTSS expat In progress
SUSE Linux Enterprise Server 12 SP5 expat Released
SUSE Linux Enterprise Server BCL 12 SP2 expat In progress
SUSE Linux Enterprise Server BCL 12 SP3 expat In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 expat In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 expat In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 expat Released
SUSE OpenStack Cloud 8 expat In progress
SUSE OpenStack Cloud 9 expat In progress
SUSE OpenStack Cloud Crowbar 8 expat In progress
SUSE OpenStack Cloud Crowbar 9 expat In progress