Upstream information

CVE-2015-0235 at MITRE

Description

Heap-based buffer overflow in the __nss_hostname_digits_dots function in glibc 2.2, and other 2.x versions before 2.18, allows context-dependent attackers to execute arbitrary code via vectors related to the (1) gethostbyname or (2) gethostbyname2 function, aka "GHOST."

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 10.00
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete

Note from the SUSE Security Team

This problem nicknamed "GHOST" affects SUSE Linux Enterprise 11 and older products. SUSE Linux Enterprise 12, openSUSE 13.1 and 13.2 and newer are not affected as they shipped with a already fixed glibc.

SUSE Bugzilla entries: 844309 [RESOLVED / ], 913646 [RESOLVED / ], 915263, 917876 [RESOLVED / ], 920055 [RESOLVED / ], 949238 [RESOLVED / FIXED], 954983 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • glibc >= 2.11.3-17.74.13
  • glibc-32bit >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-devel-32bit >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • glibc-locale-32bit >= 2.11.3-17.74.13
  • nscd >= 2.11.3-17.74.13
Patchnames:
sledsp3-glibc
SUSE Linux Enterprise Server 11 SP1-LTSS
  • glibc >= 2.11.1-0.60.1
  • glibc-32bit >= 2.11.1-0.60.1
  • glibc-devel >= 2.11.1-0.60.1
  • glibc-devel-32bit >= 2.11.1-0.60.1
  • glibc-html >= 2.11.1-0.60.1
  • glibc-i18ndata >= 2.11.1-0.60.1
  • glibc-info >= 2.11.1-0.60.1
  • glibc-locale >= 2.11.1-0.60.1
  • glibc-locale-32bit >= 2.11.1-0.60.1
  • glibc-profile >= 2.11.1-0.60.1
  • glibc-profile-32bit >= 2.11.1-0.60.1
  • nscd >= 2.11.1-0.60.1
Patchnames:
slessp1-glibc
SUSE Linux Enterprise Server 11 SP2-LTSS
  • glibc >= 2.11.3-17.45.55.5
  • glibc-32bit >= 2.11.3-17.45.55.5
  • glibc-devel >= 2.11.3-17.45.55.5
  • glibc-devel-32bit >= 2.11.3-17.45.55.5
  • glibc-html >= 2.11.3-17.45.55.5
  • glibc-i18ndata >= 2.11.3-17.45.55.5
  • glibc-info >= 2.11.3-17.45.55.5
  • glibc-locale >= 2.11.3-17.45.55.5
  • glibc-locale-32bit >= 2.11.3-17.45.55.5
  • glibc-profile >= 2.11.3-17.45.55.5
  • glibc-profile-32bit >= 2.11.3-17.45.55.5
  • nscd >= 2.11.3-17.45.55.5
Patchnames:
slessp2-glibc
SUSE Linux Enterprise Server 11 SP3
  • glibc >= 2.11.3-17.74.13
  • glibc-32bit >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-devel-32bit >= 2.11.3-17.74.13
  • glibc-html >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-info >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • glibc-locale-32bit >= 2.11.3-17.74.13
  • glibc-locale-x86 >= 2.11.3-17.72.14
  • glibc-profile >= 2.11.3-17.74.13
  • glibc-profile-32bit >= 2.11.3-17.74.13
  • glibc-profile-x86 >= 2.11.3-17.72.14
  • glibc-x86 >= 2.11.3-17.72.14
  • nscd >= 2.11.3-17.74.13
Patchnames:
slessp3-glibc
SUSE Linux Enterprise Server for VMWare 11 SP3
  • glibc >= 2.11.3-17.74.13
  • glibc-32bit >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-devel-32bit >= 2.11.3-17.74.13
  • glibc-html >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-info >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • glibc-locale-32bit >= 2.11.3-17.74.13
  • glibc-locale-x86 >= 2.11.3-17.72.14
  • glibc-profile >= 2.11.3-17.74.13
  • glibc-profile-32bit >= 2.11.3-17.74.13
  • glibc-profile-x86 >= 2.11.3-17.72.14
  • glibc-x86 >= 2.11.3-17.72.14
  • nscd >= 2.11.3-17.74.13
Patchnames:
slessp3-glibc
SUSE Linux Enterprise Software Development Kit 11 SP3
  • glibc-html >= 2.11.3-17.74.13
  • glibc-info >= 2.11.3-17.74.13
Patchnames:
sdksp3-glibc
SUSE Linux Enterprise Server 11 SP2 LTSS
  • glibc >= 2.11.3-17.45.55.5
  • glibc-devel >= 2.11.3-17.45.55.5
  • glibc-html >= 2.11.3-17.45.55.5
  • glibc-i18ndata >= 2.11.3-17.45.55.5
  • glibc-info >= 2.11.3-17.45.55.5
  • glibc-locale >= 2.11.3-17.45.55.5
  • glibc-profile >= 2.11.3-17.45.55.5
  • nscd >= 2.11.3-17.45.55.5
Builds
SAT Patch Nr: 10204
SUSE Linux Enterprise Server 11 SP2 LTSS
  • glibc >= 2.11.3-17.45.55.5
  • glibc-32bit >= 2.11.3-17.45.55.5
  • glibc-devel >= 2.11.3-17.45.55.5
  • glibc-devel-32bit >= 2.11.3-17.45.55.5
  • glibc-html >= 2.11.3-17.45.55.5
  • glibc-i18ndata >= 2.11.3-17.45.55.5
  • glibc-info >= 2.11.3-17.45.55.5
  • glibc-locale >= 2.11.3-17.45.55.5
  • glibc-locale-32bit >= 2.11.3-17.45.55.5
  • glibc-profile >= 2.11.3-17.45.55.5
  • glibc-profile-32bit >= 2.11.3-17.45.55.5
  • nscd >= 2.11.3-17.45.55.5
Builds
SAT Patch Nr: 10204
SUSE Linux Enterprise Software Development Kit 11 SP3
  • glibc-html >= 2.11.3-17.74.13
  • glibc-info >= 2.11.3-17.74.13
Builds
SAT Patch Nr: 10206
SUSE Linux Enterprise Desktop 11 SP3
  • glibc >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • nscd >= 2.11.3-17.74.13
Builds
SAT Patch Nr: 10206
SUSE Linux Enterprise Desktop 11 SP3
  • glibc >= 2.11.3-17.74.13
  • glibc-32bit >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-devel-32bit >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • glibc-locale-32bit >= 2.11.3-17.74.13
  • nscd >= 2.11.3-17.74.13
Builds
SAT Patch Nr: 10206
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • glibc >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-html >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-info >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • glibc-profile >= 2.11.3-17.74.13
  • nscd >= 2.11.3-17.74.13
Builds
SAT Patch Nr: 10206
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • glibc >= 2.11.3-17.74.13
  • glibc-32bit >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-devel-32bit >= 2.11.3-17.74.13
  • glibc-html >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-info >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • glibc-locale-32bit >= 2.11.3-17.74.13
  • glibc-profile >= 2.11.3-17.74.13
  • glibc-profile-32bit >= 2.11.3-17.74.13
  • nscd >= 2.11.3-17.74.13
Builds
SAT Patch Nr: 10206
SUSE Linux Enterprise Server 11 SP3
  • glibc >= 2.11.3-17.74.13
  • glibc-devel >= 2.11.3-17.74.13
  • glibc-html >= 2.11.3-17.74.13
  • glibc-i18ndata >= 2.11.3-17.74.13
  • glibc-info >= 2.11.3-17.74.13
  • glibc-locale >= 2.11.3-17.74.13
  • glibc-locale-x86 >= 2.11.3-17.74.13
  • glibc-profile >= 2.11.3-17.74.13
  • glibc-profile-x86 >= 2.11.3-17.74.13
  • glibc-x86 >= 2.11.3-17.74.13
  • nscd >= 2.11.3-17.74.13
Builds
SAT Patch Nr: 10206
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • glibc >= 2.4-31.113.3
  • glibc-devel >= 2.4-31.113.3
  • glibc-html >= 2.4-31.113.3
  • glibc-i18ndata >= 2.4-31.113.3
  • glibc-info >= 2.4-31.113.3
  • glibc-locale >= 2.4-31.113.3
  • glibc-profile >= 2.4-31.113.3
  • nscd >= 2.4-31.113.3
Builds
ZYPP Patch Nr: 9035
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • glibc >= 2.4-31.113.3
  • glibc-32bit >= 2.4-31.113.3
  • glibc-devel >= 2.4-31.113.3
  • glibc-devel-32bit >= 2.4-31.113.3
  • glibc-html >= 2.4-31.113.3
  • glibc-i18ndata >= 2.4-31.113.3
  • glibc-info >= 2.4-31.113.3
  • glibc-locale >= 2.4-31.113.3
  • glibc-locale-32bit >= 2.4-31.113.3
  • glibc-profile >= 2.4-31.113.3
  • glibc-profile-32bit >= 2.4-31.113.3
  • nscd >= 2.4-31.113.3
Builds
ZYPP Patch Nr: 9035
SUSE Linux Enterprise Server 11 SP1 LTSS
  • glibc >= 2.11.1-0.60.1
  • glibc-devel >= 2.11.1-0.60.1
  • glibc-html >= 2.11.1-0.60.1
  • glibc-i18ndata >= 2.11.1-0.60.1
  • glibc-info >= 2.11.1-0.60.1
  • glibc-locale >= 2.11.1-0.60.1
  • glibc-profile >= 2.11.1-0.60.1
  • nscd >= 2.11.1-0.60.1
Builds
SAT Patch Nr: 10202
SUSE Linux Enterprise Server 11 SP1 LTSS
  • glibc >= 2.11.1-0.60.1
  • glibc-32bit >= 2.11.1-0.60.1
  • glibc-devel >= 2.11.1-0.60.1
  • glibc-devel-32bit >= 2.11.1-0.60.1
  • glibc-html >= 2.11.1-0.60.1
  • glibc-i18ndata >= 2.11.1-0.60.1
  • glibc-info >= 2.11.1-0.60.1
  • glibc-locale >= 2.11.1-0.60.1
  • glibc-locale-32bit >= 2.11.1-0.60.1
  • glibc-profile >= 2.11.1-0.60.1
  • glibc-profile-32bit >= 2.11.1-0.60.1
  • nscd >= 2.11.1-0.60.1
Builds
SAT Patch Nr: 10202
openSUSE 12.3
  • glibc >= 2.17-4.17.1
  • glibc-debuginfo >= 2.17-4.17.1
  • glibc-debugsource >= 2.17-4.17.1
  • glibc-devel >= 2.17-4.17.1
  • glibc-devel-debuginfo >= 2.17-4.17.1
  • glibc-devel-static >= 2.17-4.17.1
  • glibc-extra >= 2.17-4.17.1
  • glibc-extra-debuginfo >= 2.17-4.17.1
  • glibc-html >= 2.17-4.17.1
  • glibc-i18ndata >= 2.17-4.17.1
  • glibc-info >= 2.17-4.17.1
  • glibc-locale >= 2.17-4.17.1
  • glibc-locale-debuginfo >= 2.17-4.17.1
  • glibc-obsolete >= 2.17-4.17.1
  • glibc-obsolete-debuginfo >= 2.17-4.17.1
  • glibc-profile >= 2.17-4.17.1
  • glibc-testsuite >= 2.17-4.17.2
  • glibc-utils >= 2.17-4.17.1
  • glibc-utils-32bit >= 2.17-4.17.1
  • glibc-utils-debuginfo >= 2.17-4.17.1
  • glibc-utils-debuginfo-32bit >= 2.17-4.17.1
  • glibc-utils-debugsource >= 2.17-4.17.1
  • nscd >= 2.17-4.17.1
  • nscd-debuginfo >= 2.17-4.17.1
Patchnames:
openSUSE-2015-84
openSUSE Evergreen 11.4
  • glibc >= 2.11.3-12.66.1
  • glibc-32bit >= 2.11.3-12.66.1
  • glibc-debuginfo >= 2.11.3-12.66.1
  • glibc-debuginfo-32bit >= 2.11.3-12.66.1
  • glibc-debuginfo-x86 >= 2.11.3-12.66.1
  • glibc-debugsource >= 2.11.3-12.66.1
  • glibc-devel >= 2.11.3-12.66.1
  • glibc-devel-32bit >= 2.11.3-12.66.1
  • glibc-devel-debuginfo >= 2.11.3-12.66.1
  • glibc-devel-debuginfo-32bit >= 2.11.3-12.66.1
  • glibc-devel-debuginfo-x86 >= 2.11.3-12.66.1
  • glibc-html >= 2.11.3-12.66.1
  • glibc-i18ndata >= 2.11.3-12.66.1
  • glibc-info >= 2.11.3-12.66.1
  • glibc-locale >= 2.11.3-12.66.1
  • glibc-locale-32bit >= 2.11.3-12.66.1
  • glibc-locale-debuginfo >= 2.11.3-12.66.1
  • glibc-locale-debuginfo-32bit >= 2.11.3-12.66.1
  • glibc-locale-debuginfo-x86 >= 2.11.3-12.66.1
  • glibc-locale-x86 >= 2.11.3-12.66.1
  • glibc-obsolete >= 2.11.3-12.66.1
  • glibc-obsolete-debuginfo >= 2.11.3-12.66.1
  • glibc-profile >= 2.11.3-12.66.1
  • glibc-profile-32bit >= 2.11.3-12.66.1
  • glibc-profile-x86 >= 2.11.3-12.66.1
  • glibc-x86 >= 2.11.3-12.66.1
  • nscd >= 2.11.3-12.66.1
  • nscd-debuginfo >= 2.11.3-12.66.1
Patchnames:
2015-6