Upstream information

CVE-2015-0138 at MITRE

Description

GSKit in IBM Tivoli Directory Server (ITDS) 6.0 before 6.0.0.73-ISS-ITDS-IF0073, 6.1 before 6.1.0.66-ISS-ITDS-IF0066, 6.2 before 6.2.0.42-ISS-ITDS-IF0042, and 6.3 before 6.3.0.35-ISS-ITDS-IF0035 and IBM Security Directory Server (ISDS) 6.3.1 before 6.3.1.9-ISS-ISDS-IF0009 does not properly restrict TLS state transitions, which makes it easier for remote attackers to conduct cipher-downgrade attacks to EXPORT_RSA ciphers via crafted TLS traffic, related to the "FREAK" issue, a different vulnerability than CVE-2015-0204.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 952088 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • java-1_7_1-ibm >= 1.7.1_sr4.50-38.41.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr4.50-38.41.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr4.50-38.41.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr4.50-38.41.1
SUSE Linux Enterprise Module for Legacy 12
  • java-1_6_0-ibm >= 1.6.0_sr16.4-15.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr16.4-15.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr16.4-15.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr16.4-15.1
Patchnames:
SUSE-SLE-Module-Legacy-12-2015-288
SUSE Linux Enterprise Server 11 SP1-LTSS
  • java-1_6_0-ibm >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-alsa >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr16.4-0.3.1
Patchnames:
slessp1-java-1_6_0-ibm
SUSE Linux Enterprise Server 11 SP2-LTSS
  • java-1_6_0-ibm >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-alsa >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-devel >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr16.4-0.3.1
  • java-1_7_0-ibm >= 1.7.0_sr9.0-0.7.1
  • java-1_7_0-ibm-alsa >= 1.7.0_sr9.0-0.7.1
  • java-1_7_0-ibm-devel >= 1.7.0_sr9.0-0.7.1
  • java-1_7_0-ibm-jdbc >= 1.7.0_sr9.0-0.7.1
  • java-1_7_0-ibm-plugin >= 1.7.0_sr9.0-0.7.1
Patchnames:
slessp2-java-1_6_0-ibm
slessp2-java-1_7_0-ibm
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • java-1_6_0-ibm >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-alsa >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr16.4-0.3.1
  • java-1_7_0-ibm >= 1.7.0_sr9.0-0.7.1
  • java-1_7_0-ibm-alsa >= 1.7.0_sr9.0-0.7.1
  • java-1_7_0-ibm-jdbc >= 1.7.0_sr9.0-0.7.1
  • java-1_7_0-ibm-plugin >= 1.7.0_sr9.0-0.7.1
Patchnames:
slessp3-java-1_6_0-ibm
slessp3-java-1_7_0-ibm
SUSE Linux Enterprise Server 11 SP4
  • java-1_7_1-ibm >= 1.7.1_sr3.0-1.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr3.0-1.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr3.0-1.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr3.0-1.1
SUSE Linux Enterprise Server 12 SP1
  • java-1_7_1-ibm >= 1.7.1_sr3.10-14.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr3.10-14.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr3.10-14.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr3.10-14.1
SUSE Linux Enterprise Server 12 SP2
  • java-1_7_1-ibm >= 1.7.1_sr3.50-28.2
  • java-1_7_1-ibm-alsa >= 1.7.1_sr3.50-28.2
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr3.50-28.2
  • java-1_7_1-ibm-plugin >= 1.7.1_sr3.50-28.2
SUSE Linux Enterprise Server 12 SP3
  • java-1_7_1-ibm >= 1.7.1_sr4.5-37.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr4.5-37.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr4.5-37.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr4.5-37.1
SUSE Linux Enterprise Server 12 SP4
  • java-1_7_1-ibm >= 1.7.1_sr4.30-38.26.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr4.30-38.26.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr4.30-38.26.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr4.30-38.26.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • java-1_7_1-ibm >= 1.7.1_sr3.0-11.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr3.0-11.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr3.0-11.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr3.0-11.1
Patchnames:
SUSE-SLE-SERVER-12-2015-270
SUSE Linux Enterprise Software Development Kit 11 SP3
  • java-1_6_0-ibm >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-devel >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr16.4-0.3.1
  • java-1_7_0-ibm-devel >= 1.7.0_sr9.0-0.7.1
Patchnames:
sdksp3-java-1_6_0-ibm
sdksp3-java-1_7_0-ibm
SUSE Linux Enterprise Software Development Kit 11 SP4
  • java-1_7_1-ibm-devel >= 1.7.1_sr3.0-1.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • java-1_7_1-ibm-devel >= 1.7.1_sr3.10-14.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • java-1_7_1-ibm-devel >= 1.7.1_sr3.50-28.2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • java-1_7_1-ibm-devel >= 1.7.1_sr4.5-37.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • java-1_7_1-ibm-devel >= 1.7.1_sr4.30-38.26.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • java-1_7_1-ibm-devel >= 1.7.1_sr4.50-38.41.1
SUSE Linux Enterprise Software Development Kit 12
  • java-1_7_1-ibm-devel >= 1.7.1_sr3.0-11.1
Patchnames:
SUSE-SLE-SDK-12-2015-270
SUSE Manager 1.7
  • java-1_6_0-ibm >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-devel >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr16.4-0.3.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr16.4-0.3.1
Patchnames:
sleman17sp2-java-1_6_0-ibm


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Server 11 SP4 LTSS java-1_7_1-ibm Already fixed
SUSE Linux Enterprise Server 12 java-1_7_1-ibm Released
SUSE Linux Enterprise Software Development Kit 12 java-1_7_1-ibm Released