Upstream information

CVE-2014-9984 at MITRE

Description

nscd in the GNU C Library (aka glibc or libc6) before version 2.20 does not correctly compute the size of an internal buffer when processing netgroup requests, possibly leading to an nscd daemon crash or code execution as the user running nscd.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1043984 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12-LTSS
  • glibc >= 2.19-22.24.5
  • glibc-32bit >= 2.19-22.24.5
  • glibc-devel >= 2.19-22.24.5
  • glibc-devel-32bit >= 2.19-22.24.5
  • glibc-html >= 2.19-22.24.5
  • glibc-i18ndata >= 2.19-22.24.5
  • glibc-info >= 2.19-22.24.5
  • glibc-locale >= 2.19-22.24.5
  • glibc-locale-32bit >= 2.19-22.24.5
  • glibc-profile >= 2.19-22.24.5
  • glibc-profile-32bit >= 2.19-22.24.5
  • nscd >= 2.19-22.24.5
Patchnames:
SUSE-SLE-SERVER-12-2018-54


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration glibc Already fixed
SUSE Linux Enterprise Desktop 11 SP4 glibc Not affected
SUSE Linux Enterprise Desktop 12 SP2 glibc Affected
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP4 glibc Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS glibc Not affected
SUSE Linux Enterprise Server 12 LTSS glibc Released
SUSE Linux Enterprise Server 12 SP1 LTSS glibc Already fixed
SUSE Linux Enterprise Server 12 SP2 glibc Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP4 glibc Not affected
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 glibc Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 glibc Not affected
suse/sles12sp3 glibcAlready fixed