Upstream information

CVE-2014-8161 at MITRE

Description

** RESERVED ** This candidate has been reserved by an organization or individual that will use it when announcing a new security problem. When the candidate has been publicized, the details for this candidate will be provided.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 916953 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
Patchnames:
sledsp3-postgresql91-201503
SUSE Linux Enterprise Desktop 12
  • libecpg6 >= 9.3.6-5.1
  • libpq5 >= 9.3.6-5.1
  • libpq5-32bit >= 9.3.6-5.1
  • postgresql93 >= 9.3.6-5.2
  • postgresql93-libs >= 9.3.6-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-118
SUSE Linux Enterprise Server 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Patchnames:
slessp3-postgresql91-201503
SUSE Linux Enterprise Server 12
  • libecpg6 >= 9.3.6-5.1
  • libpq5 >= 9.3.6-5.1
  • libpq5-32bit >= 9.3.6-5.1
  • postgresql93 >= 9.3.6-5.2
  • postgresql93-contrib >= 9.3.6-5.2
  • postgresql93-docs >= 9.3.6-5.2
  • postgresql93-libs >= 9.3.6-5.1
  • postgresql93-server >= 9.3.6-5.2
Patchnames:
SUSE-SLE-SERVER-12-2015-118
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Patchnames:
slessp3-postgresql91-201503
SUSE Linux Enterprise Server for SAP Applications 12
  • libecpg6 >= 9.3.6-5.1
  • libpq5 >= 9.3.6-5.1
  • libpq5-32bit >= 9.3.6-5.1
  • postgresql93 >= 9.3.6-5.2
  • postgresql93-contrib >= 9.3.6-5.2
  • postgresql93-docs >= 9.3.6-5.2
  • postgresql93-libs >= 9.3.6-5.1
  • postgresql93-server >= 9.3.6-5.2
Patchnames:
SUSE-SLE-SERVER-12-2015-118
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Patchnames:
slessp3-postgresql91-201503
SUSE Linux Enterprise Software Development Kit 11 SP3
  • postgresql91-devel >= 9.1.15-0.3.1
Patchnames:
sdksp3-postgresql91-201503
SUSE Linux Enterprise Software Development Kit 12
  • postgresql93-devel >= 9.3.6-5.1
  • postgresql93-libs >= 9.3.6-5.1
Patchnames:
SUSE-SLE-SDK-12-2015-118
SUSE Manager 2.1
  • postgresql91-pltcl >= 9.1.15-0.3.1
Patchnames:
sleman21-postgresql91-201503
SUSE Manager Server
  • postgresql91-pltcl >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Software Development Kit 11 SP3
  • postgresql91-devel >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Desktop 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Desktop 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
openSUSE Leap 42.2
  • postgresql93-docs >= 9.3.11-4.1
Patchnames:
openSUSE Leap 42.2 GA postgresql93-docs
openSUSE Leap 42.3
  • postgresql93-docs >= 9.3.17-6.1
Patchnames:
openSUSE Leap 42.3 GA postgresql93-docs
openSUSE Tumbleweed
  • postgresql93 >= 9.3.15-1.1
  • postgresql93-contrib >= 9.3.15-1.1
  • postgresql93-devel >= 9.3.15-1.1
  • postgresql93-docs >= 9.3.15-1.1
  • postgresql93-plperl >= 9.3.15-1.1
  • postgresql93-plpython >= 9.3.15-1.1
  • postgresql93-pltcl >= 9.3.15-1.1
  • postgresql93-server >= 9.3.15-1.1
  • postgresql93-test >= 9.3.15-1.1
Patchnames:
openSUSE Tumbleweed GA postgresql93


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 postgresql91 Released
SUSE Linux Enterprise Desktop 11 SP3 postgresql91 Released
SUSE Linux Enterprise Desktop 12 GA postgresql93 Released
SUSE Linux Enterprise Server 11 SP1 postgresql91 Released
SUSE Linux Enterprise Server 11 SP1 LTSS postgresql91 Released
SUSE Linux Enterprise Server 11 SP3 postgresql91 Released
SUSE Linux Enterprise Server 12 GA postgresql93 Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 postgresql91 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 postgresql91 Released
SUSE Manager Server 2.1 postgresql91 Released