Upstream information

CVE-2014-8161 at MITRE

Description

PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allows remote authenticated users to obtain sensitive column values by triggering constraint violation and then reading the error message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 916953 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
Patchnames:
sledsp3-postgresql91-201503
SUSE Linux Enterprise Desktop 12
  • libecpg6 >= 9.3.6-5.1
  • libpq5 >= 9.3.6-5.1
  • libpq5-32bit >= 9.3.6-5.1
  • postgresql93 >= 9.3.6-5.2
Patchnames:
SUSE-SLE-DESKTOP-12-2015-118
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Patchnames:
slessp3-postgresql91-201503
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • libecpg6 >= 9.3.6-5.1
  • libpq5 >= 9.3.6-5.1
  • libpq5-32bit >= 9.3.6-5.1
  • postgresql93 >= 9.3.6-5.2
  • postgresql93-contrib >= 9.3.6-5.2
  • postgresql93-docs >= 9.3.6-5.2
  • postgresql93-server >= 9.3.6-5.2
Patchnames:
SUSE-SLE-SERVER-12-2015-118
SUSE Linux Enterprise Software Development Kit 11 SP3
  • postgresql91-devel >= 9.1.15-0.3.1
Patchnames:
sdksp3-postgresql91-201503
SUSE Linux Enterprise Software Development Kit 12
  • postgresql93-devel >= 9.3.6-5.1
Patchnames:
SUSE-SLE-SDK-12-2015-118
SUSE Manager 2.1
  • postgresql91-pltcl >= 9.1.15-0.3.1
Patchnames:
sleman21-postgresql91-201503
openSUSE Tumbleweed
  • postgresql93 >= 9.3.15-1.1
  • postgresql93-contrib >= 9.3.15-1.1
  • postgresql93-devel >= 9.3.15-1.1
  • postgresql93-docs >= 9.3.15-1.1
  • postgresql93-plperl >= 9.3.15-1.1
  • postgresql93-plpython >= 9.3.15-1.1
  • postgresql93-pltcl >= 9.3.15-1.1
  • postgresql93-server >= 9.3.15-1.1
  • postgresql93-test >= 9.3.15-1.1
Patchnames:
openSUSE Tumbleweed GA postgresql93


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 postgresql91 Released
SUSE Linux Enterprise Desktop 11 SP3 postgresql91 Released
SUSE Linux Enterprise Desktop 12 postgresql93 Released
SUSE Linux Enterprise Server 11 SP1 postgresql91 Released
SUSE Linux Enterprise Server 11 SP1 LTSS postgresql91 Released
SUSE Linux Enterprise Server 11 SP3 postgresql91 Released
SUSE Linux Enterprise Server 11 SP3 for VMware postgresql91 Released
SUSE Linux Enterprise Server 12 postgresql93 Released
SUSE Linux Enterprise Server for SAP Business All-in-One postgresql91 Released
SUSE Manager Server postgresql91 Released