Upstream information

CVE-2014-7818 at MITRE

Description

Directory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.20, 4.0.x before 4.0.11, 4.1.x before 4.1.7, and 4.2.x before 4.2.0.beta3, when serve_static_assets is enabled, allows remote attackers to determine the existence of files outside the application root via a /..%2F sequence.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 903662 [RESOLVED / FIXED], 905727 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • rubygem-actionpack-3_2 >= 3.2.12-0.19.1
Patchnames:
sleslms13-rubygem-actionpack-3_2
SUSE Linux Enterprise High Availability 15 SP1
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-3.3.1
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-actionpack-5_1 >= 5.1.4-1.26
SUSE Linux Enterprise Software Development Kit 11 SP4
  • rubygem-actionpack-3_2 >= 3.2.12-0.19.1
SUSE OpenStack Cloud 6
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.2-2.2
SUSE Studio Onsite 1.3
  • Containment-Studio-SLE11_SP3 >= 5.05.81-20150505234825
  • rubygem-actionpack-3_2 >= 3.2.12-0.19.1
  • susestudio >= 1.3.10-0.17.45
  • susestudio-bundled-packages >= 1.3.10-0.17.45
  • susestudio-common >= 1.3.10-0.17.45
  • susestudio-runner >= 1.3.10-0.17.45
  • susestudio-sid >= 1.3.10-0.17.45
  • susestudio-ui-server >= 1.3.10-0.17.45
Patchnames:
slestso13-rubygem-actionpack-3_2
slestso13-susestudio-1310-201502
SUSE WebYast 1.3
  • rubygem-actionpack-3_2 >= 3.2.12-0.19.1
Patchnames:
slewyst13-rubygem-actionpack-3_2
openSUSE Tumbleweed
  • ruby2.2-rubygem-actionpack-4_2 >= 4.2.7.1-1.1
  • ruby2.2-rubygem-actionpack-5_0 >= 5.0.0.1-1.1
  • ruby2.2-rubygem-actionpack-doc-4_2 >= 4.2.7.1-1.1
  • ruby2.2-rubygem-actionpack-doc-5_0 >= 5.0.0.1-1.1
  • ruby2.3-rubygem-actionpack-4_2 >= 4.2.7.1-1.1
  • ruby2.3-rubygem-actionpack-5_0 >= 5.0.0.1-1.1
  • ruby2.3-rubygem-actionpack-doc-4_2 >= 4.2.7.1-1.1
  • ruby2.3-rubygem-actionpack-doc-5_0 >= 5.0.0.1-1.1
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-actionpack-4_2-4.2.7.1-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
sle-11-WebYaST (1.3) rubygem-actionpack-3_2 Released
sle-ha (15) rubygem-actionpack-5_1 Already fixed
sle-sdk (11) rubygem-actionpack-3_2 Released
sle-slms (1.3) rubygem-actionpack-3_2 Released
sle-studioonsite (1.3) rubygem-actionpack-3_2 Released
suse-openstack-cloud (7) rubygem-actionmailer-4_2 In progress
suse-openstack-cloud (7) rubygem-actionpack-4_2 In progress
suse-openstack-cloud-crowbar (8) rubygem-actionmailer-4_2 In progress
suse-openstack-cloud-crowbar (8) rubygem-actionpack-4_2 In progress
suse-openstack-cloud-crowbar (9) rubygem-actionmailer-4_2 In progress
suse-openstack-cloud-crowbar (9) rubygem-actionpack-4_2 In progress