Upstream information

CVE-2014-7202 at MITRE

Description

stream_engine.cpp in libzmq (aka ZeroMQ/C++)) 4.0.5 before 4.0.5 allows man-in-the-middle attackers to conduct downgrade attacks via a crafted connection request.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 898917 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libzmq3 >= 4.0.4-13.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libzmq3 >= 4.0.4-6.1
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libzmq3 >= 4.0.4-14.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Workstation Extension 12
  • libzmq3 >= 4.0.4-2.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libzmq5 >= 4.2.3-3.3.2
  • zeromq-devel >= 4.2.3-3.3.2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libzmq5 >= 4.2.3-3.8.1
  • zeromq-devel >= 4.2.3-3.8.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libzmq5 >= 4.2.3-3.15.4
  • zeromq-devel >= 4.2.3-3.15.4
SUSE Linux Enterprise Module for Basesystem 15
  • libzmq5 >= 4.2.3-1.24
  • zeromq-devel >= 4.2.3-1.24
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libzmq3 >= 4.0.4-13.1
  • zeromq-devel >= 4.0.4-13.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libzmq3 >= 4.0.4-6.1
  • zeromq-devel >= 4.0.4-6.1
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libzmq3 >= 4.0.4-14.1
  • zeromq-devel >= 4.0.4-14.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libzmq3 >= 4.0.4-15.3.1
  • zeromq-devel >= 4.0.4-15.3.1
SUSE Linux Enterprise Software Development Kit 12
  • libzmq3 >= 4.0.4-2.1
  • zeromq-devel >= 4.0.4-2.1
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libzmq3 >= 4.0.4-15.3.1
openSUSE Tumbleweed
  • libzmq5 >= 4.2.0-1.1
  • zeromq-devel >= 4.2.0-1.1
  • zeromq-tools >= 4.2.0-1.1
Patchnames:
openSUSE Tumbleweed GA libzmq5


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Enterprise Storage 1.0 zeromq Already fixed
SUSE Linux Enterprise Desktop 12 zeromq Already fixed
SUSE Linux Enterprise Module for Advanced Systems Management 12 zeromq Already fixed
SUSE Linux Enterprise Software Development Kit 12 zeromq Already fixed
SUSE Linux Enterprise Workstation Extension 12 zeromq Already fixed
SUSE Manager Client Tools for SLE 12 zeromq Already fixed