Upstream information

CVE-2014-5033 at MITRE

Description

KDE kdelibs before 4.14 and kauth before 5.1 does not properly use D-Bus for communication with a polkit authority, which allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition via a (1) setuid process or (2) pkexec process, related to CVE-2013-4288 and "PID reuse race conditions."

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 864716 [RESOLVED / FIXED], 912121 [RESOLVED]

SUSE Security Advisories:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 polkit-default-privs Already fixed
SLES for SAP Applications libvirt Released
SUSE Linux Enterprise Desktop 11 SP2 libvirt Released
SUSE Linux Enterprise Desktop 11 SP3 libvirt Released
SUSE Linux Enterprise Module for Public Cloud 12 kernel-ec2 Analysis
SUSE Linux Enterprise Server 11 SP2 libvirt Released
SUSE Linux Enterprise Server 11 SP2 LTSS libvirt Released
SUSE Linux Enterprise Server 11 SP3 libvirt Released
SUSE Linux Enterprise Server 11 SP3 LTSS libvirt Released
SUSE Linux Enterprise Server 12 SP2 BCL polkit-default-privs Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON polkit-default-privs Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS SAP polkit-default-privs Already fixed
SUSE Linux Enterprise Server 12 SP3 BCL polkit-default-privs Already fixed
SUSE Linux Enterprise Server 12 SP3 ESPOS polkit-default-privs Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS polkit-default-privs Already fixed
SUSE Linux Enterprise Server 12 SP4 ESPOS polkit-default-privs Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS polkit-default-privs Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 polkit-default-privs Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 polkit-default-privs Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP2 libvirt Released
SUSE Linux Enterprise Software Development Kit 11 SP3 libvirt Released
SUSE OpenStack Cloud 8 polkit-default-privs Already fixed
SUSE OpenStack Cloud 9 polkit-default-privs Already fixed
SUSE OpenStack Cloud Crowbar 8 polkit-default-privs Already fixed
SUSE OpenStack Cloud Crowbar 9 polkit-default-privs Already fixed