Upstream information

CVE-2014-4966 at MITRE

Description

Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ansible >= 2.2.0.0-1.1
Patchnames:
openSUSE Tumbleweed GA ansible-2.2.0.0-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Manager Client Tools Beta for SLE 15 ansible In progress
SUSE Manager Client Tools for SLE 15 ansible In progress
SUSE OpenStack Cloud 7 ansible In progress