Upstream information

CVE-2014-4877 at MITRE

Description

Absolute path traversal vulnerability in GNU Wget before 1.16, when recursion is enabled, allows remote FTP servers to write to arbitrary files, and consequently execute arbitrary code, via a LIST response that references the same filename within two entries, one of which indicates that the filename is for a symlink.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9.3 7.5
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
SUSE Bugzilla entry: 902709 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • wget >= 1.11.4-1.19.1
Patchnames:
sledsp3-wget
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12 SP1
  • wget >= 1.14-7.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • wget >= 1.14-10.3
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • wget >= 1.14-20.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • wget >= 1.14-21.7.1
SUSE Linux Enterprise Desktop 12
  • wget >= 1.14-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-2014-76
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • wget >= 1.14-21.10.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • wget >= 1.19.5-3.6.2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • wget >= 1.20.3-3.9.2
SUSE Linux Enterprise Module for Basesystem 15
  • wget >= 1.19.5-1.8
SUSE Linux Enterprise Server 11 SP1-LTSS
  • wget >= 1.11.4-1.19.1
Patchnames:
slessp1-wget
SUSE Linux Enterprise Server 11 SP2-LTSS
  • wget >= 1.11.4-1.19.1
Patchnames:
slessp2-wget
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • wget >= 1.11.4-1.19.1
Patchnames:
slessp3-wget
SUSE Linux Enterprise Server 11 SP4
  • wget >= 1.11.4-1.19.1
SUSE Linux Enterprise Server 11-SECURITY
  • wget-openssl1 >= 1.11.4-1.26.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • wget >= 1.14-7.1
Patchnames:
SUSE-SLE-SERVER-12-2014-76
openSUSE Leap 15.0
  • wget >= 1.19.5-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA wget-1.19.5-lp150.1.1
openSUSE Tumbleweed
  • wget >= 1.18-2.3
Patchnames:
openSUSE Tumbleweed GA wget-1.18-2.3


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 wget Released
SLED-10-SP3 wget Released
SLED-10-SP4 wget Released
SLES for SAP Applications wget Released
SLES-10-SP3 wget Released
SLES-10-SP4 wget Released
SLES_LTSS-10-SP4 wget Released
SUSE Enterprise Storage 5 wget Released
SUSE Linux Enterprise Desktop 11 SP1 wget Released
SUSE Linux Enterprise Desktop 11 SP2 wget Released
SUSE Linux Enterprise Desktop 11 SP3 wget Released
SUSE Linux Enterprise Desktop 11 SP4 wget Released
SUSE Linux Enterprise Desktop 12 wget Released
SUSE Linux Enterprise High Performance Computing 12 SP5 wget Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 wget Released
SUSE Linux Enterprise Server 11 SP1 wget Released
SUSE Linux Enterprise Server 11 SP1 LTSS wget Released
SUSE Linux Enterprise Server 11 SP2 wget Released
SUSE Linux Enterprise Server 11 SP2 LTSS wget Released
SUSE Linux Enterprise Server 11 SP2 for VMware wget Released
SUSE Linux Enterprise Server 11 SP3 wget Released
SUSE Linux Enterprise Server 11 SP3 LTSS wget Released
SUSE Linux Enterprise Server 11 SP3 for VMware wget Released
SUSE Linux Enterprise Server 11 SP4 wget Released
SUSE Linux Enterprise Server 11 SP4 LTSS wget Released
SUSE Linux Enterprise Server 12 wget Released
SUSE Linux Enterprise Server 12 SP2 ESPOS wget Released
SUSE Linux Enterprise Server 12 SP2 LTSS wget Released
SUSE Linux Enterprise Server 12 SP3 ESPOS wget Released
SUSE Linux Enterprise Server 12 SP3 LTSS wget Released
SUSE Linux Enterprise Server 12 SP4 ESPOS wget Released
SUSE Linux Enterprise Server 12 SP4 LTSS wget Released
SUSE Linux Enterprise Server 12 SP5 wget Released
SUSE Linux Enterprise Server BCL 12 SP2 wget Released
SUSE Linux Enterprise Server BCL 12 SP3 wget Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wget Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wget Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wget Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 wget Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 wget Released
SUSE OpenStack Cloud 7 wget Released
SUSE OpenStack Cloud 8 wget Released
SUSE OpenStack Cloud 9 wget Released
SUSE OpenStack Cloud Crowbar 8 wget Released
SUSE OpenStack Cloud Crowbar 9 wget Released