Upstream information

CVE-2014-4607 at MITRE

Description

Integer overflow in the LZO algorithm variant in Oberhumer liblzo2 and lzo-2 before 2.07 on 32-bit platforms might allow remote attackers to execute arbitrary code via a crafted Literal Run.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 883947 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • liblzo2-2 >= 2.03-12.3.1
  • liblzo2-2-32bit >= 2.03-12.3.1
Patchnames:
sledsp3-liblzo2-2
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP1
  • liblzo2-2 >= 2.08-1.13
  • liblzo2-2-32bit >= 2.08-1.13
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • liblzo2-2 >= 2.08-1.6
  • liblzo2-2-32bit >= 2.08-1.13
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • liblzo2-2 >= 2.10-2.22
  • lzo-devel >= 2.10-2.22
  • lzo-devel-static >= 2.10-2.22
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • libvncserver0 >= 0.9.10-4.14.1
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • libvncserver0 >= 0.9.10-4.25.1
SUSE Linux Enterprise Server 11 SP1-LTSS
  • liblzo2-2 >= 2.03-12.3.1
  • liblzo2-2-32bit >= 2.03-12.3.1
Patchnames:
slessp1-liblzo2-2
SUSE Linux Enterprise Server 11 SP2-LTSS
  • liblzo2-2 >= 2.03-12.3.1
  • liblzo2-2-32bit >= 2.03-12.3.1
Patchnames:
slessp2-liblzo2-2
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • liblzo2-2 >= 2.03-12.3.1
  • liblzo2-2-32bit >= 2.03-12.3.1
  • liblzo2-2-x86 >= 2.03-12.3.1
Patchnames:
slessp3-liblzo2-2
SUSE Linux Enterprise Server 11 SP4
  • liblzo2-2 >= 2.03-12.3.1
  • liblzo2-2-32bit >= 2.03-12.3.1
  • liblzo2-2-x86 >= 2.03-12.3.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • liblzo2-2 >= 2.08-1.6
SUSE Linux Enterprise Software Development Kit 11 SP3
  • lzo-devel >= 2.03-12.3.1
  • lzo-devel-32bit >= 2.03-12.3.1
Patchnames:
sdksp3-liblzo2-2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • lzo-devel >= 2.03-12.3.1
  • lzo-devel-32bit >= 2.03-12.3.1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • icecream >= 1.0.1-5.1
  • lzo-devel >= 2.08-1.6
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
  • icecream >= 1.0.1-5.1
  • lzo-devel >= 2.08-1.13
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libvncclient0 >= 0.9.10-4.9.1
SUSE Linux Enterprise Workstation Extension 15 SP2
  • libvncclient0 >= 0.9.10-4.14.1
  • libvncserver0 >= 0.9.10-4.14.1
SUSE Linux Enterprise Workstation Extension 15
  • libvncclient0 >= 0.9.10-2.21
openSUSE Leap 15.0
  • liblzo2-2 >= 2.10-lp150.2.10
  • libvncclient0 >= 0.9.10-lp150.2.3
Patchnames:
openSUSE Leap 15.0 GA liblzo2-2-2.10-lp150.2.10
openSUSE Leap 15.0 GA libvncclient0-0.9.10-lp150.2.3
openSUSE Tumbleweed
  • LibVNCServer-devel >= 0.9.10-3.5
  • icecream >= 1.3.1-3.7
  • icecream-clang-wrappers >= 1.3.1-3.7
  • libicecream-devel >= 1.3.1-3.7
  • liblzo2-2 >= 2.09-1.9
  • liblzo2-2-32bit >= 2.09-1.9
  • libvncclient0 >= 0.9.10-3.5
  • libvncserver0 >= 0.9.10-3.5
  • lzo-devel >= 2.09-1.9
  • lzo-devel-32bit >= 2.09-1.9
  • lzo-devel-static >= 2.09-1.9
  • nfdump >= 1.6.23-1.3
Patchnames:
openSUSE Tumbleweed GA LibVNCServer-devel-0.9.10-3.5
openSUSE Tumbleweed GA icecream-1.3.1-3.7
openSUSE Tumbleweed GA nfdump-1.6.23-1.3


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 lzo Already fixed
SLED-10-SP3 lzo Released
SLED-10-SP4 lzo Released
SLES-10-SP3 lzo Released
SLES-10-SP4 lzo Released
SLES_LTSS-10-SP4 lzo Released
SUSE Linux Enterprise Desktop 11 SP1 lzo Released
SUSE Linux Enterprise Desktop 11 SP2 lzo Released
SUSE Linux Enterprise Desktop 11 SP3 lzo Released
SUSE Linux Enterprise High Performance Computing 12 SP5 lzo Already fixed
SUSE Linux Enterprise Server 11 SP1 lzo Released
SUSE Linux Enterprise Server 11 SP1 LTSS lzo Released
SUSE Linux Enterprise Server 11 SP2 lzo Released
SUSE Linux Enterprise Server 11 SP2 LTSS lzo Released
SUSE Linux Enterprise Server 11 SP2 for VMware lzo Released
SUSE Linux Enterprise Server 11 SP3 lzo Released
SUSE Linux Enterprise Server 11 SP3 for VMware lzo Released
SUSE Linux Enterprise Server 12 SP3 ESPOS lzo Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS lzo Already fixed
SUSE Linux Enterprise Server 12 SP4 ESPOS lzo Already fixed
SUSE Linux Enterprise Server 12 SP4 LTSS lzo Already fixed
SUSE Linux Enterprise Server 12 SP5 lzo Already fixed
SUSE Linux Enterprise Server BCL 12 SP2 lzo Already fixed
SUSE Linux Enterprise Server BCL 12 SP3 lzo Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 lzo Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 lzo Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 lzo Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 lzo Released
SUSE Linux Enterprise Software Development Kit 11 SP1 lzo Released
SUSE Linux Enterprise Software Development Kit 11 SP2 lzo Released
SUSE Linux Enterprise Software Development Kit 11 SP3 lzo Released
SUSE Linux Enterprise Workstation Extension 15 SP2 LibVNCServer Already fixed
SUSE OpenStack Cloud 8 lzo Already fixed
SUSE OpenStack Cloud 9 lzo Already fixed
SUSE OpenStack Cloud Crowbar 8 lzo Already fixed
SUSE OpenStack Cloud Crowbar 9 lzo Already fixed