Upstream information

CVE-2014-4038 at MITRE

Description

ppc64-diag 2.6.1 allows local users to overwrite arbitrary files via a symlink attack related to (1) rtas_errd/diag_support.c and /tmp/get_dt_files, (2) scripts/ppc64_diag_mkrsrc and /tmp/diagSEsnap/snapH.tar.gz, or (3) lpd/test/lpd_ela_test.sh and /var/tmp/ras.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 882667 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • ppc64-diag >= 2.7.6-1.53
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA ppc64-diag-2.7.6-1.53
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • ppc64-diag >= 2.7.6-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA ppc64-diag-2.7.6-3.3.1
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • ppc64-diag >= 2.6.1-0.14.1
Patchnames:
slessp3-ppc64-diag
SUSE Linux Enterprise Server 11 SP4
  • ppc64-diag >= 2.6.7-1.31
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ppc64-diag-2.6.7-1.31
SUSE Linux Enterprise Server 12 SP1
  • ppc64-diag >= 2.6.9-2.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA ppc64-diag-2.6.9-2.1
SUSE Linux Enterprise Server 12 SP2
  • ppc64-diag >= 2.7.1-5.6
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA ppc64-diag-2.7.1-5.6
SUSE Linux Enterprise Server 12 SP3
  • ppc64-diag >= 2.7.3-1.17
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ppc64-diag-2.7.3-1.17
SUSE Linux Enterprise Server 12 SP4
  • ppc64-diag >= 2.7.4-1.18
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA ppc64-diag-2.7.4-1.18
SUSE Linux Enterprise Server 12 SP5
  • ppc64-diag >= 2.7.5-2.30
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA ppc64-diag-2.7.5-2.30
SUSE Linux Enterprise Server 12
  • ppc64-diag >= 2.6.7-2.1
Patchnames:
SUSE Linux Enterprise Server 12 GA ppc64-diag-2.6.7-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 15 SP2 ppc64-diag Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 ppc64-diag Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 ppc64-diag Already fixed
SUSE Linux Enterprise Server 11 SP3 ppc64-diag Released
SUSE Linux Enterprise Server 12 SP5 ppc64-diag Already fixed
SUSE Linux Enterprise Server 15 LTSS ppc64-diag Already fixed
SUSE Linux Enterprise Server 15 SP2 ppc64-diag Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ppc64-diag Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 ppc64-diag Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ppc64-diag Already fixed
SUSE Linux Enterprise Storage 7 ppc64-diag Already fixed
SUSE Manager Proxy 4.1 ppc64-diag Already fixed
SUSE Manager Retail Branch Server 4.1 ppc64-diag Already fixed
SUSE Manager Server 4.1 ppc64-diag Already fixed