Upstream information

CVE-2014-3698 at MITRE

Description

The jabber_idn_validate function in jutil.c in the Jabber protocol plugin in libpurple in Pidgin before 2.10.10 allows remote attackers to obtain sensitive information from process memory via a crafted XMPP message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 902408 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • finch >= 2.6.6-0.25.2
  • finch-devel >= 2.6.6-0.25.2
  • libpurple >= 2.6.6-0.25.2
  • libpurple-devel >= 2.6.6-0.25.2
  • libpurple-lang >= 2.6.6-0.25.2
  • libpurple-meanwhile >= 2.6.6-0.25.2
  • libpurple-tcl >= 2.6.6-0.25.2
  • pidgin >= 2.6.6-0.25.2
  • pidgin-devel >= 2.6.6-0.25.2
Patchnames:
sdksp3-finch
sledsp3-finch
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • finch >= 2.6.6-0.25.2
  • finch-devel >= 2.6.6-0.25.2
  • libpurple >= 2.6.6-0.25.2
  • libpurple-devel >= 2.6.6-0.25.2
  • libpurple-lang >= 2.6.6-0.25.2
  • pidgin >= 2.6.6-0.25.2
  • pidgin-devel >= 2.6.6-0.25.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA finch-2.6.6-0.25.2
SUSE Linux Enterprise Desktop 12 SP1
  • finch >= 2.10.9-8.1
  • finch-devel >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-devel >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • libpurple-meanwhile >= 2.10.9-8.1
  • libpurple-tcl >= 2.10.9-8.1
  • pidgin >= 2.10.9-8.1
  • pidgin-devel >= 2.10.9-8.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA finch-2.10.9-8.1
SUSE Linux Enterprise Software Development Kit 12 SP1 GA finch-devel-2.10.9-8.1
SUSE Linux Enterprise Workstation Extension 12 SP1 GA finch-2.10.9-8.1
SUSE Linux Enterprise Desktop 12 SP2
  • finch >= 2.11.0-12.5
  • finch-devel >= 2.11.0-12.5
  • libpurple >= 2.11.0-12.5
  • libpurple-devel >= 2.11.0-12.5
  • libpurple-lang >= 2.11.0-12.5
  • libpurple-meanwhile >= 2.11.0-12.5
  • libpurple-tcl >= 2.11.0-12.5
  • pidgin >= 2.11.0-12.5
  • pidgin-devel >= 2.11.0-12.5
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA finch-2.11.0-12.5
SUSE Linux Enterprise Software Development Kit 12 SP2 GA finch-devel-2.11.0-12.5
SUSE Linux Enterprise Workstation Extension 12 SP2 GA finch-2.11.0-12.5
SUSE Linux Enterprise Desktop 12 SP3
  • finch >= 2.12.0-1.33
  • finch-devel >= 2.12.0-1.33
  • libpurple >= 2.12.0-1.33
  • libpurple-branding-upstream >= 2.12.0-1.33
  • libpurple-devel >= 2.12.0-1.33
  • libpurple-lang >= 2.12.0-1.33
  • libpurple-plugin-sametime >= 2.12.0-1.33
  • libpurple-tcl >= 2.12.0-1.33
  • pidgin >= 2.12.0-1.33
  • pidgin-devel >= 2.12.0-1.33
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA finch-2.12.0-1.33
SUSE Linux Enterprise Software Development Kit 12 SP3 GA finch-devel-2.12.0-1.33
SUSE Linux Enterprise Workstation Extension 12 SP3 GA finch-2.12.0-1.33
SUSE Linux Enterprise Desktop 12 SP4
  • finch >= 2.12.0-3.3.1
  • finch-devel >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-branding-upstream >= 2.12.0-3.3.1
  • libpurple-devel >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • libpurple-plugin-sametime >= 2.12.0-3.3.1
  • libpurple-tcl >= 2.12.0-3.3.1
  • pidgin >= 2.12.0-3.3.1
  • pidgin-devel >= 2.12.0-3.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA finch-2.12.0-3.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA finch-devel-2.12.0-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA finch-2.12.0-3.3.1
SUSE Linux Enterprise Desktop 12 SP5
SUSE Linux Enterprise Workstation Extension 12 SP5
  • finch >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-branding-upstream >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • libpurple-plugin-sametime >= 2.12.0-3.3.1
  • libpurple-tcl >= 2.12.0-3.3.1
  • pidgin >= 2.12.0-3.3.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA finch-2.12.0-3.3.1
SUSE Linux Enterprise Desktop 12
  • finch >= 2.10.9-8.1
  • finch-devel >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-devel >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • libpurple-meanwhile >= 2.10.9-8.1
  • libpurple-tcl >= 2.10.9-8.1
  • pidgin >= 2.10.9-8.1
  • pidgin-devel >= 2.10.9-8.1
Patchnames:
SUSE-SLE-DESKTOP-12-2014-107
SUSE-SLE-SDK-12-2014-107
SUSE-SLE-WE-12-2014-107
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libpurple >= 2.13.0-3.35
  • libpurple-branding-upstream >= 2.13.0-3.35
  • libpurple-devel >= 2.13.0-3.35
  • libpurple-lang >= 2.13.0-3.35
  • libpurple-plugin-sametime >= 2.13.0-3.35
  • pidgin >= 2.13.0-3.35
  • pidgin-devel >= 2.13.0-3.35
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP1 GA libpurple-2.13.0-3.35
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Workstation Extension 15 SP2
  • libpurple >= 2.13.0-10.105
  • libpurple-branding-upstream >= 2.13.0-10.105
  • libpurple-devel >= 2.13.0-10.105
  • libpurple-lang >= 2.13.0-10.105
  • libpurple-plugin-sametime >= 2.13.0-10.105
  • pidgin >= 2.13.0-10.105
  • pidgin-devel >= 2.13.0-10.105
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP2 GA libpurple-2.13.0-10.105
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Workstation Extension 15 SP3
  • libpurple >= 2.13.0-10.105
  • libpurple-branding-upstream >= 2.13.0-10.105
  • libpurple-devel >= 2.13.0-10.105
  • libpurple-lang >= 2.13.0-10.105
  • libpurple-plugin-sametime >= 2.13.0-10.105
  • pidgin >= 2.13.0-10.105
  • pidgin-devel >= 2.13.0-10.105
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP3 GA libpurple-2.13.0-10.105
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Linux Enterprise Workstation Extension 15 SP4
  • libpurple >= 2.14.8-150400.1.10
  • libpurple-branding-upstream >= 2.14.8-150400.1.10
  • libpurple-client0 >= 2.14.8-150400.1.10
  • libpurple-devel >= 2.14.8-150400.1.10
  • libpurple-lang >= 2.14.8-150400.1.10
  • libpurple-plugin-sametime >= 2.14.8-150400.1.10
  • libpurple0 >= 2.14.8-150400.1.10
  • pidgin >= 2.14.8-150400.1.10
  • pidgin-devel >= 2.14.8-150400.1.10
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP4 GA libpurple-2.14.8-150400.1.10
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
SUSE Linux Enterprise Workstation Extension 15
  • libpurple >= 2.13.0-3.35
  • libpurple-branding-upstream >= 2.13.0-3.35
  • libpurple-devel >= 2.13.0-3.35
  • libpurple-lang >= 2.13.0-3.35
  • libpurple-plugin-sametime >= 2.13.0-3.35
  • pidgin >= 2.13.0-3.35
  • pidgin-devel >= 2.13.0-3.35
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA libpurple-2.13.0-3.35
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Software Development Kit 11 SP3
  • finch >= 2.6.6-0.25.2
  • finch-devel >= 2.6.6-0.25.2
  • libpurple >= 2.6.6-0.25.2
  • libpurple-devel >= 2.6.6-0.25.2
  • libpurple-lang >= 2.6.6-0.25.2
  • pidgin >= 2.6.6-0.25.2
  • pidgin-devel >= 2.6.6-0.25.2
Patchnames:
sdksp3-finch
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • finch >= 2.10.9-8.1
  • finch-devel >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-devel >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • libpurple-meanwhile >= 2.10.9-8.1
  • libpurple-tcl >= 2.10.9-8.1
  • pidgin >= 2.10.9-8.1
  • pidgin-devel >= 2.10.9-8.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA finch-devel-2.10.9-8.1
SUSE Linux Enterprise Workstation Extension 12 SP1 GA finch-2.10.9-8.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • finch >= 2.11.0-12.5
  • finch-devel >= 2.11.0-12.5
  • libpurple >= 2.11.0-12.5
  • libpurple-devel >= 2.11.0-12.5
  • libpurple-lang >= 2.11.0-12.5
  • libpurple-meanwhile >= 2.11.0-12.5
  • libpurple-tcl >= 2.11.0-12.5
  • pidgin >= 2.11.0-12.5
  • pidgin-devel >= 2.11.0-12.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA finch-devel-2.11.0-12.5
SUSE Linux Enterprise Workstation Extension 12 SP2 GA finch-2.11.0-12.5
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • finch >= 2.12.0-1.33
  • finch-devel >= 2.12.0-1.33
  • libpurple >= 2.12.0-1.33
  • libpurple-branding-upstream >= 2.12.0-1.33
  • libpurple-devel >= 2.12.0-1.33
  • libpurple-lang >= 2.12.0-1.33
  • libpurple-plugin-sametime >= 2.12.0-1.33
  • libpurple-tcl >= 2.12.0-1.33
  • pidgin >= 2.12.0-1.33
  • pidgin-devel >= 2.12.0-1.33
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA finch-devel-2.12.0-1.33
SUSE Linux Enterprise Workstation Extension 12 SP3 GA finch-2.12.0-1.33
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • finch >= 2.12.0-3.3.1
  • finch-devel >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-branding-upstream >= 2.12.0-3.3.1
  • libpurple-devel >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • libpurple-plugin-sametime >= 2.12.0-3.3.1
  • libpurple-tcl >= 2.12.0-3.3.1
  • pidgin >= 2.12.0-3.3.1
  • pidgin-devel >= 2.12.0-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA finch-devel-2.12.0-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA finch-2.12.0-3.3.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • finch >= 2.12.0-3.3.1
  • finch-devel >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-branding-upstream >= 2.12.0-3.3.1
  • libpurple-devel >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • libpurple-plugin-sametime >= 2.12.0-3.3.1
  • libpurple-tcl >= 2.12.0-3.3.1
  • pidgin >= 2.12.0-3.3.1
  • pidgin-devel >= 2.12.0-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA finch-devel-2.12.0-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP5 GA finch-2.12.0-3.3.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • finch >= 2.10.9-8.1
  • finch-devel >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-devel >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • libpurple-meanwhile >= 2.10.9-8.1
  • libpurple-tcl >= 2.10.9-8.1
  • pidgin >= 2.10.9-8.1
  • pidgin-devel >= 2.10.9-8.1
Patchnames:
SUSE-SLE-SDK-12-2014-107
SUSE-SLE-WE-12-2014-107
SUSE Linux Enterprise Software Development Kit 12 SP1
  • finch-devel >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-devel >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • pidgin-devel >= 2.10.9-8.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA finch-devel-2.10.9-8.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • finch-devel >= 2.11.0-12.5
  • libpurple >= 2.11.0-12.5
  • libpurple-devel >= 2.11.0-12.5
  • libpurple-lang >= 2.11.0-12.5
  • pidgin-devel >= 2.11.0-12.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA finch-devel-2.11.0-12.5
SUSE Linux Enterprise Software Development Kit 12 SP3
  • finch-devel >= 2.12.0-1.33
  • libpurple >= 2.12.0-1.33
  • libpurple-devel >= 2.12.0-1.33
  • libpurple-lang >= 2.12.0-1.33
  • pidgin-devel >= 2.12.0-1.33
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA finch-devel-2.12.0-1.33
SUSE Linux Enterprise Software Development Kit 12 SP4
  • finch-devel >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-devel >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • pidgin-devel >= 2.12.0-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA finch-devel-2.12.0-3.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • finch-devel >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-devel >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • pidgin-devel >= 2.12.0-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA finch-devel-2.12.0-3.3.1
SUSE Linux Enterprise Software Development Kit 12
  • finch-devel >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-devel >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • pidgin-devel >= 2.10.9-8.1
Patchnames:
SUSE-SLE-SDK-12-2014-107
SUSE Linux Enterprise Workstation Extension 12 SP1
  • finch >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • libpurple-meanwhile >= 2.10.9-8.1
  • libpurple-tcl >= 2.10.9-8.1
  • pidgin >= 2.10.9-8.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA finch-2.10.9-8.1
SUSE Linux Enterprise Workstation Extension 12 SP2
  • finch >= 2.11.0-12.5
  • libpurple >= 2.11.0-12.5
  • libpurple-lang >= 2.11.0-12.5
  • libpurple-meanwhile >= 2.11.0-12.5
  • libpurple-tcl >= 2.11.0-12.5
  • pidgin >= 2.11.0-12.5
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA finch-2.11.0-12.5
SUSE Linux Enterprise Workstation Extension 12 SP3
  • finch >= 2.12.0-1.33
  • libpurple >= 2.12.0-1.33
  • libpurple-branding-upstream >= 2.12.0-1.33
  • libpurple-lang >= 2.12.0-1.33
  • libpurple-plugin-sametime >= 2.12.0-1.33
  • libpurple-tcl >= 2.12.0-1.33
  • pidgin >= 2.12.0-1.33
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA finch-2.12.0-1.33
SUSE Linux Enterprise Workstation Extension 12 SP4
  • finch >= 2.12.0-3.3.1
  • libpurple >= 2.12.0-3.3.1
  • libpurple-branding-upstream >= 2.12.0-3.3.1
  • libpurple-lang >= 2.12.0-3.3.1
  • libpurple-plugin-sametime >= 2.12.0-3.3.1
  • libpurple-tcl >= 2.12.0-3.3.1
  • pidgin >= 2.12.0-3.3.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA finch-2.12.0-3.3.1
SUSE Linux Enterprise Workstation Extension 12
  • finch >= 2.10.9-8.1
  • libpurple >= 2.10.9-8.1
  • libpurple-lang >= 2.10.9-8.1
  • libpurple-meanwhile >= 2.10.9-8.1
  • libpurple-tcl >= 2.10.9-8.1
  • pidgin >= 2.10.9-8.1
Patchnames:
SUSE-SLE-WE-12-2014-107
openSUSE Leap 15.0
  • libpurple >= 2.13.0-lp150.3.1
  • libpurple-lang >= 2.13.0-lp150.3.1
  • libpurple-tcl >= 2.13.0-lp150.3.1
  • pidgin >= 2.13.0-lp150.3.1
Patchnames:
openSUSE Leap 15.0 GA libpurple-2.13.0-lp150.3.1
openSUSE Leap 15.2
  • libpurple >= 2.13.0-lp152.6.5
  • libpurple-lang >= 2.13.0-lp152.6.5
  • libpurple-tcl >= 2.13.0-lp152.6.5
  • pidgin >= 2.13.0-lp152.6.5
Patchnames:
openSUSE Leap 15.2 GA libpurple-2.13.0-lp152.6.2
openSUSE Leap 15.3
  • libpurple >= 2.13.0-10.105
  • libpurple-lang >= 2.13.0-10.105
  • libpurple-tcl >= 2.13.0-10.105
  • pidgin >= 2.13.0-10.105
Patchnames:
openSUSE Leap 15.3 GA libpurple-2.13.0-10.105
openSUSE Leap 15.4
  • libpurple >= 2.14.8-150400.1.10
  • libpurple-client0 >= 2.14.8-150400.1.10
  • libpurple-lang >= 2.14.8-150400.1.10
  • libpurple-tcl >= 2.14.8-150400.1.10
  • libpurple0 >= 2.14.8-150400.1.10
  • pidgin >= 2.14.8-150400.1.10
Patchnames:
openSUSE Leap 15.4 GA libpurple-2.14.8-150400.1.10
openSUSE Tumbleweed
  • finch >= 2.11.0-4.1
  • finch-devel >= 2.11.0-4.1
  • libpurple >= 2.11.0-4.1
  • libpurple-branding-upstream >= 2.11.0-4.1
  • libpurple-devel >= 2.11.0-4.1
  • libpurple-lang >= 2.11.0-4.1
  • libpurple-plugin-sametime >= 2.11.0-4.1
  • libpurple-tcl >= 2.11.0-4.1
  • pidgin >= 2.11.0-4.1
  • pidgin-devel >= 2.11.0-4.1
Patchnames:
openSUSE Tumbleweed GA finch-2.11.0-4.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP3 pidgin Released
SUSE Linux Enterprise Desktop 12 pidgin Released
SUSE Linux Enterprise Desktop 12 SP1 pidgin Released
SUSE Linux Enterprise Server 11 SP3 pidgin Released
SUSE Linux Enterprise Server 12 pidgin Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 pidgin Released
SUSE Linux Enterprise Server for SAP Applications 12 pidgin Released
SUSE Linux Enterprise Software Development Kit 11 SP3 pidgin Released
SUSE Linux Enterprise Software Development Kit 12 pidgin Released
SUSE Linux Enterprise Workstation Extension 12 pidgin Released