CVE-2014-2891

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-2891 at MITRE

Description

strongSwan before 5.1.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a crafted ID_DER_ASN1_DN ID payload.

NVD CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P)

SUSE information

SUSE Bugzilla entry: 876449

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • strongswan >= 4.4.0-6.25.1
  • strongswan-doc >= 4.4.0-6.25.1
Builds
SAT Patch Nr: 9251
openSUSE 12.3
  • strongswan >= 5.0.1-4.16.1
  • strongswan-debugsource >= 5.0.1-4.16.1
  • strongswan-doc >= 5.0.1-4.16.1
  • strongswan-ipsec >= 5.0.1-4.16.1
  • strongswan-ipsec-debuginfo >= 5.0.1-4.16.1
  • strongswan-libs0 >= 5.0.1-4.16.1
  • strongswan-libs0-debuginfo >= 5.0.1-4.16.1
  • strongswan-mysql >= 5.0.1-4.16.1
  • strongswan-mysql-debuginfo >= 5.0.1-4.16.1
  • strongswan-nm >= 5.0.1-4.16.1
  • strongswan-nm-debuginfo >= 5.0.1-4.16.1
  • strongswan-sqlite >= 5.0.1-4.16.1
  • strongswan-sqlite-debuginfo >= 5.0.1-4.16.1
Patchnames:
openSUSE-2014-384
openSUSE 13.1
  • strongswan >= 5.1.1-4.1
  • strongswan-debugsource >= 5.1.1-4.1
  • strongswan-doc >= 5.1.1-4.1
  • strongswan-ipsec >= 5.1.1-4.1
  • strongswan-ipsec-debuginfo >= 5.1.1-4.1
  • strongswan-libs0 >= 5.1.1-4.1
  • strongswan-libs0-debuginfo >= 5.1.1-4.1
  • strongswan-mysql >= 5.1.1-4.1
  • strongswan-mysql-debuginfo >= 5.1.1-4.1
  • strongswan-nm >= 5.1.1-4.1
  • strongswan-nm-debuginfo >= 5.1.1-4.1
  • strongswan-sqlite >= 5.1.1-4.1
  • strongswan-sqlite-debuginfo >= 5.1.1-4.1
Patchnames:
openSUSE-2014-384
openSUSE Evergreen 11.4
  • strongswan >= 4.5.0-6.64.1
  • strongswan-debugsource >= 4.5.0-6.64.1
  • strongswan-doc >= 4.5.0-6.64.1
  • strongswan-ikev1 >= 4.5.0-6.64.1
  • strongswan-ikev1-debuginfo >= 4.5.0-6.64.1
  • strongswan-ikev2 >= 4.5.0-6.64.1
  • strongswan-ikev2-debuginfo >= 4.5.0-6.64.1
  • strongswan-ipsec >= 4.5.0-6.64.1
  • strongswan-ipsec-debuginfo >= 4.5.0-6.64.1
  • strongswan-libs0 >= 4.5.0-6.64.1
  • strongswan-libs0-debuginfo >= 4.5.0-6.64.1
  • strongswan-mysql >= 4.5.0-6.64.1
  • strongswan-mysql-debuginfo >= 4.5.0-6.64.1
  • strongswan-nm >= 4.5.0-6.64.1
  • strongswan-nm-debuginfo >= 4.5.0-6.64.1
  • strongswan-sqlite >= 4.5.0-6.64.1
  • strongswan-sqlite-debuginfo >= 4.5.0-6.64.1
Patchnames:
2014-54

List of products where fixes are in QA

SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 LTSS for x86