Upstream information

CVE-2014-0148 at MITRE

Description

Qemu before 2.0 block driver for Hyper-V VHDX Images is vulnerable to infinite loops and other potential issues when calculating BAT entries, due to missing bounds checks for block_size and logical_sector_size variables. These are used to derive other fields like 'sectors_per_block' etc. A user able to alter the Qemu disk image could ise this flaw to crash the Qemu instance resulting in DoS.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 870439 [RESOLVED / FIXED], 871442 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 qemu Already fixed
SLES for SAP Applications kvm Released
SUSE Linux Enterprise Desktop 11 SP1 kvm Affected
SUSE Linux Enterprise Desktop 11 SP3 kvm Released
SUSE Linux Enterprise Desktop 11 SP4 kvm Already fixed
SUSE Linux Enterprise Desktop 12 qemu Already fixed
SUSE Linux Enterprise Desktop 12 SP1 qemu Unsupported
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search kvm Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS xen Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 xen Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP2 qemu Analysis
SUSE Linux Enterprise Module for Server Applications 15 SP2 xen Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 xen In progress
SUSE Linux Enterprise Server 11 SP1 kvm Affected
SUSE Linux Enterprise Server 11 SP1 LTSS kvm Affected
SUSE Linux Enterprise Server 11 SP3 kvm Released
SUSE Linux Enterprise Server 11 SP3 LTSS kvm Released
SUSE Linux Enterprise Server 11 SP4 kvm Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS kvm Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS xen In progress
SUSE Linux Enterprise Server 12 qemu Already fixed
SUSE Linux Enterprise Server 12 SP1 qemu Unsupported
SUSE Linux Enterprise Server 12 SP2 BCL xen Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON xen Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS SAP xen Already fixed
SUSE Linux Enterprise Server 12 SP3 BCL qemu Already fixed
SUSE Linux Enterprise Server 12 SP3 ESPOS qemu Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS qemu Already fixed
SUSE Linux Enterprise Server 15 LTSS xen Already fixed
SUSE Linux Enterprise Server ESPOS 15 xen Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 qemu Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 xen Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One kvm Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 qemu Ignore
SUSE Linux Enterprise Software Development Kit 11 SP2 qemu Ignore
SUSE Linux Enterprise Software Development Kit 11 SP3 qemu Ignore
SUSE Linux Enterprise Software Development Kit 11 SP4 qemu Ignore
SUSE OpenStack Cloud 8 qemu Already fixed
SUSE OpenStack Cloud Crowbar 8 qemu Already fixed
SUSE Studio Extension for System z 1.2 kvm Affected
SUSE Studio Onsite qemu Ignore