CVE-2014-0076
SLE CLIENT TOOLS 10 for s390x,SLE CLIENT TOOLS 10 for x86,SLE CLIENT TOOLS 10 for x86_64,SUSE Linux Enterprise Desktop 11 SP3,SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T,SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit,SUSE Linux Enterprise Server 10 SP3 LTSS for x86,SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T,SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit,SUSE Linux Enterprise Server 10 SP4 LTSS for x86,SUSE Linux Enterprise Server 11 SP1 LTSS,SUSE Linux Enterprise Server 11 SP2 LTSS,SUSE Linux Enterprise Server 11 SP3,SUSE Linux Enterprise Server 11 SP3 for VMware,SUSE Linux Enterprise Software Development Kit 11 SP3,SUSE Manager 1.7 for SLE 11 SP2,SUSE Studio Onsite 1.3
CVE-2014-0076, security advisory, novell, suse linux, suse, security, cve

CVE-2014-0076

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-0076 at MITRE

Description

The Montgomery ladder implementation in OpenSSL through 1.0.0l does not ensure that certain swap operations have a constant-time behavior, which makes it easier for local users to obtain ECDSA nonces via a FLUSH+RELOAD cache side-channel attack.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.30
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 869945 [RESOLVED / FIXED], 880891 [RESOLVED / FIXED], 883126 [RESOLVED / FIXED], 905106

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.54.1
  • openssl >= 0.9.8j-0.54.1
Patchnames:
sledsp3-libopenssl-devel
SUSE Linux Enterprise Server 11 SP1-LTSS
  • libopenssl-devel >= 0.9.8j-0.72.1
  • libopenssl0_9_8 >= 0.9.8j-0.58.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.58.1
  • openssl >= 0.9.8j-0.58.1
  • openssl-doc >= 0.9.8j-0.58.1
Patchnames:
slessp1-libopenssl-devel
SUSE Linux Enterprise Server 11 SP2-LTSS
  • libopenssl-devel >= 0.9.8j-0.72.1
  • libopenssl0_9_8 >= 0.9.8j-0.58.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.58.1
  • openssl >= 0.9.8j-0.58.1
  • openssl-doc >= 0.9.8j-0.58.1
Patchnames:
slessp2-libopenssl-devel
SUSE Linux Enterprise Server 11 SP3
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.54.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.66.1
  • openssl >= 0.9.8j-0.54.1
  • openssl-doc >= 0.9.8j-0.54.1
Patchnames:
slessp3-libopenssl-devel
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.54.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.66.1
  • openssl >= 0.9.8j-0.54.1
  • openssl-doc >= 0.9.8j-0.54.1
Patchnames:
slessp3-libopenssl-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libopenssl-devel >= 0.9.8j-0.54.1
Patchnames:
sdksp3-libopenssl-devel
SUSE Manager 1.7
  • libopenssl0_9_8 >= 0.9.8j-0.62.3
  • libopenssl0_9_8-32bit >= 0.9.8j-0.62.3
  • libopenssl0_9_8-hmac >= 0.9.8j-0.62.3
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.62.3
  • openssl >= 0.9.8j-0.62.3
  • openssl-doc >= 0.9.8j-0.62.3
Patchnames:
sleman17sp2-libopenssl-devel
SUSE Studio Onsite 1.3
  • libopenssl-devel >= 0.9.8j-0.62.3
Patchnames:
slestso13-libopenssl-devel
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • openssl >= 0.9.8a-18.80.5
  • openssl-devel >= 0.9.8a-18.80.5
  • openssl-doc >= 0.9.8a-18.80.5
Builds
ZYPP Patch Nr: 8815
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.80.5
  • openssl-32bit >= 0.9.8a-18.80.5
  • openssl-devel >= 0.9.8a-18.80.5
  • openssl-devel-32bit >= 0.9.8a-18.80.5
  • openssl-doc >= 0.9.8a-18.80.5
Builds
ZYPP Patch Nr: 8815
SUSE Manager 1.7 for SLE 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.62.3
  • libopenssl0_9_8-32bit >= 0.9.8j-0.62.3
  • libopenssl0_9_8-hmac >= 0.9.8j-0.62.3
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.62.3
  • openssl >= 0.9.8j-0.62.3
  • openssl-doc >= 0.9.8j-0.62.3
Builds
SAT Patch Nr: 9690
SUSE Studio Onsite 1.3
  • libopenssl-devel >= 0.9.8j-0.62.3
Builds
SAT Patch Nr: 9690
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • openssl >= 0.9.8a-18.45.75.1
  • openssl-devel >= 0.9.8a-18.45.75.1
  • openssl-doc >= 0.9.8a-18.45.75.1
Builds
ZYPP Patch Nr: 8814
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.45.75.1
  • openssl-32bit >= 0.9.8a-18.45.75.1
  • openssl-devel >= 0.9.8a-18.45.75.1
  • openssl-devel-32bit >= 0.9.8a-18.45.75.1
  • openssl-doc >= 0.9.8a-18.45.75.1
Builds
ZYPP Patch Nr: 8814
SUSE Linux Enterprise Server 11 SP2 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.58.1
  • openssl >= 0.9.8j-0.58.1
  • openssl-doc >= 0.9.8j-0.58.1
Builds
SAT Patch Nr: 9324
SUSE Linux Enterprise Server 11 SP2 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.58.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.58.1
  • openssl >= 0.9.8j-0.58.1
  • openssl-doc >= 0.9.8j-0.58.1
Builds
SAT Patch Nr: 9324
SLE CLIENT TOOLS 10 for x86
  • openssl >= 0.9.8a-18.80.5
  • openssl-certs >= 1.96-0.18.1
  • openssl-devel >= 0.9.8a-18.80.5
  • openssl-doc >= 0.9.8a-18.80.5
Builds
ZYPP Patch Nr: 8842
SLE CLIENT TOOLS 10 for s390x
SLE CLIENT TOOLS 10 for x86_64
  • openssl >= 0.9.8a-18.80.5
  • openssl-32bit >= 0.9.8a-18.80.5
  • openssl-certs >= 1.96-0.18.1
  • openssl-devel >= 0.9.8a-18.80.5
  • openssl-devel-32bit >= 0.9.8a-18.80.5
  • openssl-doc >= 0.9.8a-18.80.5
Builds
ZYPP Patch Nr: 8842
SUSE Linux Enterprise Server 11 SP1 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.58.1
  • openssl >= 0.9.8j-0.58.1
  • openssl-doc >= 0.9.8j-0.58.1
Builds
SAT Patch Nr: 9323
SUSE Linux Enterprise Server 11 SP1 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.58.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.58.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.58.1
  • openssl >= 0.9.8j-0.58.1
  • openssl-doc >= 0.9.8j-0.58.1
Builds
SAT Patch Nr: 9323
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libopenssl-devel >= 0.9.8j-0.54.1
Builds
SAT Patch Nr: 9073
SUSE Linux Enterprise Desktop 11 SP3
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • openssl >= 0.9.8j-0.54.1
Builds
SAT Patch Nr: 9073
SUSE Linux Enterprise Desktop 11 SP3
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.54.1
  • openssl >= 0.9.8j-0.54.1
Builds
SAT Patch Nr: 9073
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.54.1
  • openssl >= 0.9.8j-0.54.1
  • openssl-doc >= 0.9.8j-0.54.1
Builds
SAT Patch Nr: 9073
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.54.1
  • openssl >= 0.9.8j-0.54.1
  • openssl-doc >= 0.9.8j-0.54.1
Builds
SAT Patch Nr: 9073
SUSE Linux Enterprise Server 11 SP3
  • libopenssl0_9_8 >= 0.9.8j-0.54.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.54.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.54.1
  • openssl >= 0.9.8j-0.54.1
  • openssl-doc >= 0.9.8j-0.54.1
Builds
SAT Patch Nr: 9073
openSUSE 12.3
  • libopenssl-devel >= 1.0.1e-1.40.1
  • libopenssl-devel-32bit >= 1.0.1e-1.40.1
  • libopenssl1_0_0 >= 1.0.1e-1.40.1
  • libopenssl1_0_0-32bit >= 1.0.1e-1.40.1
  • libopenssl1_0_0-debuginfo >= 1.0.1e-1.40.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1e-1.40.1
  • openssl >= 1.0.1e-1.40.1
  • openssl-debuginfo >= 1.0.1e-1.40.1
  • openssl-debugsource >= 1.0.1e-1.40.1
  • openssl-doc >= 1.0.1e-1.40.1
Patchnames:
openSUSE-2014-269
openSUSE 13.1
  • libopenssl-devel >= 1.0.1e-11.28.1
  • libopenssl-devel-32bit >= 1.0.1e-11.28.1
  • libopenssl1_0_0 >= 1.0.1e-11.28.1
  • libopenssl1_0_0-32bit >= 1.0.1e-11.28.1
  • libopenssl1_0_0-debuginfo >= 1.0.1e-11.28.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1e-11.28.1
  • openssl >= 1.0.1e-11.28.1
  • openssl-debuginfo >= 1.0.1e-11.28.1
  • openssl-debugsource >= 1.0.1e-11.28.1
  • openssl-doc >= 1.0.1e-11.28.1
Patchnames:
openSUSE-2014-269
openSUSE 13.2
  • libopenssl0_9_8 >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-32bit >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-debuginfo >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8zh-9.3.1
  • libopenssl0_9_8-debugsource >= 0.9.8zh-9.3.1
Patchnames:
openSUSE-2016-294
openSUSE Leap 42.1
  • libopenssl0_9_8 >= 0.9.8zh-14.1
  • libopenssl0_9_8-32bit >= 0.9.8zh-14.1
  • libopenssl0_9_8-debuginfo >= 0.9.8zh-14.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8zh-14.1
  • libopenssl0_9_8-debugsource >= 0.9.8zh-14.1
Patchnames:
openSUSE-2016-294