CVE-2014-0044

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-0044 at MITRE

Description

The opus_packet_get_samples_per_frame function in client in Mumble 1.2.4 and the 1.2.3 pre-release snapshots allows remote attackers to cause a denial of service (crash) via a crafted length prefix value, which triggers a NULL pointer dereference or a heap-based buffer over-read (aka "out-of-bounds array access").

NVD CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P)

SUSE information

SUSE Bugzilla entry: 862527

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • mumble >= 1.2.5-21.4.1
  • mumble-32bit >= 1.2.5-21.4.1
  • mumble-debuginfo >= 1.2.5-21.4.1
  • mumble-debuginfo-32bit >= 1.2.5-21.4.1
  • mumble-debugsource >= 1.2.5-21.4.1
  • mumble-server >= 1.2.5-21.4.1
  • mumble-server-debuginfo >= 1.2.5-21.4.1
Patchnames:
openSUSE-2014-152
openSUSE 13.1
  • mumble >= 1.2.5-2.8.2
  • mumble-32bit >= 1.2.5-2.8.2
  • mumble-debuginfo >= 1.2.5-2.8.2
  • mumble-debuginfo-32bit >= 1.2.5-2.8.2
  • mumble-debugsource >= 1.2.5-2.8.2
  • mumble-server >= 1.2.5-2.8.2
  • mumble-server-debuginfo >= 1.2.5-2.8.2
Patchnames:
openSUSE-2014-152