Upstream information

CVE-2013-7322 at MITRE

Description

usersfile.c in liboath in OATH Toolkit before 2.4.1 does not properly handle lines containing an invalid one-time-password (OTP) type and a user name in /etc/users.oath, which causes the wrong line to be updated when invalidating an OTP and allows context-dependent attackers to conduct replay attacks, as demonstrated by a commented out line when using libpam-oath.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.9
Vector AV:N/AC:M/Au:S/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • liboath-devel >= 2.6.2-1.15
  • liboath0 >= 2.6.2-1.15
  • oath-toolkit-xml >= 2.6.2-1.15
SUSE Linux Enterprise Module for Basesystem 15
  • liboath0 >= 2.6.2-1.15
  • oath-toolkit-xml >= 2.6.2-1.15
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • oath-toolkit >= 2.6.2-1.15
SUSE Linux Enterprise Workstation Extension 15
SUSE Linux Enterprise Workstation Extension 15 SP1
SUSE Linux Enterprise Workstation Extension 15 SP2
  • libpskc-devel >= 2.6.2-1.15
  • libpskc0 >= 2.6.2-1.15
openSUSE Leap 15.0
  • libpskc0 >= 2.6.2-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libpskc0-2.6.2-lp150.1.1
openSUSE Tumbleweed
  • liboath-devel >= 2.6.7-1.3
  • liboath0 >= 2.6.7-1.3
  • libpskc-devel >= 2.6.7-1.3
  • libpskc0 >= 2.6.7-1.3
  • oath-toolkit >= 2.6.7-1.3
  • oath-toolkit-xml >= 2.6.7-1.3
  • pam_oath >= 2.6.7-1.3
Patchnames:
openSUSE Tumbleweed GA liboath-devel-2.6.7-1.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 oath-toolkit Already fixed
SUSE Enterprise Storage 6 oath-toolkit Already fixed
SUSE Linux Enterprise High Performance Computing 15 LTSS oath-toolkit Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS oath-toolkit Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 oath-toolkit Already fixed
SUSE Linux Enterprise Server 15 LTSS oath-toolkit Already fixed
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux oath-toolkit Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS oath-toolkit Already fixed
SUSE Linux Enterprise Server ESPOS 15 oath-toolkit Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 oath-toolkit Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 oath-toolkit Already fixed
SUSE Linux Enterprise Workstation Extension 15 SP2 oath-toolkit Already fixed
SUSE Manager Proxy 4.0 oath-toolkit Already fixed
SUSE Manager Retail Branch Server 4.0 oath-toolkit Already fixed
SUSE Manager Server 4.0 oath-toolkit Already fixed