Upstream information

CVE-2013-6459 at MITRE


Cross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby allows remote attackers to inject arbitrary web script or HTML via vectors involving generated pagination links.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 856831 [RESOLVED / FIXED], 858218 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • rubygem-will_paginate >= 3.0.3-0.9.1
SUSE Studio Onsite 1.3
  • susestudio >= 1.3.7-0.17.1
  • susestudio-admin_en >= 11.3-0.15.1
  • susestudio-admin_en-pdf >= 11.3-0.15.1
  • susestudio-bundled-packages >= 1.3.7-0.17.1
  • susestudio-common >= 1.3.7-0.17.1
  • susestudio-runner >= 1.3.7-0.17.1
  • susestudio-sid >= 1.3.7-0.17.1
  • susestudio-ui-server >= 1.3.7-0.17.1

Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Studio Onsite 1.3 susestudio Released

SUSE Timeline for this CVE

CVE page created: Thu Dec 26 21:18:46 2013
CVE page last modified: Tue Nov 29 12:45:27 2022