CVE-2013-6449

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-6449 at MITRE

Description

The ssl_get_algorithm2 function in ssl/s3_lib.c in OpenSSL before 1.0.2 obtains a certain version number from an incorrect data structure, which allows remote attackers to cause a denial of service (daemon crash) via crafted traffic from a TLS 1.2 client.

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P)

SUSE information

SUSE Bugzilla entry: 856687

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • libopenssl-devel >= 1.0.1e-1.21.1
  • libopenssl-devel-32bit >= 1.0.1e-1.21.1
  • libopenssl1_0_0 >= 1.0.1e-1.21.1
  • libopenssl1_0_0-32bit >= 1.0.1e-1.21.1
  • libopenssl1_0_0-debuginfo >= 1.0.1e-1.21.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1e-1.21.1
  • openssl >= 1.0.1e-1.21.1
  • openssl-debuginfo >= 1.0.1e-1.21.1
  • openssl-debugsource >= 1.0.1e-1.21.1
  • openssl-doc >= 1.0.1e-1.21.1
Patchnames:
openSUSE-2014-10
openSUSE-2014-27
openSUSE 13.1
  • libopenssl-devel >= 1.0.1e-11.9.1
  • libopenssl-devel-32bit >= 1.0.1e-11.9.1
  • libopenssl1_0_0 >= 1.0.1e-11.9.1
  • libopenssl1_0_0-32bit >= 1.0.1e-11.9.1
  • libopenssl1_0_0-debuginfo >= 1.0.1e-11.9.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.1e-11.9.1
  • openssl >= 1.0.1e-11.9.1
  • openssl-debuginfo >= 1.0.1e-11.9.1
  • openssl-debugsource >= 1.0.1e-11.9.1
  • openssl-doc >= 1.0.1e-11.9.1
Patchnames:
openSUSE-2014-27
openSUSE-2014-4