Upstream information

CVE-2013-4402 at MITRE

Description

The compressed packet parser in GnuPG 1.4.x before 1.4.15 and 2.0.x before 2.0.22 allows remote attackers to cause a denial of service (infinite recursion) via a crafted OpenPGP message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 844175 [RESOLVED / FIXED], 941439 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • gpg2 >= 2.0.9-25.33.37.1
  • gpg2-lang >= 2.0.9-25.33.37.1
Patchnames:
sledsp2-gpg2
SUSE Linux Enterprise Desktop 11 SP3
  • gpg2 >= 2.0.9-25.33.37.1
  • gpg2-lang >= 2.0.9-25.33.37.1
Patchnames:
sledsp3-gpg2
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gpg2 >= 2.0.24-3.2
  • gpg2-lang >= 2.0.24-3.2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • gpg2 >= 2.0.24-8.1
  • gpg2-lang >= 2.0.24-8.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
  • gpg2 >= 2.0.24-1.5
  • gpg2-lang >= 2.0.24-1.5
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • gpg2 >= 2.0.24-9.8.1
  • gpg2-lang >= 2.0.24-9.8.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • gpg2 >= 2.2.5-4.6.2
  • gpg2-lang >= 2.2.5-4.6.2
SUSE Linux Enterprise Module for Basesystem 15
  • gpg2 >= 2.2.5-2.9
  • gpg2-lang >= 2.2.5-2.9
SUSE Linux Enterprise Server 11 SP1-LTSS
  • gpg2 >= 2.0.9-25.33.37.6
  • gpg2-lang >= 2.0.9-25.33.37.6
Patchnames:
slessp1-gpg2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
SUSE Linux Enterprise Server for VMWare 11 SP2
  • gpg2 >= 2.0.9-25.33.37.1
  • gpg2-lang >= 2.0.9-25.33.37.1
Patchnames:
slessp2-gpg2
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • gpg2 >= 2.0.9-25.33.37.1
  • gpg2-lang >= 2.0.9-25.33.37.1
Patchnames:
slessp3-gpg2
SUSE Linux Enterprise Server 11 SP4
  • gpg2 >= 2.0.9-25.33.39.1
  • gpg2-lang >= 2.0.9-25.33.39.1
openSUSE Leap 15.0
  • gpg2 >= 2.2.5-lp150.2.1
  • gpg2-lang >= 2.2.5-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA gpg2-2.2.5-lp150.2.1
openSUSE Tumbleweed
  • gpg2 >= 2.1.16-1.1
  • gpg2-lang >= 2.1.16-1.1
Patchnames:
openSUSE Tumbleweed GA gpg2-2.1.16-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 gpg Released
SLED-10-SP4 gpg Released
SLES-10-SP3 gpg Released
SLES-10-SP4 gpg Released
SLES_LTSS-10-SP4 gpg Released