Upstream information

CVE-2013-4389 at MITRE

Description

Multiple format string vulnerabilities in log_subscriber.rb files in the log subscriber component in Action Mailer in Ruby on Rails 3.x before 3.2.15 allow remote attackers to cause a denial of service via a crafted e-mail address that is improperly handled during construction of a log message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 846239 [RESOLVED / FIXED], 854786 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • rubygem-actionmailer-3_2 >= 3.2.12-0.7.3
  • rubygem-activesupport-3_2 >= 3.2.12-0.7.1
Patchnames:
sleslms13-rubygem-actionmailer-3_2
sleslms13-rubygem-activesupport-3_2
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
SUSE Linux Enterprise Software Development Kit 11 SP2
  • rubygem-activesupport-3_2 >= 3.2.12-0.7.1
Patchnames:
sdksp2-rubygem-activesupport-3_2
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Software Development Kit 11 SP3
  • rubygem-activesupport-3_2 >= 3.2.12-0.7.1
Patchnames:
sdksp3-rubygem-activesupport-3_2
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • rubygem-actionmailer-3_2 >= 3.2.12-0.9.1
  • rubygem-actionpack-3_2 >= 3.2.12-0.19.1
  • rubygem-activesupport-3_2 >= 3.2.12-0.9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA rubygem-actionmailer-3_2-3.2.12-0.9.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA rubygem-actionpack-3_2-3.2.12-0.19.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA rubygem-activesupport-3_2-3.2.12-0.9.1
SUSE Linux Enterprise High Availability Extension 11 SP3
  • hawk >= 0.6.1-0.17.1
  • hawk-templates >= 0.6.1-0.17.1
Patchnames:
slehasp3-hawk
SUSE Linux Enterprise Server 11 SP3
  • hawk >= 0.6.1-0.17.1
  • hawk-templates >= 0.6.1-0.17.1
  • rubygem-activesupport-3_2 >= 3.2.12-0.7.1
Patchnames:
sdksp3-rubygem-activesupport-3_2
slehasp3-hawk
SUSE Studio Onsite 1.3
  • rubygem-actionmailer-3_2 >= 3.2.12-0.7.3
  • rubygem-activesupport-3_2 >= 3.2.12-0.7.1
  • susestudio >= 1.3.7-0.17.1
  • susestudio-admin_en >= 11.3-0.15.1
  • susestudio-admin_en-pdf >= 11.3-0.15.1
  • susestudio-bundled-packages >= 1.3.7-0.17.1
  • susestudio-common >= 1.3.7-0.17.1
  • susestudio-runner >= 1.3.7-0.17.1
  • susestudio-sid >= 1.3.7-0.17.1
  • susestudio-ui-server >= 1.3.7-0.17.1
Patchnames:
slestso13-rubygem-actionmailer-3_2
slestso13-rubygem-activesupport-3_2
slestso13-susestudio-137-201404
SUSE WebYast 1.3
  • rubygem-actionmailer-3_2 >= 3.2.12-0.7.3
  • rubygem-activesupport-3_2 >= 3.2.12-0.7.1
Patchnames:
slewyst13-rubygem-actionmailer-3_2
slewyst13-rubygem-activesupport-3_2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 rubygem-actionpack-2_1 Released
SUSE Linux Enterprise Server 11 SP2 rubygem-actionpack-2_1 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 rubygem-actionpack-2_1 Released
SUSE Linux Enterprise Software Development Kit 11 SP2 rubygem-actionpack-2_1 Released


SUSE Timeline for this CVE

CVE page created: Wed Oct 16 21:16:19 2013
CVE page last modified: Tue Oct 11 12:01:24 2022