Upstream information

CVE-2013-4359 at MITRE

Description

Integer overflow in kbdint.c in mod_sftp in ProFTPD 1.3.4d and 1.3.5r3 allows remote attackers to cause a denial of service (memory consumption) via a large response count value in an authentication request, which triggers a large memory allocation.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.96
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 843444 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • proftpd >= 1.3.4d-4.4.5
  • proftpd-debuginfo >= 1.3.4d-4.4.5
  • proftpd-debugsource >= 1.3.4d-4.4.5
  • proftpd-devel >= 1.3.4d-4.4.5
  • proftpd-doc >= 1.3.4d-4.4.5
  • proftpd-lang >= 1.3.4d-4.4.5
  • proftpd-ldap >= 1.3.4d-4.4.5
  • proftpd-ldap-debuginfo >= 1.3.4d-4.4.5
  • proftpd-mysql >= 1.3.4d-4.4.5
  • proftpd-mysql-debuginfo >= 1.3.4d-4.4.5
  • proftpd-pgsql >= 1.3.4d-4.4.5
  • proftpd-pgsql-debuginfo >= 1.3.4d-4.4.5
  • proftpd-radius >= 1.3.4d-4.4.5
  • proftpd-radius-debuginfo >= 1.3.4d-4.4.5
  • proftpd-sqlite >= 1.3.4d-4.4.5
  • proftpd-sqlite-debuginfo >= 1.3.4d-4.4.5
Patchnames:
openSUSE-2013-778
openSUSE 13.1
  • proftpd >= 1.3.5a-7.1
  • proftpd-debuginfo >= 1.3.5a-7.1
  • proftpd-debugsource >= 1.3.5a-7.1
  • proftpd-devel >= 1.3.5a-7.1
  • proftpd-doc >= 1.3.5a-7.1
  • proftpd-lang >= 1.3.5a-7.1
  • proftpd-ldap >= 1.3.5a-7.1
  • proftpd-ldap-debuginfo >= 1.3.5a-7.1
  • proftpd-mysql >= 1.3.5a-7.1
  • proftpd-mysql-debuginfo >= 1.3.5a-7.1
  • proftpd-pgsql >= 1.3.5a-7.1
  • proftpd-pgsql-debuginfo >= 1.3.5a-7.1
  • proftpd-radius >= 1.3.5a-7.1
  • proftpd-radius-debuginfo >= 1.3.5a-7.1
  • proftpd-sqlite >= 1.3.5a-7.1
  • proftpd-sqlite-debuginfo >= 1.3.5a-7.1
Patchnames:
openSUSE-2015-410
openSUSE 13.2
  • proftpd >= 1.3.5a-3.1
  • proftpd-debuginfo >= 1.3.5a-3.1
  • proftpd-debugsource >= 1.3.5a-3.1
  • proftpd-devel >= 1.3.5a-3.1
  • proftpd-doc >= 1.3.5a-3.1
  • proftpd-lang >= 1.3.5a-3.1
  • proftpd-ldap >= 1.3.5a-3.1
  • proftpd-ldap-debuginfo >= 1.3.5a-3.1
  • proftpd-mysql >= 1.3.5a-3.1
  • proftpd-mysql-debuginfo >= 1.3.5a-3.1
  • proftpd-pgsql >= 1.3.5a-3.1
  • proftpd-pgsql-debuginfo >= 1.3.5a-3.1
  • proftpd-radius >= 1.3.5a-3.1
  • proftpd-radius-debuginfo >= 1.3.5a-3.1
  • proftpd-sqlite >= 1.3.5a-3.1
  • proftpd-sqlite-debuginfo >= 1.3.5a-3.1
Patchnames:
openSUSE-2015-410