Upstream information

CVE-2013-4131 at MITRE

Description

The mod_dav_svn Apache HTTPD server module in Subversion 1.7.0 through 1.7.10 and 1.8.x before 1.8.1 allows remote authenticated users to cause a denial of service (assertion failure or out-of-bounds read) via a certain (1) COPY, (2) DELETE, or (3) MOVE request against a revision root.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.00
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 830031 [CLOSED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 12
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-1.25
  • libsvn_auth_kwallet-1-0 >= 1.8.10-1.25
  • subversion >= 1.8.10-1.25
  • subversion-bash-completion >= 1.8.10-1.25
  • subversion-devel >= 1.8.10-1.25
  • subversion-perl >= 1.8.10-1.25
  • subversion-python >= 1.8.10-1.25
  • subversion-server >= 1.8.10-1.25
  • subversion-tools >= 1.8.10-1.25
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libsvn_auth_gnome_keyring-1-0
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-15.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-15.1
  • subversion >= 1.8.10-15.1
  • subversion-bash-completion >= 1.8.10-15.1
  • subversion-devel >= 1.8.10-15.1
  • subversion-perl >= 1.8.10-15.1
  • subversion-python >= 1.8.10-15.1
  • subversion-server >= 1.8.10-15.1
  • subversion-tools >= 1.8.10-15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libsvn_auth_gnome_keyring-1-0
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-24.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.8.10-24.1
  • subversion-bash-completion >= 1.8.10-24.1
  • subversion-devel >= 1.8.10-24.1
  • subversion-perl >= 1.8.10-24.1
  • subversion-python >= 1.8.10-24.1
  • subversion-server >= 1.8.10-24.1
  • subversion-tools >= 1.8.10-24.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libsvn_auth_gnome_keyring-1-0
openSUSE 13.2
  • subversion >= 1.8.10-2.4.4
  • subversion-devel >= 1.8.10-2.4.4
  • subversion-perl >= 1.8.10-2.4.4
  • subversion-python >= 1.8.10-2.4.4
  • subversion-server >= 1.8.10-2.4.4
  • subversion-tools >= 1.8.10-2.4.4
Patchnames:
openSUSE 13.2 GA subversion
openSUSE Evergreen 11.4
  • libsvn_auth_gnome_keyring-1-0 >= 1.7.14-59.1
  • libsvn_auth_gnome_keyring-1-0-debuginfo >= 1.7.14-59.1
  • libsvn_auth_kwallet-1-0 >= 1.7.14-59.1
  • libsvn_auth_kwallet-1-0-debuginfo >= 1.7.14-59.1
  • subversion >= 1.7.14-59.1
  • subversion-bash-completion >= 1.7.14-59.1
  • subversion-debuginfo >= 1.7.14-59.1
  • subversion-debugsource >= 1.7.14-59.1
  • subversion-devel >= 1.7.14-59.1
  • subversion-perl >= 1.7.14-59.1
  • subversion-perl-debuginfo >= 1.7.14-59.1
  • subversion-python >= 1.7.14-59.1
  • subversion-python-debuginfo >= 1.7.14-59.1
  • subversion-ruby >= 1.7.14-59.1
  • subversion-ruby-debuginfo >= 1.7.14-59.1
  • subversion-server >= 1.7.14-59.1
  • subversion-server-debuginfo >= 1.7.14-59.1
  • subversion-tools >= 1.7.14-59.1
  • subversion-tools-debuginfo >= 1.7.14-59.1
Patchnames:
2013-169
openSUSE Leap 42.1
  • subversion >= 1.8.10-3.3
  • subversion-devel >= 1.8.10-3.3
  • subversion-perl >= 1.8.10-3.3
  • subversion-python >= 1.8.10-3.3
  • subversion-server >= 1.8.10-3.3
  • subversion-tools >= 1.8.10-3.3
Patchnames:
openSUSE Leap 42.1 GA subversion
openSUSE Leap 42.2
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.4-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.4-1.1
  • subversion >= 1.9.4-1.1
  • subversion-bash-completion >= 1.9.4-1.1
  • subversion-devel >= 1.9.4-1.1
  • subversion-perl >= 1.9.4-1.1
  • subversion-python >= 1.9.4-1.1
  • subversion-server >= 1.9.4-1.1
  • subversion-tools >= 1.9.4-1.1
Patchnames:
openSUSE Leap 42.2 GA libsvn_auth_gnome_keyring-1-0
openSUSE Tumbleweed
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.5-1.1
  • subversion >= 1.9.5-1.1
  • subversion-bash-completion >= 1.9.5-1.1
  • subversion-devel >= 1.9.5-1.1
  • subversion-perl >= 1.9.5-1.1
  • subversion-python >= 1.9.5-1.1
  • subversion-python-ctypes >= 1.9.5-1.1
  • subversion-ruby >= 1.9.5-1.1
  • subversion-server >= 1.9.5-1.1
  • subversion-tools >= 1.9.5-1.1
Patchnames:
openSUSE Tumbleweed GA libsvn_auth_gnome_keyring-1-0