Upstream information

CVE-2013-4131 at MITRE

Description

The mod_dav_svn Apache HTTPD server module in Subversion 1.7.0 through 1.7.10 and 1.8.x before 1.8.1 allows remote authenticated users to cause a denial of service (assertion failure or out-of-bounds read) via a certain (1) COPY, (2) DELETE, or (3) MOVE request against a revision root.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 830031 [VERIFIED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • subversion >= 1.10.0-3.3.1
  • subversion-devel >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Basesystem 15
  • subversion >= 1.10.0-1.24
  • subversion-devel >= 1.10.0-1.24
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • subversion-bash-completion >= 1.10.0-3.3.1
  • subversion-perl >= 1.10.0-3.3.1
  • subversion-python >= 1.10.0-3.3.1
  • subversion-tools >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Development Tools 15
  • subversion-bash-completion >= 1.10.0-1.24
  • subversion-perl >= 1.10.0-1.24
  • subversion-python >= 1.10.0-1.24
  • subversion-tools >= 1.10.0-1.24
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • subversion-server >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Server Applications 15
  • subversion-server >= 1.10.0-1.24
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-15.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-15.1
  • subversion >= 1.8.10-15.1
  • subversion-bash-completion >= 1.8.10-15.1
  • subversion-devel >= 1.8.10-15.1
  • subversion-perl >= 1.8.10-15.1
  • subversion-python >= 1.8.10-15.1
  • subversion-server >= 1.8.10-15.1
  • subversion-tools >= 1.8.10-15.1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-24.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.8.10-24.1
  • subversion-bash-completion >= 1.8.10-24.1
  • subversion-devel >= 1.8.10-24.1
  • subversion-perl >= 1.8.10-24.1
  • subversion-python >= 1.8.10-24.1
  • subversion-server >= 1.8.10-24.1
  • subversion-tools >= 1.8.10-24.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.19-25.3.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.8.19-25.3.1
  • subversion-bash-completion >= 1.8.19-25.3.1
  • subversion-devel >= 1.8.19-25.3.1
  • subversion-perl >= 1.8.19-25.3.1
  • subversion-python >= 1.8.19-25.3.1
  • subversion-server >= 1.8.19-25.3.1
  • subversion-tools >= 1.8.19-25.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libsvn_auth_gnome_keyring-1-0 >= 1.10.6-1.12
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.10.6-1.12
  • subversion-bash-completion >= 1.10.6-1.12
  • subversion-devel >= 1.10.6-1.12
  • subversion-perl >= 1.10.6-1.12
  • subversion-python >= 1.10.6-1.12
  • subversion-server >= 1.10.6-1.12
  • subversion-tools >= 1.10.6-1.12
SUSE Linux Enterprise Software Development Kit 12
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-1.25
  • libsvn_auth_kwallet-1-0 >= 1.8.10-1.25
  • subversion >= 1.8.10-1.25
  • subversion-bash-completion >= 1.8.10-1.25
  • subversion-devel >= 1.8.10-1.25
  • subversion-perl >= 1.8.10-1.25
  • subversion-python >= 1.8.10-1.25
  • subversion-server >= 1.8.10-1.25
  • subversion-tools >= 1.8.10-1.25
openSUSE Tumbleweed
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.5-1.1
  • subversion >= 1.9.5-1.1
  • subversion-bash-completion >= 1.9.5-1.1
  • subversion-devel >= 1.9.5-1.1
  • subversion-perl >= 1.9.5-1.1
  • subversion-python >= 1.9.5-1.1
  • subversion-python-ctypes >= 1.9.5-1.1
  • subversion-ruby >= 1.9.5-1.1
  • subversion-server >= 1.9.5-1.1
  • subversion-tools >= 1.9.5-1.1
Patchnames:
openSUSE Tumbleweed GA libsvn_auth_gnome_keyring-1-0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 subversion Analysis
SUSE Enterprise Storage 6 subversion Analysis
SUSE Linux Enterprise High Performance Computing 15 LTSS subversion Analysis
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS subversion Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP2 subversion Analysis
SUSE Linux Enterprise Module for Development Tools 15 SP2 subversion Analysis
SUSE Linux Enterprise Module for Server Applications 15 SP2 subversion Analysis
SUSE Linux Enterprise Server 15 LTSS subversion Analysis
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux subversion Analysis
SUSE Linux Enterprise Server 15 SP1 LTSS subversion Analysis
SUSE Linux Enterprise Server ESPOS 15 subversion Analysis
SUSE Linux Enterprise Server for SAP Applications 15 subversion Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP1 subversion Analysis
SUSE Manager Proxy 4.0 subversion Analysis
SUSE Manager Retail Branch Server 4.0 subversion Analysis
SUSE Manager Server 4.0 subversion Analysis