Upstream information

CVE-2013-2161 at MITRE

Description

XML injection vulnerability in account/utils.py in OpenStack Swift Folsom, Grizzly, and Havana allows attackers to trigger invalid or spoofed Swift responses via an account name.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 824286 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Cloud 1.0
  • openstack-swift >= 1.4.8+git.1332408124.4a6fead-0.13.1
  • openstack-swift-account >= 1.4.8+git.1332408124.4a6fead-0.13.1
  • openstack-swift-container >= 1.4.8+git.1332408124.4a6fead-0.13.1
  • openstack-swift-doc >= 1.4.8+git.1332408124.4a6fead-0.13.1
  • openstack-swift-object >= 1.4.8+git.1332408124.4a6fead-0.13.1
  • openstack-swift-proxy >= 1.4.8+git.1332408124.4a6fead-0.13.1
  • python-swift >= 1.4.8+git.1332408124.4a6fead-0.13.1
Builds
SAT Patch Nr: 7864
openSUSE 12.3
  • openstack-swift >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
  • openstack-swift-account >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
  • openstack-swift-container >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
  • openstack-swift-doc >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
  • openstack-swift-object >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
  • openstack-swift-proxy >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
  • openstack-swift-test >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
  • python-swift >= 1.7.4.1+git.1359529903.0ce3e1d-2.8.1
Patchnames:
openSUSE-2013-557