CVE-2013-2145

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-2145 at MITRE

Description

The cpansign verify functionality in the Module::Signature module before 0.72 for Perl allows attackers to bypass the signature check and execute arbitrary code via a SIGNATURE file with a "special unknown cipher" that references an untrusted module in Digest/.

NVD CVSS v2 Base Score: 4.4 (AV:L/AC:M/Au:N/C:P/I:P/A:P)

SUSE information

SUSE Bugzilla entry: 828010

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • perl-Module-Signature >= 0.73-4.4.1
Patchnames:
openSUSE-2013-573
openSUSE Evergreen 11.4
  • perl-Module-Signature >= 0.73-9.1
Patchnames:
2013-108