Upstream information

CVE-2013-2127 at MITRE

Description

Buffer overflow in the exposure correction code in LibRaw before 0.15.1 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 822665 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libraw9 >= 0.15.4-21.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Workstation Extension 12 SP1
SUSE Linux Enterprise Workstation Extension 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libraw9 >= 0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.89
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libraw-devel >= 0.15.4-30.1
  • libraw-devel-static >= 0.15.4-30.1
  • libraw9 >= 0.15.4-30.1
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libraw9 >= 0.15.4-30.1
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libraw-devel >= 0.18.9-3.8.1
  • libraw16 >= 0.18.9-3.8.1
SUSE Linux Enterprise Workstation Extension 15
  • libraw-devel >= 0.18.9-1.9
  • libraw16 >= 0.18.9-1.9
openSUSE Leap 15.0
  • libraw16 >= 0.18.9-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libraw16
openSUSE Leap 42.1
  • libraw-devel >= 0.16.2-2.6
  • libraw10 >= 0.16.2-2.6
Patchnames:
openSUSE Leap 42.1 GA libraw-devel
openSUSE Leap 42.2
  • libraw-devel >= 0.17.1-1.2
  • libraw15 >= 0.17.1-1.2
Patchnames:
openSUSE Leap 42.2 GA libraw-devel
openSUSE Leap 42.3
  • libraw-devel >= 0.17.1-4.3
  • libraw15 >= 0.17.1-4.3
Patchnames:
openSUSE Leap 42.3 GA libraw-devel
openSUSE Tumbleweed
  • libraw-devel >= 0.17.2-1.4
  • libraw-devel-static >= 0.17.2-1.4
  • libraw-tools >= 0.17.2-1.4
  • libraw15 >= 0.17.2-1.4
Patchnames:
openSUSE Tumbleweed GA libraw-devel