Upstream information

CVE-2013-2127 at MITRE

Description

Buffer overflow in the exposure correction code in LibRaw before 0.15.1 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 822665 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Desktop 12 SP2
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.89
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Desktop 12 SP3
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.89
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Desktop 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libraw-devel-0.15.4-21.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Desktop 12
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libraw-devel >= 0.18.9-3.8.1
  • libraw16 >= 0.18.9-3.8.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP1 GA libraw-devel-0.18.9-3.8.1
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Workstation Extension 15 SP2
  • libraw-devel >= 0.18.9-3.8.1
  • libraw16 >= 0.18.9-3.8.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP2 GA libraw-devel-0.18.9-3.8.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
SUSE Linux Enterprise Workstation Extension 15
  • libraw-devel >= 0.18.9-1.9
  • libraw16 >= 0.18.9-1.9
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA libraw-devel-0.18.9-1.9
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.89
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.89
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libraw-devel-0.15.4-21.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libraw-devel >= 0.15.4-30.1
  • libraw-devel-static >= 0.15.4-30.1
  • libraw9 >= 0.15.4-30.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libraw-devel-0.15.4-30.1
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libraw9-0.15.4-30.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.89
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libraw-devel >= 0.15.4-3.89
  • libraw-devel-static >= 0.15.4-3.89
  • libraw9 >= 0.15.4-3.89
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libraw-devel-0.15.4-21.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libraw-devel >= 0.15.4-30.1
  • libraw-devel-static >= 0.15.4-30.1
  • libraw9 >= 0.15.4-30.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libraw-devel-0.15.4-30.1
SUSE Linux Enterprise Software Development Kit 12
  • libraw-devel >= 0.15.4-3.88
  • libraw-devel-static >= 0.15.4-3.88
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libraw-devel-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libraw9-0.15.4-3.88
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libraw9 >= 0.15.4-30.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libraw9-0.15.4-30.1
SUSE Linux Enterprise Workstation Extension 12
  • libraw9 >= 0.15.4-3.88
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA libraw9-0.15.4-3.88
openSUSE Leap 15.0
  • libraw16 >= 0.18.9-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libraw16-0.18.9-lp150.1.1
openSUSE Tumbleweed
  • libraw-devel >= 0.17.2-1.4
  • libraw-devel-static >= 0.17.2-1.4
  • libraw-tools >= 0.17.2-1.4
  • libraw15 >= 0.17.2-1.4
Patchnames:
openSUSE Tumbleweed GA libraw-devel-0.17.2-1.4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP4 libraw Analysis
SUSE Linux Enterprise Server 12 SP5 libraw Analysis
SUSE Linux Enterprise Server 15 SP4 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libraw Analysis
SUSE Linux Enterprise Software Development Kit 12 SP5 libraw Analysis
SUSE Linux Enterprise Workstation Extension 12 SP5 libraw Analysis
SUSE Linux Enterprise Workstation Extension 15 SP4 libraw Analysis
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP4 libraw Analysis
SUSE Linux Enterprise Server 15 SP1 libraw Analysis
SUSE Linux Enterprise Server 15 SP2 libraw Analysis
SUSE Linux Enterprise Server 15 SP3 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 15 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libraw Analysis
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 12 libraw Analysis
SUSE Linux Enterprise Desktop 12 SP1 libraw Analysis
SUSE Linux Enterprise Desktop 12 SP2 libraw Analysis
SUSE Linux Enterprise Desktop 12 SP3 libraw Analysis
SUSE Linux Enterprise Desktop 12 SP4 libraw Analysis
SUSE Linux Enterprise Desktop 15 libraw Analysis
SUSE Linux Enterprise Desktop 15 SP1 libraw Analysis
SUSE Linux Enterprise Desktop 15 SP2 libraw Analysis
SUSE Linux Enterprise Desktop 15 SP3 libraw Analysis
SUSE Linux Enterprise Server 12 libraw Analysis
SUSE Linux Enterprise Server 12 SP1 libraw Analysis
SUSE Linux Enterprise Server 12 SP2 libraw Analysis
SUSE Linux Enterprise Server 12 SP3 libraw Analysis
SUSE Linux Enterprise Server 15 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 12 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libraw Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libraw Analysis
SUSE Linux Enterprise Software Development Kit 12 libraw Analysis
SUSE Linux Enterprise Software Development Kit 12 SP1 libraw Analysis
SUSE Linux Enterprise Software Development Kit 12 SP2 libraw Analysis
SUSE Linux Enterprise Software Development Kit 12 SP3 libraw Analysis
SUSE Linux Enterprise Software Development Kit 12 SP4 libraw Analysis
SUSE Linux Enterprise Workstation Extension 12 libraw Analysis
SUSE Linux Enterprise Workstation Extension 12 SP1 libraw Analysis
SUSE Linux Enterprise Workstation Extension 12 SP2 libraw Analysis
SUSE Linux Enterprise Workstation Extension 12 SP3 libraw Analysis
SUSE Linux Enterprise Workstation Extension 12 SP4 libraw Analysis
SUSE Linux Enterprise Workstation Extension 15 libraw Analysis
SUSE Linux Enterprise Workstation Extension 15 SP1 libraw Analysis
SUSE Linux Enterprise Workstation Extension 15 SP2 libraw Analysis
SUSE Linux Enterprise Workstation Extension 15 SP3 libraw Analysis


SUSE Timeline for this CVE

CVE page created: Fri Aug 9 15:58:29 2013
CVE page last modified: Mon Jan 16 15:53:24 2023