Upstream information

CVE-2013-2124 at MITRE

Description

Double free vulnerability in inspect-fs.c in LibguestFS 1.20.x before 1.20.7, 1.21.x, 1.22.0, and 1.23.0 allows remote attackers to cause a denial of service (crash) via empty guest files.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 828006 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • guestfs-data >= 1.38.0-3.52
  • guestfs-tools >= 1.38.0-3.52
  • guestfs-winsupport >= 1.38.0-3.52
  • guestfsd >= 1.38.0-3.52
  • libguestfs-devel >= 1.38.0-3.52
  • libguestfs0 >= 1.38.0-3.52
  • ocaml-libguestfs-devel >= 1.38.0-3.52
  • perl-Sys-Guestfs >= 1.38.0-3.52
  • python3-libguestfs >= 1.38.0-3.52
  • virt-v2v >= 1.38.0-3.52
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP1 GA ocaml-libguestfs-devel-1.38.0-3.52
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA guestfs-data-1.38.0-3.52
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libguestfs-devel >= 1.20.12-0.18.70
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libguestfs-devel-1.20.12-0.18.70
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libguestfs-devel >= 1.26.10-4.27
  • ocaml-libguestfs-devel >= 1.26.10-4.27
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libguestfs-devel-1.26.10-4.27
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libguestfs-devel >= 1.32.4-14.18
  • ocaml-libguestfs-devel >= 1.32.4-14.18
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libguestfs-devel-1.32.4-14.18
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libguestfs-devel >= 1.32.4-19.24
  • ocaml-libguestfs-devel >= 1.32.4-19.24
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libguestfs-devel-1.32.4-19.24
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libguestfs-devel >= 1.32.4-21.3.10
  • ocaml-libguestfs-devel >= 1.32.4-21.3.10
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libguestfs-devel-1.32.4-21.3.10
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Software Development Kit 12
  • libguestfs-devel >= 1.26.9-1.23
  • ocaml-libguestfs-devel >= 1.26.9-1.23
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libguestfs-devel-1.26.9-1.23
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • ocaml-libguestfs-devel >= 1.38.0-3.52
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP1 GA ocaml-libguestfs-devel-1.38.0-3.52
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise Module for Development Tools 15
  • ocaml-libguestfs-devel >= 1.38.0-3.52
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA ocaml-libguestfs-devel-1.38.0-3.52
SUSE Linux Enterprise High Performance Computing 12 SP5
  • guestfs-data >= 1.32.4-21.3.10
  • guestfs-tools >= 1.32.4-21.3.10
  • guestfsd >= 1.32.4-21.3.10
  • libguestfs0 >= 1.32.4-21.3.10
  • perl-Sys-Guestfs >= 1.32.4-21.3.10
  • python-libguestfs >= 1.32.4-21.3.10
  • virt-p2v >= 1.32.4-21.3.10
  • virt-v2v >= 1.32.4-21.3.10
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA guestfs-data-1.32.4-21.3.10
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • guestfs-data >= 1.38.0-3.52
  • guestfs-tools >= 1.38.0-3.52
  • guestfs-winsupport >= 1.38.0-3.52
  • guestfsd >= 1.38.0-3.52
  • libguestfs-devel >= 1.38.0-3.52
  • libguestfs0 >= 1.38.0-3.52
  • ocaml-libguestfs-devel >= 1.38.0-3.52
  • perl-Sys-Guestfs >= 1.38.0-3.52
  • python3-libguestfs >= 1.38.0-3.52
  • virt-v2v >= 1.38.0-3.52
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA ocaml-libguestfs-devel-1.38.0-3.52
SUSE Linux Enterprise Module for Server Applications 15 GA guestfs-data-1.38.0-3.52
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • guestfs-data >= 1.38.0-3.52
  • guestfs-tools >= 1.38.0-3.52
  • guestfs-winsupport >= 1.38.0-3.52
  • guestfsd >= 1.38.0-3.52
  • libguestfs-devel >= 1.38.0-3.52
  • libguestfs0 >= 1.38.0-3.52
  • perl-Sys-Guestfs >= 1.38.0-3.52
  • python3-libguestfs >= 1.38.0-3.52
  • virt-v2v >= 1.38.0-3.52
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA guestfs-data-1.38.0-3.52
SUSE Linux Enterprise Module for Server Applications 15
  • guestfs-data >= 1.38.0-3.52
  • guestfs-tools >= 1.38.0-3.52
  • guestfs-winsupport >= 1.38.0-3.52
  • guestfsd >= 1.38.0-3.52
  • libguestfs-devel >= 1.38.0-3.52
  • libguestfs0 >= 1.38.0-3.52
  • perl-Sys-Guestfs >= 1.38.0-3.52
  • python3-libguestfs >= 1.38.0-3.52
  • virt-v2v >= 1.38.0-3.52
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA guestfs-data-1.38.0-3.52
SUSE Linux Enterprise Server 11 SP3
  • guestfs-data >= 1.20.4-0.14.9
  • guestfs-tools >= 1.20.4-0.14.9
  • guestfsd >= 1.20.4-0.14.9
  • libguestfs0 >= 1.20.4-0.14.9
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA guestfs-data-1.20.4-0.14.9
SUSE Linux Enterprise Server 11 SP4
  • guestfs-data >= 1.20.12-0.18.70
  • guestfs-tools >= 1.20.12-0.18.70
  • guestfsd >= 1.20.12-0.18.70
  • libguestfs-devel >= 1.20.12-0.18.70
  • libguestfs0 >= 1.20.12-0.18.70
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA guestfs-data-1.20.12-0.18.70
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libguestfs-devel-1.20.12-0.18.70
SUSE Linux Enterprise Server 12 SP1
  • guestfs-data >= 1.26.10-4.27
  • guestfs-tools >= 1.26.10-4.27
  • guestfsd >= 1.26.10-4.27
  • libguestfs-devel >= 1.26.10-4.27
  • libguestfs0 >= 1.26.10-4.27
  • ocaml-libguestfs-devel >= 1.26.10-4.27
  • perl-Sys-Guestfs >= 1.26.10-4.27
  • python-libguestfs >= 1.26.10-4.27
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA guestfs-data-1.26.10-4.27
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libguestfs-devel-1.26.10-4.27
SUSE Linux Enterprise Server 12 SP2
  • guestfs-data >= 1.32.4-14.18
  • guestfs-tools >= 1.32.4-14.18
  • guestfsd >= 1.32.4-14.18
  • libguestfs-devel >= 1.32.4-14.18
  • libguestfs0 >= 1.32.4-14.18
  • ocaml-libguestfs-devel >= 1.32.4-14.18
  • perl-Sys-Guestfs >= 1.32.4-14.18
  • python-libguestfs >= 1.32.4-14.18
  • virt-p2v >= 1.32.4-14.18
  • virt-v2v >= 1.32.4-14.18
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA guestfs-data-1.32.4-14.18
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libguestfs-devel-1.32.4-14.18
SUSE Linux Enterprise Server 12 SP3
  • guestfs-data >= 1.32.4-19.24
  • guestfs-tools >= 1.32.4-19.24
  • guestfsd >= 1.32.4-19.24
  • libguestfs-devel >= 1.32.4-19.24
  • libguestfs0 >= 1.32.4-19.24
  • ocaml-libguestfs-devel >= 1.32.4-19.24
  • perl-Sys-Guestfs >= 1.32.4-19.24
  • python-libguestfs >= 1.32.4-19.24
  • virt-p2v >= 1.32.4-19.24
  • virt-v2v >= 1.32.4-19.24
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA guestfs-data-1.32.4-19.24
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libguestfs-devel-1.32.4-19.24
SUSE Linux Enterprise Server 12 SP4
  • guestfs-data >= 1.32.4-21.3.10
  • guestfs-tools >= 1.32.4-21.3.10
  • guestfsd >= 1.32.4-21.3.10
  • libguestfs-devel >= 1.32.4-21.3.10
  • libguestfs0 >= 1.32.4-21.3.10
  • ocaml-libguestfs-devel >= 1.32.4-21.3.10
  • perl-Sys-Guestfs >= 1.32.4-21.3.10
  • python-libguestfs >= 1.32.4-21.3.10
  • virt-p2v >= 1.32.4-21.3.10
  • virt-v2v >= 1.32.4-21.3.10
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA guestfs-data-1.32.4-21.3.10
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libguestfs-devel-1.32.4-21.3.10
SUSE Linux Enterprise Server 12 SP5
  • guestfs-data >= 1.32.4-21.3.10
  • guestfs-tools >= 1.32.4-21.3.10
  • guestfsd >= 1.32.4-21.3.10
  • libguestfs-devel >= 1.32.4-21.3.10
  • libguestfs0 >= 1.32.4-21.3.10
  • ocaml-libguestfs-devel >= 1.32.4-21.3.10
  • perl-Sys-Guestfs >= 1.32.4-21.3.10
  • python-libguestfs >= 1.32.4-21.3.10
  • virt-p2v >= 1.32.4-21.3.10
  • virt-v2v >= 1.32.4-21.3.10
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA guestfs-data-1.32.4-21.3.10
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libguestfs-devel-1.32.4-21.3.10
SUSE Linux Enterprise Server 12
  • guestfs-data >= 1.26.9-1.23
  • guestfs-tools >= 1.26.9-1.23
  • guestfsd >= 1.26.9-1.23
  • libguestfs-devel >= 1.26.9-1.23
  • libguestfs0 >= 1.26.9-1.23
  • ocaml-libguestfs-devel >= 1.26.9-1.23
  • perl-Sys-Guestfs >= 1.26.9-1.23
Patchnames:
SUSE Linux Enterprise Server 12 GA guestfs-data-1.26.9-1.23
SUSE Linux Enterprise Software Development Kit 12 GA libguestfs-devel-1.26.9-1.23
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • guestfs-data >= 1.32.4-14.18
  • guestfs-tools >= 1.32.4-14.18
  • guestfsd >= 1.32.4-14.18
  • libguestfs0 >= 1.32.4-14.18
  • perl-Sys-Guestfs >= 1.32.4-14.18
  • python-libguestfs >= 1.32.4-14.18
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA guestfs-data-1.32.4-14.18
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libguestfs-devel >= 1.32.4-21.3.10
  • ocaml-libguestfs-devel >= 1.32.4-21.3.10
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libguestfs-devel-1.32.4-21.3.10
openSUSE Leap 15.0
  • guestfs-data >= 1.38.0-lp150.2.4
  • libguestfs0 >= 1.38.0-lp150.2.4
  • virt-v2v >= 1.38.0-lp150.2.4
Patchnames:
openSUSE Leap 15.0 GA guestfs-data-1.38.0-lp150.2.4
openSUSE Tumbleweed
  • guestfs-data >= 1.32.4-11.1
  • guestfs-tools >= 1.32.4-11.1
  • guestfsd >= 1.32.4-11.1
  • libguestfs-devel >= 1.32.4-11.1
  • libguestfs-test >= 1.32.4-11.1
  • libguestfs0 >= 1.32.4-11.1
  • lua-libguestfs >= 1.32.4-11.1
  • ocaml-libguestfs >= 1.32.4-11.1
  • ocaml-libguestfs-devel >= 1.32.4-11.1
  • perl-Sys-Guestfs >= 1.32.4-11.1
  • python-libguestfs >= 1.32.4-11.1
  • rubygem-libguestfs >= 1.32.4-11.1
  • virt-p2v >= 1.32.4-11.1
Patchnames:
openSUSE Tumbleweed GA guestfs-data-1.32.4-11.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP4 libguestfs Already fixed
SUSE Linux Enterprise Server 11 SP3 libguestfs Already fixed
SUSE Linux Enterprise Server 11 SP3-LTSS libguestfs Already fixed
SUSE Linux Enterprise Server 11 SP4 libguestfs Already fixed
SUSE Linux Enterprise Server 11 SP4-LTSS libguestfs Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libguestfs Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 libguestfs Already fixed


SUSE Timeline for this CVE

CVE page created: Wed Jul 3 18:55:34 2013
CVE page last modified: Mon Jan 16 15:53:22 2023