Upstream information

CVE-2013-2066 at MITRE

Description

Buffer overflow in X.org libXv 1.0.7 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the XvQueryPortAttributes function.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 815451 [RESOLVED / FIXED], 821671 [RESOLVED / FIXED], 880221 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • xorg-x11-libXv >= 7.4-1.16.1
  • xorg-x11-libXv-32bit >= 7.4-1.16.1
  • xorg-x11-libXv-devel >= 7.4-1.16.1
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.1
Patchnames:
sdksp2-xorg-x11-libXv
sledsp2-xorg-x11-libXv
SUSE Linux Enterprise Desktop 11 SP3
  • xorg-x11-libXv >= 7.4-1.16.2
  • xorg-x11-libXv-32bit >= 7.4-1.16.2
  • xorg-x11-libXv-devel >= 7.4-1.16.2
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.2
Patchnames:
sdksp3-xorg-x11-libXv
sledsp3-xorg-x11-libXv
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-libXv-devel >= 7.4-1.16.2
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA xorg-x11-libXv-devel-32bit-7.4-1.16.2
SUSE Linux Enterprise Desktop 12 SP1
  • libXv-devel >= 1.0.10-3.57
  • libXv1 >= 1.0.10-3.57
  • libXv1-32bit >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libXv1-1.0.10-3.57
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libXv-devel-1.0.10-3.57
SUSE Linux Enterprise Desktop 12 SP2
  • libXv-devel >= 1.0.10-3.57
  • libXv1 >= 1.0.10-3.57
  • libXv1-32bit >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libXv1-1.0.10-3.57
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libXv-devel-1.0.10-3.56
SUSE Linux Enterprise Desktop 12 SP3
  • libXv-devel >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libXv1-1.0.10-7.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Desktop 12 SP4
  • libXv-devel >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libXv1-1.0.10-7.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Desktop 12
  • libXv-devel >= 1.0.10-3.57
  • libXv1 >= 1.0.10-3.57
  • libXv1-32bit >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libXv1-1.0.10-3.57
SUSE Linux Enterprise Software Development Kit 12 GA libXv-devel-1.0.10-3.57
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libXv-devel >= 1.0.11-1.23
  • libXv1 >= 1.0.11-1.23
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libXv-devel-1.0.11-1.23
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libXv-devel >= 1.0.11-1.23
  • libXv1 >= 1.0.11-1.23
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libXv-devel-1.0.11-1.23
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libXv-devel >= 1.0.11-1.23
  • libXv1 >= 1.0.11-1.23
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libXv-devel-1.0.11-1.23
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libXv-devel >= 1.0.11-1.23
  • libXv1 >= 1.0.11-1.23
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libXv-devel-1.0.11-1.23
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libXv1-1.0.10-7.1
SUSE Linux Enterprise Server 11 SP1-LTSS
  • xorg-x11-libXv >= 7.4-1.16.8
  • xorg-x11-libXv-32bit >= 7.4-1.16.8
Patchnames:
slessp1-xorg-x11-libXv
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
  • xorg-x11-libXv >= 7.4-1.16.1
  • xorg-x11-libXv-32bit >= 7.4-1.16.1
  • xorg-x11-libXv-devel >= 7.4-1.16.1
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.1
  • xorg-x11-libXv-x86 >= 7.4-1.16.1
Patchnames:
sdksp2-xorg-x11-libXv
slessp2-xorg-x11-libXv
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • xorg-x11-libXv >= 7.4-1.16.2
  • xorg-x11-libXv-32bit >= 7.4-1.16.2
  • xorg-x11-libXv-devel >= 7.4-1.16.2
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.2
  • xorg-x11-libXv-x86 >= 7.4-1.16.2
Patchnames:
sdksp3-xorg-x11-libXv
slessp3-xorg-x11-libXv
SUSE Linux Enterprise Server 11 SP4
  • xorg-x11-libXv >= 7.4-1.16.8
  • xorg-x11-libXv-32bit >= 7.4-1.16.8
  • xorg-x11-libXv-devel >= 7.4-1.16.2
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.2
  • xorg-x11-libXv-x86 >= 7.4-1.16.2
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA xorg-x11-libXv-32bit-7.4-1.16.2
SUSE Linux Enterprise Software Development Kit 11 SP4 GA xorg-x11-libXv-devel-32bit-7.4-1.16.2
SUSE Linux Enterprise Server 12 SP1
  • libXv-devel >= 1.0.10-3.57
  • libXv1 >= 1.0.10-3.57
  • libXv1-32bit >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libXv1-1.0.10-3.57
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libXv-devel-1.0.10-3.57
SUSE Linux Enterprise Server 12 SP2
  • libXv-devel >= 1.0.10-3.57
  • libXv1 >= 1.0.10-3.57
  • libXv1-32bit >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libXv1-1.0.10-3.56
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libXv-devel-1.0.10-3.56
SUSE Linux Enterprise Server 12 SP3
  • libXv-devel >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libXv1-1.0.10-7.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Server 12 SP4
  • libXv-devel >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libXv1-1.0.10-7.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Server 12 SP5
  • libXv-devel >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libXv1-1.0.10-7.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Server 12
  • libXv-devel >= 1.0.10-3.57
  • libXv1 >= 1.0.10-3.57
  • libXv1-32bit >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Server 12 GA libXv1-1.0.10-3.56
SUSE Linux Enterprise Software Development Kit 12 GA libXv-devel-1.0.10-3.57
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libXv1 >= 1.0.10-3.56
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libXv1-1.0.10-3.56
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libXv-devel >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libXv-devel-1.0.10-3.57
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libXv-devel >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libXv-devel-1.0.10-3.56
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libXv-devel >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libXv-devel >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libXv-devel >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libXv-devel-1.0.10-7.1
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Software Development Kit 12
  • libXv-devel >= 1.0.10-3.57
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libXv-devel-1.0.10-3.57
SUSE Linux Enterprise Software Development Kit 11 SP2
  • xorg-x11-libXv-devel >= 7.4-1.16.1
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.1
Patchnames:
sdksp2-xorg-x11-libXv
SUSE Linux Enterprise Software Development Kit 11 SP3
  • xorg-x11-libXv-devel >= 7.4-1.16.2
  • xorg-x11-libXv-devel-32bit >= 7.4-1.16.2
Patchnames:
sdksp3-xorg-x11-libXv
openSUSE Leap 15.0
  • libXv1 >= 1.0.11-lp150.1.7
Patchnames:
openSUSE Leap 15.0 GA libXv1-1.0.11-lp150.1.7
openSUSE Tumbleweed
  • libXv-devel >= 1.0.11-1.1
  • libXv-devel-32bit >= 1.0.11-1.1
  • libXv1 >= 1.0.11-1.1
  • libXv1-32bit >= 1.0.11-1.1
Patchnames:
openSUSE Tumbleweed GA libXv-devel-1.0.11-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications Mesa Released
SUSE Linux Enterprise Desktop 11 SP1 Mesa Released
SUSE Linux Enterprise Desktop 11 SP2 Mesa Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search Mesa Released
SUSE Linux Enterprise Server 11 SP1 Mesa Released
SUSE Linux Enterprise Server 11 SP1 LTSS Mesa Released
SUSE Linux Enterprise Server 11 SP2 Mesa Released
SUSE Linux Enterprise Server 11 SP2 LTSS Mesa Released
SUSE Linux Enterprise Server 11 SP2 for VMware Mesa Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 Mesa Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 Mesa Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 Mesa Released
SUSE Linux Enterprise Software Development Kit 11 SP1 Mesa Released
SUSE Linux Enterprise Software Development Kit 11 SP2 Mesa Released