Upstream information

CVE-2013-2062 at MITRE

Description

Multiple integer overflows in X.org libXp 1.0.1 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XpGetAttributes, (2) XpGetOneAttribute, (3) XpGetPrinterList, and (4) XpQueryScreens functions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 815451 [RESOLVED / FIXED], 821668 [RESOLVED / FIXED], 880221 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • xorg-x11-libXp >= 7.4-1.18.1
  • xorg-x11-libXp-32bit >= 7.4-1.18.1
  • xorg-x11-libXp-devel >= 7.4-1.18.1
Patchnames:
sledsp2-xorg-x11-libXp
SUSE Linux Enterprise Desktop 11 SP3
  • xorg-x11-libXp >= 7.4-1.18.1
  • xorg-x11-libXp-32bit >= 7.4-1.18.1
Patchnames:
sledsp3-xorg-x11-libXp
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libXp6 >= 1.0.2-3.58
  • libXp6-32bit >= 1.0.2-3.58
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libXp-devel >= 1.0.3-1.24
  • libXp6 >= 1.0.3-1.24
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • libXp6-32bit >= 1.0.3-1.24
SUSE Linux Enterprise Server 11 SP1-LTSS
  • xorg-x11-libXp >= 7.4-1.18.7
  • xorg-x11-libXp-32bit >= 7.4-1.18.7
Patchnames:
slessp1-xorg-x11-libXp
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server for SAP Applications 11 SP2
SUSE Linux Enterprise Server for VMWare 11 SP2
  • xorg-x11-libXp >= 7.4-1.18.1
  • xorg-x11-libXp-32bit >= 7.4-1.18.1
  • xorg-x11-libXp-x86 >= 7.4-1.18.1
Patchnames:
slessp2-xorg-x11-libXp
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • xorg-x11-libXp >= 7.4-1.18.1
  • xorg-x11-libXp-32bit >= 7.4-1.18.1
  • xorg-x11-libXp-x86 >= 7.4-1.18.1
Patchnames:
slessp3-xorg-x11-libXp
SUSE Linux Enterprise Server 11 SP4
  • xorg-x11-libXp >= 7.4-1.18.7
  • xorg-x11-libXp-32bit >= 7.4-1.18.7
  • xorg-x11-libXp-x86 >= 7.4-1.18.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libXp6 >= 1.0.2-3.57
SUSE Linux Enterprise Software Development Kit 11 SP2
  • xorg-x11-libXp-devel >= 7.4-1.18.1
  • xorg-x11-libXp-devel-32bit >= 7.4-1.18.1
Patchnames:
sdksp2-xorg-x11-libXp
SUSE Linux Enterprise Software Development Kit 11 SP3
  • xorg-x11-libXp-devel >= 7.4-1.18.1
  • xorg-x11-libXp-devel-32bit >= 7.4-1.18.1
Patchnames:
sdksp3-xorg-x11-libXp
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-libXp-devel >= 7.4-1.18.1
  • xorg-x11-libXp-devel-32bit >= 7.4-1.18.1
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libXp-devel >= 1.0.2-3.58
openSUSE Leap 15.0
  • libXp6 >= 1.0.3-lp150.1.7
Patchnames:
openSUSE Leap 15.0 GA libXp6-1.0.3-lp150.1.7
openSUSE Tumbleweed
  • libXp-devel >= 1.0.3-1.7
  • libXp-devel-32bit >= 1.0.3-1.7
  • libXp6 >= 1.0.3-1.7
  • libXp6-32bit >= 1.0.3-1.7
Patchnames:
openSUSE Tumbleweed GA libXp-devel-1.0.3-1.7


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 Mesa Released
SLED-10-SP4 Mesa Released
SLES for SAP Applications Mesa Released
SLES-10-SP3 Mesa Released
SLES-10-SP4 Mesa Released
SLES_LTSS-10-SP4 Mesa Released
SUSE Linux Enterprise Desktop 11 SP1 Mesa Released
SUSE Linux Enterprise Desktop 11 SP2 Mesa Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search Mesa Released
SUSE Linux Enterprise Server 11 SP1 Mesa Released
SUSE Linux Enterprise Server 11 SP1 LTSS Mesa Released
SUSE Linux Enterprise Server 11 SP2 Mesa Released
SUSE Linux Enterprise Server 11 SP2 LTSS Mesa Released
SUSE Linux Enterprise Server 11 SP2 for VMware Mesa Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 Mesa Released
SUSE Linux Enterprise Software Development Kit 11 SP1 Mesa Released
SUSE Linux Enterprise Software Development Kit 11 SP2 Mesa Released