Upstream information

CVE-2013-1976 at MITRE

Description

The (1) tomcat5, (2) tomcat6, and (3) tomcat7 init scripts, as used in the RPM distribution of Tomcat for JBoss Enterprise Web Server 1.0.2 and 2.0.0, and Red Hat Enterprise Linux 5 and 6, allow local users to change the ownership of arbitrary files via a symlink attack on (a) tomcat5-initd.log, (b) tomcat6-initd.log, (c) catalina.out, or (d) tomcat7-initd.log.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.89
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 822177 [RESOLVED / FIXED], 824284 [CLOSED / ]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libmysqlclient18 >= 10.0.11-6.4
  • libmysqlclient18-32bit >= 10.0.11-6.4
  • libmysqlclient_r18 >= 10.0.11-6.4
  • libmysqlclient_r18-32bit >= 10.0.11-6.4
  • mariadb >= 10.0.11-6.4
  • mariadb-client >= 10.0.11-6.4
  • mariadb-errormessages >= 10.0.11-6.4
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libmysqlclient18
SUSE Linux Enterprise Desktop 12 SP1
  • libmysqlclient18 >= 10.0.21-1.17
  • libmysqlclient18-32bit >= 10.0.21-1.17
  • libmysqlclient_r18 >= 10.0.21-1.17
  • libmysqlclient_r18-32bit >= 10.0.21-1.17
  • mariadb >= 10.0.21-1.17
  • mariadb-client >= 10.0.21-1.17
  • mariadb-errormessages >= 10.0.21-1.17
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libmysqlclient18
SUSE Linux Enterprise Desktop 12 SP2
  • libmysqlclient18 >= 10.0.27-12.1
  • libmysqlclient18-32bit >= 10.0.27-12.1
  • libmysqlclient_r18 >= 10.0.27-12.1
  • libmysqlclient_r18-32bit >= 10.0.27-12.1
  • mariadb >= 10.0.27-12.1
  • mariadb-client >= 10.0.27-12.1
  • mariadb-errormessages >= 10.0.27-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libmysqlclient18
SUSE Linux Enterprise Server 11 SP2
  • tomcat6 >= 6.0.18-20.35.42.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.42.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.42.1
  • tomcat6-javadoc >= 6.0.18-20.35.42.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.42.1
  • tomcat6-lib >= 6.0.18-20.35.42.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.42.1
  • tomcat6-webapps >= 6.0.18-20.35.42.1
Patchnames:
slessp2-tomcat6
SUSE Linux Enterprise Server 11 SP3
  • tomcat6 >= 6.0.18-20.35.42.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.42.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.42.1
  • tomcat6-javadoc >= 6.0.18-20.35.42.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.42.1
  • tomcat6-lib >= 6.0.18-20.35.42.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.42.1
  • tomcat6-webapps >= 6.0.18-20.35.42.1
Patchnames:
slessp3-tomcat6
SUSE Linux Enterprise Server 11 SP4
  • libmysql55client18 >= 5.5.43-0.7.3
  • libmysql55client18-32bit >= 5.5.43-0.7.3
  • libmysql55client18-x86 >= 5.5.43-0.7.3
  • libmysql55client_r18 >= 5.5.43-0.7.3
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • mysql >= 5.5.43-0.7.3
  • mysql-client >= 5.5.43-0.7.3
  • mysql-tools >= 5.5.43-0.7.3
  • tomcat6 >= 6.0.41-0.43.1
  • tomcat6-admin-webapps >= 6.0.41-0.43.1
  • tomcat6-docs-webapp >= 6.0.41-0.43.1
  • tomcat6-javadoc >= 6.0.41-0.43.1
  • tomcat6-jsp-2_1-api >= 6.0.41-0.43.1
  • tomcat6-lib >= 6.0.41-0.43.1
  • tomcat6-servlet-2_5-api >= 6.0.41-0.43.1
  • tomcat6-webapps >= 6.0.41-0.43.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libmysql55client18-32bit
SUSE Linux Enterprise Server 11 SP4 GA tomcat6
SUSE Linux Enterprise Server 12
  • libmysqlclient18 >= 10.0.11-6.4
  • libmysqlclient18-32bit >= 10.0.11-6.4
  • mariadb >= 10.0.11-6.4
  • mariadb-client >= 10.0.11-6.4
  • mariadb-errormessages >= 10.0.11-6.4
  • mariadb-tools >= 10.0.11-6.4
  • tomcat >= 7.0.55-2.8
  • tomcat-admin-webapps >= 7.0.55-2.8
  • tomcat-docs-webapp >= 7.0.55-2.8
  • tomcat-el-2_2-api >= 7.0.55-2.8
  • tomcat-javadoc >= 7.0.55-2.8
  • tomcat-jsp-2_2-api >= 7.0.55-2.8
  • tomcat-lib >= 7.0.55-2.8
  • tomcat-servlet-3_0-api >= 7.0.55-2.8
  • tomcat-webapps >= 7.0.55-2.8
Patchnames:
SUSE Linux Enterprise Server 12 GA libmysqlclient18
SUSE Linux Enterprise Server 12 GA tomcat
SUSE Linux Enterprise Server 12 SP1
  • libmysqlclient18 >= 10.0.21-1.17
  • libmysqlclient18-32bit >= 10.0.21-1.17
  • mariadb >= 10.0.21-1.17
  • mariadb-client >= 10.0.21-1.17
  • mariadb-errormessages >= 10.0.21-1.17
  • mariadb-tools >= 10.0.21-1.17
  • tomcat >= 8.0.23-1.80
  • tomcat-admin-webapps >= 8.0.23-1.80
  • tomcat-docs-webapp >= 8.0.23-1.80
  • tomcat-el-3_0-api >= 8.0.23-1.80
  • tomcat-javadoc >= 8.0.23-1.80
  • tomcat-jsp-2_3-api >= 8.0.23-1.80
  • tomcat-lib >= 8.0.23-1.80
  • tomcat-servlet-3_1-api >= 8.0.23-1.80
  • tomcat-webapps >= 8.0.23-1.80
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libmysqlclient18
SUSE Linux Enterprise Server 12 SP1 GA tomcat
SUSE Linux Enterprise Server 12 SP2
  • libmysqlclient18 >= 10.0.27-12.1
  • libmysqlclient18-32bit >= 10.0.27-12.1
  • mariadb >= 10.0.27-12.1
  • mariadb-client >= 10.0.27-12.1
  • mariadb-errormessages >= 10.0.27-12.1
  • mariadb-tools >= 10.0.27-12.1
  • tomcat >= 8.0.36-11.4
  • tomcat-admin-webapps >= 8.0.36-11.4
  • tomcat-docs-webapp >= 8.0.36-11.4
  • tomcat-el-3_0-api >= 8.0.36-11.4
  • tomcat-javadoc >= 8.0.36-11.4
  • tomcat-jsp-2_3-api >= 8.0.36-11.4
  • tomcat-lib >= 8.0.36-11.4
  • tomcat-servlet-3_1-api >= 8.0.36-11.4
  • tomcat-webapps >= 8.0.36-11.4
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libmysqlclient18
SUSE Linux Enterprise Server 12 SP2 GA tomcat
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libmysqlclient18 >= 10.0.27-12.1
  • mariadb >= 10.0.27-12.1
  • mariadb-client >= 10.0.27-12.1
  • mariadb-errormessages >= 10.0.27-12.1
  • mariadb-tools >= 10.0.27-12.1
  • tomcat >= 8.0.36-11.4
  • tomcat-admin-webapps >= 8.0.36-11.4
  • tomcat-docs-webapp >= 8.0.36-11.4
  • tomcat-el-3_0-api >= 8.0.36-11.4
  • tomcat-javadoc >= 8.0.36-11.4
  • tomcat-jsp-2_3-api >= 8.0.36-11.4
  • tomcat-lib >= 8.0.36-11.4
  • tomcat-servlet-3_1-api >= 8.0.36-11.4
  • tomcat-webapps >= 8.0.36-11.4
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libmysqlclient18
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA tomcat
SUSE Linux Enterprise Server for VMWare 11 SP2
  • tomcat6 >= 6.0.18-20.35.42.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.42.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.42.1
  • tomcat6-javadoc >= 6.0.18-20.35.42.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.42.1
  • tomcat6-lib >= 6.0.18-20.35.42.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.42.1
  • tomcat6-webapps >= 6.0.18-20.35.42.1
Patchnames:
slessp2-tomcat6
SUSE Linux Enterprise Server for VMWare 11 SP3
  • tomcat6 >= 6.0.18-20.35.42.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.42.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.42.1
  • tomcat6-javadoc >= 6.0.18-20.35.42.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.42.1
  • tomcat6-lib >= 6.0.18-20.35.42.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.42.1
  • tomcat6-webapps >= 6.0.18-20.35.42.1
Patchnames:
slessp3-tomcat6
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysql55client_r18-32bit
SUSE Linux Enterprise Software Development Kit 12
  • libmysqlclient-devel >= 10.0.11-6.4
  • libmysqlclient_r18 >= 10.0.11-6.4
  • libmysqld-devel >= 10.0.11-6.4
  • libmysqld18 >= 10.0.11-6.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libmysqlclient-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libmysqlclient-devel >= 10.0.21-1.17
  • libmysqlclient_r18 >= 10.0.21-1.17
  • libmysqld-devel >= 10.0.21-1.17
  • libmysqld18 >= 10.0.21-1.17
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libmysqlclient-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libmysqlclient-devel >= 10.0.27-12.1
  • libmysqlclient_r18 >= 10.0.27-12.1
  • libmysqld-devel >= 10.0.27-12.1
  • libmysqld18 >= 10.0.27-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libmysqlclient-devel
SUSE Linux Enterprise Workstation Extension 12
  • libmysqlclient_r18 >= 10.0.11-6.4
  • libmysqlclient_r18-32bit >= 10.0.11-6.4
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA libmysqlclient_r18
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libmysqlclient_r18 >= 10.0.21-1.17
  • libmysqlclient_r18-32bit >= 10.0.21-1.17
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libmysqlclient_r18
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libmysqlclient_r18 >= 10.0.27-12.1
  • libmysqlclient_r18-32bit >= 10.0.27-12.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libmysqlclient_r18
SUSE Manager 1.2 for SLE 11 SP1
  • tomcat6 >= 6.0.18-20.35.42.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.42.1
  • tomcat6-lib >= 6.0.18-20.35.42.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.42.1
Builds
SAT Patch Nr: 8154
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • tomcat6 >= 6.0.18-20.35.42.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.42.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.42.1
  • tomcat6-javadoc >= 6.0.18-20.35.42.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.42.1
  • tomcat6-lib >= 6.0.18-20.35.42.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.42.1
  • tomcat6-webapps >= 6.0.18-20.35.42.1
Builds
SAT Patch Nr: 8155
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • tomcat6 >= 6.0.18-20.35.42.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.42.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.42.1
  • tomcat6-javadoc >= 6.0.18-20.35.42.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.42.1
  • tomcat6-lib >= 6.0.18-20.35.42.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.42.1
  • tomcat6-webapps >= 6.0.18-20.35.42.1
Builds
SAT Patch Nr: 8156
openSUSE 12.3
  • tomcat >= 7.0.35-2.33.1
  • tomcat-admin-webapps >= 7.0.35-2.33.1
  • tomcat-docs-webapp >= 7.0.35-2.33.1
  • tomcat-el-2_2-api >= 7.0.35-2.33.1
  • tomcat-javadoc >= 7.0.35-2.33.1
  • tomcat-jsp-2_2-api >= 7.0.35-2.33.1
  • tomcat-jsvc >= 7.0.35-2.33.1
  • tomcat-lib >= 7.0.35-2.33.1
  • tomcat-servlet-3_0-api >= 7.0.35-2.33.1
  • tomcat-webapps >= 7.0.35-2.33.1
Patchnames:
openSUSE-2013-632
openSUSE 13.2
  • libmysqlclient-devel >= 10.0.13-2.3.2
  • libmysqlclient18 >= 10.0.13-2.3.2
  • libmysqlclient18-32bit >= 10.0.13-2.3.2
  • libmysqlclient_r18 >= 10.0.13-2.3.2
  • libmysqld18 >= 10.0.13-2.3.2
  • mariadb >= 10.0.13-2.3.2
  • mariadb-client >= 10.0.13-2.3.2
  • mariadb-errormessages >= 10.0.13-2.3.2
Patchnames:
openSUSE 13.2 GA libmysqlclient-devel
openSUSE Evergreen 11.4
  • tomcat6 >= 6.0.32-42.1
  • tomcat6-admin-webapps >= 6.0.32-42.1
  • tomcat6-docs-webapp >= 6.0.32-42.1
  • tomcat6-el-1_0-api >= 6.0.32-42.1
  • tomcat6-javadoc >= 6.0.32-42.1
  • tomcat6-jsp-2_1-api >= 6.0.32-42.1
  • tomcat6-lib >= 6.0.32-42.1
  • tomcat6-servlet-2_5-api >= 6.0.32-42.1
  • tomcat6-webapps >= 6.0.32-42.1
Patchnames:
2013-129
openSUSE Leap 42.1
  • libmysqlclient-devel >= 10.0.21-1.5
  • libmysqlclient18 >= 10.0.21-1.5
  • libmysqlclient18-32bit >= 10.0.21-1.5
  • libmysqlclient_r18 >= 10.0.21-1.5
  • libmysqld18 >= 10.0.21-1.5
  • mariadb >= 10.0.21-1.5
  • mariadb-client >= 10.0.21-1.5
  • mariadb-errormessages >= 10.0.21-1.5
Patchnames:
openSUSE Leap 42.1 GA libmysqlclient-devel
openSUSE Leap 42.2
  • libmysqlclient-devel >= 10.0.27-13.1
  • libmysqlclient18 >= 10.0.27-13.1
  • libmysqlclient_r18 >= 10.0.27-13.1
  • libmysqld18 >= 10.0.27-13.1
  • mariadb >= 10.0.27-13.1
  • mariadb-client >= 10.0.27-13.1
  • mariadb-errormessages >= 10.0.27-13.1
  • tomcat >= 8.0.36-2.7
  • tomcat-admin-webapps >= 8.0.36-2.7
  • tomcat-el-3_0-api >= 8.0.36-2.7
  • tomcat-jsp-2_3-api >= 8.0.36-2.7
  • tomcat-lib >= 8.0.36-2.7
  • tomcat-servlet-3_1-api >= 8.0.36-2.7
  • tomcat-webapps >= 8.0.36-2.7
Patchnames:
openSUSE Leap 42.2 GA libmysqlclient-devel
openSUSE Leap 42.2 GA tomcat
openSUSE Tumbleweed
  • libmysql56client18 >= 5.6.34-1.1
  • libmysql56client18-32bit >= 5.6.34-1.1
  • libmysql56client_r18 >= 5.6.34-1.1
  • libmysql56client_r18-32bit >= 5.6.34-1.1
  • libmysqlclient-devel >= 10.0.22-3.8
  • libmysqlclient18 >= 10.0.22-3.8
  • libmysqlclient18-32bit >= 10.0.22-3.8
  • libmysqlclient_r18 >= 10.0.22-3.8
  • libmysqlclient_r18-32bit >= 10.0.22-3.8
  • libmysqld-devel >= 10.0.22-3.8
  • libmysqld18 >= 10.0.22-3.8
  • mariadb >= 10.0.22-3.8
  • mariadb-bench >= 10.0.22-3.8
  • mariadb-client >= 10.0.22-3.8
  • mariadb-errormessages >= 10.0.22-3.8
  • mariadb-test >= 10.0.22-3.8
  • mariadb-tools >= 10.0.22-3.8
  • mysql-community-server >= 5.6.34-1.1
  • mysql-community-server-bench >= 5.6.34-1.1
  • mysql-community-server-client >= 5.6.34-1.1
  • mysql-community-server-errormessages >= 5.6.34-1.1
  • mysql-community-server-test >= 5.6.34-1.1
  • mysql-community-server-tools >= 5.6.34-1.1
  • tomcat >= 8.0.36-3.3
  • tomcat-admin-webapps >= 8.0.36-3.3
  • tomcat-docs-webapp >= 8.0.36-3.3
  • tomcat-el-3_0-api >= 8.0.36-3.3
  • tomcat-embed >= 8.0.36-3.3
  • tomcat-javadoc >= 8.0.36-3.3
  • tomcat-jsp-2_3-api >= 8.0.36-3.3
  • tomcat-jsvc >= 8.0.36-3.3
  • tomcat-lib >= 8.0.36-3.3
  • tomcat-servlet-3_1-api >= 8.0.36-3.3
  • tomcat-webapps >= 8.0.36-3.3
Patchnames:
openSUSE Tumbleweed GA libmysql56client18-32bit
openSUSE Tumbleweed GA libmysqlclient-devel
openSUSE Tumbleweed GA tomcat