Upstream information

CVE-2013-1431 at MITRE

Description

The Wocky module in Telepathy Gabble before 0.16.6 and 0.17.x before 0.17.4, when connecting to a "legacy Jabber server," does not properly enforce the WockyConnector:tls-required flag, which allows remote attackers to bypass TLS verification and perform a man-in-the-middle attacks.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 822586 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
  • telepathy-gabble >= 0.18.3-5.7
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Workstation Extension 12 SP1
  • telepathy-gabble >= 0.18.1-3.268
openSUSE 12.3
  • telepathy-gabble >= 0.17.1-2.8.1
  • telepathy-gabble-debuginfo >= 0.17.1-2.8.1
  • telepathy-gabble-debugsource >= 0.17.1-2.8.1
  • telepathy-gabble-xmpp-console >= 0.17.1-2.8.1
  • telepathy-gabble-xmpp-console-debuginfo >= 0.17.1-2.8.1
Patchnames:
openSUSE-2013-492
openSUSE Leap 42.1
  • telepathy-gabble >= 0.18.3-2.2
Patchnames:
openSUSE Leap 42.1 GA telepathy-gabble
openSUSE Leap 42.2
  • telepathy-gabble >= 0.18.3-4.5
Patchnames:
openSUSE Leap 42.2 GA telepathy-gabble
openSUSE Leap 42.3
  • telepathy-gabble >= 0.18.3-6.2
Patchnames:
openSUSE Leap 42.3 GA telepathy-gabble
openSUSE Tumbleweed
  • telepathy-gabble >= 0.18.3-1.10
  • telepathy-gabble-xmpp-console >= 0.18.3-1.10
Patchnames:
openSUSE Tumbleweed GA telepathy-gabble