Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-1431 at MITRE


The Wocky module in Telepathy Gabble before 0.16.6 and 0.17.x before 0.17.4, when connecting to a "legacy Jabber server," does not properly enforce the WockyConnector:tls-required flag, which allows remote attackers to bypass TLS verification and perform a man-in-the-middle attacks.

NVD CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

SUSE information

SUSE Bugzilla entry: 822586

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • telepathy-gabble >= 0.17.1-2.8.1
  • telepathy-gabble-debuginfo >= 0.17.1-2.8.1
  • telepathy-gabble-debugsource >= 0.17.1-2.8.1
  • telepathy-gabble-xmpp-console >= 0.17.1-2.8.1
  • telepathy-gabble-xmpp-console-debuginfo >= 0.17.1-2.8.1